Subject: Bug#1452: Issue with some GUI elements not being drawn

From: "Costanzo, Ian M." <[email-masked]>
Date: Wed, 1 Apr 2020 15:09:39 +0000

Package: x2go-client
Version: 4.1.2.2

Client Setup:
Manjaro Linux 19.0.2
x2go-client 4.1.2.2

Server setup:
CentOS Linux 7.7.1908 (Core)
x2goserver 4.1.0.3
x2goserver-xsession 4.1.0.3
NXagent 3.5.99.17c

Hello,

I have been experiencing an issue where some gui elements (dropdown menus or popup windows) are not being drawn. In some instances (dropdown menu) it is still navigable and submenus will (sometimes) be drawn. Other instances like pop-up menus are not accessible if not drawn. Checking application logs, it appears the window was successfully launched but the X server isn't drawing it? Not sure, any insight would be appreciated.

Regards,

Ian Costanzo

Electrical and Computer Engineering

Worcester Polytechnic Institute

[email-masked]

774-312-7019

---

From: Ulrich Sibiller <[email-masked]>
Date: Wed, 1 Apr 2020 17:16:54 +0200

Just to be sure: are you talking about the x2goclient window or about
application windows IN the session?

If it is within the session then the version nxagent becomes relevant.
You are using 3.5.99.17c (I don't know what "c" means here, we do not
use letters in our versions), but 3.5.99.23 is current. So please
update an re-test..

Uli

On Wed, Apr 1, 2020 at 5:10 PM Costanzo, Ian M. <[email-masked]> wrote:
> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> https://lists.x2go.org/listinfo/x2go-dev

---

From: "Costanzo, Ian M." <[email-masked]>
Date: Wed, 1 Apr 2020 15:21:06 +0000

Hi Uli,

Thanks for the swift response! I am talking about applications in the session, specifically Cadence Virtuoso. I will reach out to the admin to update the NX-agent to 3.5.99.23.

Also sorry about the email spam, the server kept saying I was submitting bugs incorrectly, so I kept trying following the directions here: https://wiki.x2go.org/doku.php/wiki:bugs

Thanks,
Ian
________________________________
From: Ulrich Sibiller <[email-masked]>
Sent: Wednesday, April 1, 2020 11:16
To: Costanzo, Ian M. <[email-masked]>; [email-masked] <[email-masked]>
Subject: [EXT] Re: [X2Go-Dev] Bug#1452: Issue with some GUI elements not being drawn

Uli

On Wed, Apr 1, 2020 at 5:10 PM Costanzo, Ian M. <[email-masked]> wrote:
> https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Flists.x2go.org%2Flistinfo%2Fx2go-dev&amp;data=02%7C01%7Cimcostanzo%40wpi.edu%7Ca549035a8da24e1a105d08d7d64fc651%7C589c76f5ca1541f9884b55ec15a0672a%7C0%7C0%7C637213510424114439&amp;sdata=v0eg5CegVGC%2Fk90tDnMuVdgGPcsPqGZARVy%2Fml3h97A%3D&amp;reserved=0