Subject: Bug#1445: pyhoca-cli fails to connect to suspended x2go session

From: Randy Goldenberg <[email-masked]>
Date: Fri, 6 Mar 2020 13:54:31 -0800

Package: pyhoca-cli
Version: 0.6.1.2
Tag: patch

pyhoca-cli fails to connect to suspended x2g0 sessions.

$ pyhoca-cli --server my.x2go.server -t desktop -c openbox-session -g maximize 
-R NEWEST

pyhoca-cli[13131] NOTICE: preparing requested X2Go session
pyhoca-cli[13131] (PyHocaCLI) NOTICE: preparing requested X2Go session
pyhoca-cli[13131] (x2gosessregistry-pylib) NOTICE: registering X2Go session 
Pyhoca-Client_Session...
pyhoca-cli[13131] (x2goclient-pylib) NOTICE: initializing X2Go session...
pyhoca-cli[13131] (x2gocontrolsession-pylib) NOTICE: connecting to 
[my.x2go.server]:22
/usr/lib/python3/dist-packages/Crypto/Cipher/blockalgo.py:141: FutureWarning: 
CTR mode needs counter parameter, not IV
 self._cipher = factory.new(key, *args, **kwargs)
pyhoca-cli[13131] (PyHocaCLI) NOTICE: authentication has been successful
pyhoca-cli[13131] (PyHocaCLI) NOTICE: give the X2Go session some time to come 
up...
Traceback (most recent call last):
 File "/usr/bin/pyhoca-cli", line 455, in <module>
   thisPyHocaCLI.MainLoop()
 File "/usr/lib/python3/dist-packages/pyhoca/cli/frontend.py", line 702, in 
MainLoop
   self.resume_session(self.x2go_session_hash)
 File "/usr/lib/python3/dist-packages/pyhoca/cli/frontend.py", line 229, in 
resume_session
   if available_sessions is None:
UnboundLocalError: local variable 'available_sessions' referenced before 
assignment

client OS: Ubuntu 16.04.6 LTS

server OS: Ubuntu 16.04.6 LTS

server's version of the x2goserver package:
x2goserver: 4.1.0.4
x2goserver-common: 4.1.0.4
x2goserver-desktopsharing: 4.1.0.3
x2goserver-extensions: 4.1.0.4
x2goserver-fmbindings: 4.1.0.4
x2goserver-printing: 4.1.0.4
x2goserver-xsession: 4.1.0.4

Patch attached.

----- End forwarded message -----
--- /usr/lib/python3/dist-packages/pyhoca/cli/frontend.py	2020-03-06 13:12:15.067076509 -0800
+++ /usr/lib/python3/dist-packages/pyhoca/cli/frontend.py.FIXED	2020-03-06 13:25:57.017743170 -0800
@@ -226,6 +226,7 @@
         """
         # resume a running session
         self.logger('resuming X2Go session: %s' % self.args.resume, loglevel=x2go.loglevel_INFO, )
+        available_sessions = self._X2GoClient__list_sessions(s_hash, with_command=self.args.command)
         if available_sessions is None:
             available_sessions = self._X2GoClient__list_sessions(s_hash)
         if available_sessions and self.args.resume == 'OLDEST':

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 11 Mar 2020 01:49:29 +0100 (CET)

tag #1445 pending
fixed #1445 0.6.1.3
thanks

Hi!

X2Go issue #1445 (src:pyhoca-cli) reported by you has been
fixed in X2Go Git. You can see the changelog below, and you can
check the diff of the fix at:

    https://code.x2go.org/gitweb?p=pyhoca-cli.git;a=commitdiff;h=2b507520a7b4984d7020a6d5153d29350a24a9a9

The issue will most likely be fixed in src:pyhoca-cli (0.6.1.3).

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
commit 2b507520a7b4984d7020a6d5153d29350a24a9a9
Author: Mike Gabriel <[email-masked]>
Date:   Wed Mar 11 01:49:07 2020 +0100

    pyhoca/cli/frontend.py: Fix reference before assignment error in resume_session() method. Thanks to Randy Goldenberg for spotting this. (Fixes: #1445).

diff --git a/debian/changelog b/debian/changelog
index e17aed8..f4e4f2d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,9 @@
 pyhoca-cli (0.6.1.3-0x2go1) UNRELEASED; urgency=medium
 
-  * Continue development
+  [ Mike Gabriel ]
+  * pyhoca/cli/frontend.py: Fix reference before assignment error in
+    resume_session() method. Thanks to Randy Goldenberg for spotting
+    this. (Fixes: #1445).
 
  -- X2Go Release Manager <[email-masked]>  Thu, 26 Dec 2019 17:03:42 +0100

---

From: X2Go Release Manager X2Go Release Manager <[email-masked]>
Date: Tue, 22 Aug 2023 08:51:31 +0200 (CEST)

close #1445
thanks

Hello,

we are very hopeful that X2Go issue #1445 reported by you
has been resolved in the new release (0.6.1.3) of the
X2Go source project »src:pyhoca-cli«.

You can view the complete changelog entry of src:pyhoca-cli (0.6.1.3)
below, and you can use the following link to view all the code changes
between this and the last release of src:pyhoca-cli.

    https://code.x2go.org/gitweb?p=pyhoca-cli.git;a=commitdiff;h=c6245eb5861acd4fa5ecedc9994b3549831b6b70;hp=071bd72d80d20a325613e38ed6296d2788dd65e5

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:pyhoca-cli.

Thanks a lot for contributing to X2Go!!!

light+love

---
X2Go Component: src:pyhoca-cli
Version: 0.6.1.3-0x2go1
Status: RELEASE
Timestamp: 1692686744
Date: Tue, 22 Aug 2023 08:45:44 +0200
Fixes: 1445
Changes:
 pyhoca-cli (0.6.1.3-0x2go1) RELEASED; urgency=medium
 .
   [ Mike Gabriel ]
   * New upstream release (0.6.1.3):
     - pyhoca/cli/frontend.py: Fix reference before assignment error in
       resume_session() method. Thanks to Randy Goldenberg for spotting
       this. (Fixes: #1445).
     - pyhoca-cli: Add cmdline parameter --dpi.
     - pyhoca-cli: Do input check on value passed in via the --link option.
     - pyhoca-cli: Add cmdline parameter --clipboard-mode.
     - pyhoca-cli: Follow-up fix for --dpi switch. Fix input value verification.
       Only demand an integer, if args.dpi is set to something else than None.
     - pyhoca-cli: Add --kdrive cmdline option.
     - pyhoca-cli.1 man page: Drop -d from --quiet documentation line.
     - Move --dpi cmdline option from X2Go options to NX options.
     - pyhoca-cli: Add cmdline option --list-cmdline-features. Required for
       Remmina X2Go Plugin.
     - pyhoca-cli: Write program version to STDOUT (not STDERR).
     - man/man1/pyhoca-cli.1: Add documentation for --list-cmdline-features.
     - pyhoca-cli: Don't try to immitate look_for_keys behaviour as implemented
       in the x2go Python module.
 .
   [ Daniel Teichmann ]
   * New upstream release (0.6.1.3):
     - pyhoca-cli: Print debug message before exiting pyhoca-cli.
     - Fix typo in man page.
     - Add --non-interactive cmdline option for forcefully preventing password
       queries on the TTY.
     - {pyhoca-cli, pyhoca/cli/frontend.py}: Only look for private ssh keys if
       appropriate.
     - pyhoca{-cli,/cli/frontend.py}: Add --ssh-passphrase feature.
 .
   [ Mihai Moldovan ]
   * New upstream version (0.6.1.3):
     - misc: pre-release copyright update.
     - man/man1/pyhoca-cli.1: pre-release date update.
     - misc: change http:// to https:// links where appropriate.
   * debian/control:
     + Change http:// to https:// links where appropriate.
   * debian/copyright:
     + Change http:// to https:// links where appropriate.
   * debian/watch:
     + Change http:// to https:// links where appropriate.
   * pyhoca-cli.spec:
     + Change http:// to https:// links where appropriate.
     + Drop Python 2 support for OpenSuSE Leap 15.4+ and Tumbleweed (and ALP).
     + Remove pycache handling from the files list. Python-2-variants don't
       have the concept of __pycache__ directories at all, so using
       %pycache_only there is redundant. Python-3-variants sprinkle __pycache__
       directories wherever there are .py files, which means that they are
       conveniently contained in the "pyhoca" subdirectory of sitelib. Older
       *SuSE versions, including Leap, just ignored files or directories in the
       %files list that do not exist, but Tumbleweed is throwing an error if
       you try to include a file or directory that does not exist. The fix is
       easy: don't try to include the non-existent __pycache__ top-level
       directory.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Tue, 22 Aug 2023 06:55:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the pyhoca-cli package:

#1445: pyhoca-cli fails to connect to suspended x2go session

It has been closed by X2Go Release Manager X2Go Release Manager <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact X2Go Release Manager X2Go Release Manager <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:pyhoca-cli) has been marked as closed
From: X2Go Release Manager X2Go Release Manager <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Tue, 22 Aug 2023 08:51:31 +0200 (CEST)

close #1445
thanks

Hello,

light+love

---

Subject: pyhoca-cli fails to connect to suspended x2go session
From: Randy Goldenberg <[email-masked]>
To: [email-masked]
Date: Fri, 6 Mar 2020 13:54:31 -0800

Package: pyhoca-cli
Version: 0.6.1.2
Tag: patch

Patch attached.