Subject: The reported issue has been fixed in NX (redistributed) 3.5.0.18

From: Mike Gabriel <[email-masked]>
Date: Sat, 23 Mar 2013 00:48:16 +0100

close #104
close #107
close #143
close #145
thanks

The reported issue has been fixed for release 3.5.0.18 of NX (redistributed).

light+love,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sat, 23 Mar 2013 00:03:03 +0000

This is an automatic notification regarding your Bug report
which was filed against the nx-libs package:

#143: nx-libs installs into wrong location

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: The reported issue has been fixed in NX (redistributed) 3.5.0.18
From: Mike Gabriel <[email-masked]>
To: [email-masked], [email-masked], [email-masked], [email-masked]
Cc: [email-masked]
Date: Sat, 23 Mar 2013 00:48:16 +0100

close #104
close #107
close #143
close #145
thanks

light+love,
Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: nx-libs installs into wrong location
From: Jan Engelhardt <[email-masked]>
To: [email-masked]
Date: Thu, 7 Mar 2013 18:25:24 +0100 (CET)

Package: nx-libs
Version: 3.5.0.17

Installation is done using

make install \
        INSTALL_DIR="install -dm0755" \
        INSTALL_FILE="install -pm0644" \
        INSTALL_PROGRAM="install -pm0755" \
        DESTDIR="/var/tmp/whatever" PREFIX="/usr" \
        NXLIBDIR="/usr/lib64/nx" X2GOLIBDIR="/usr/lib/x2go"

And at the end of the day, rpm notices the following broken link:

[  126s] ERROR: link target doesn't exist (neither in build root nor in
installed sys...
[  126s]   /usr/lib/x2go/bin/x2goagent -> /usr/lib/nx/bin/nxagent

This is because the top-level Makefile does a rather dumb command:

        cd $(DESTDIR)$(X2GOLIBDIR)/bin/ && ln -sf ../../nx/bin/nxagent 
x2goagent

so it creates a pointer to a non-existing target.