Subject: nx-libs installs into wrong location

From: Jan Engelhardt <[email-masked]>
Date: Thu, 7 Mar 2013 18:25:24 +0100 (CET)

Package: nx-libs
Version: 3.5.0.17

Installation is done using

make install \
        INSTALL_DIR="install -dm0755" \
        INSTALL_FILE="install -pm0644" \
        INSTALL_PROGRAM="install -pm0755" \
        DESTDIR="/var/tmp/whatever" PREFIX="/usr" \
        NXLIBDIR="/usr/lib64/nx" X2GOLIBDIR="/usr/lib/x2go"

And at the end of the day, rpm notices the following broken link:

[  126s] ERROR: link target doesn't exist (neither in build root nor in
installed sys...
[  126s]   /usr/lib/x2go/bin/x2goagent -> /usr/lib/nx/bin/nxagent

This is because the top-level Makefile does a rather dumb command:

        cd $(DESTDIR)$(X2GOLIBDIR)/bin/ && ln -sf ../../nx/bin/nxagent 
x2goagent

so it creates a pointer to a non-existing target.

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 07 Mar 2013 19:12:10 +0100

Hi Jan,

> so it creates a pointer to a non-existing target.

Thanks for submitting this bug. Any chance you can provide a patch?

Thanks,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Jan Engelhardt <[email-masked]>
Date: Thu, 7 Mar 2013 20:14:44 +0100 (CET)

> Thanks for submitting this bug. Any chance you can provide a patch?

This is getting above my head. I already had to endure the silent
introduction of the NXLIBDIR variable..
(it's really not fun if suddenly the entire filelist in .spec or whatever else
is worthless because USRLIBDIR and SHLIBDIR are no longer used)

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 22 Mar 2013 23:38:36 +0100

tag #143 pending
thanks

Hi Jan,

> is worthless because USRLIBDIR and SHLIBDIR are no longer used)

The issue should be solved by this commit:
http://code.x2go.org/gitweb?p=nx-libs.git;a=commitdiff;h=f81df1a69982fb3c4cfe13248dec1b8bc3fb66af

Thanks for reporting!
Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy: