Subject: Connection failed. Cannot create remote file

From: Alexanderstr Miete <[email-masked]>
Date: Sat, 14 Dec 2019 19:09:44 +0000

Package: <x2goserver>
Body:
Package: <x2goserver>
Version: <Not exactly sure where to check. Please let me know>
Not sure, if this is a real bug. But it seems to have been an issue
before (See here:
https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=227)

Surprisingly, without any known changes, we suddenly receive a new error
when establishing previously error free connections. The following error
appears in the client (similar to the one described here in 2014:
https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=227) , however the
connection is established as usual
without any apparent problems.

So why does this annoying error message appear and how can it be fixed?

*Connection failed. Cannot create remote file
~templatemate3/.x2go/ssh/key.TJ4977 - SCP: Warning: status code 1 received:
scp: ~templatemate3/.x2go/ssh: No such file or directory*
Let me know if you need any further info.

Client and Server running Ubuntu 18-04 LTS

 Thank you!

---

From: Mihai Moldovan <[email-masked]>
Date: Fri, 20 Dec 2019 00:21:07 +0100

* On 12/18/19 10:33 AM, Alexanderstr Miete wrote:
> Interesting. Thanks for the update. I also notice that no sound via standard
> PulseAudio (which previously worked) is transmitted to the client anymore from
> any remote machine (default port 4713, SSH port forwarding).  Is that related to
> this bug here too? https://bugs.launchpad.net/ubuntu/+source/libssh/+bug/1856795
> or something else that requires looking into?

Very likely, yes. We use scp to transfer some files (including the cookie file),
so if scp is broken within libssh that'll fail to work as well.

Mihai

---

From: Mihai Moldovan <[email-masked]>
Date: Fri, 20 Dec 2019 20:32:49 +0100 (CET)

tag #1428 pending
fixed #1428 4.1.2.2
thanks

Hello,

X2Go issue #1428 (src:x2goclient) reported by you has been
fixed in X2Go Git. You can see the changelog below, and you can
check the diff of the fix at:

    http://code.x2go.org/gitweb?p=x2goclient.git;a=commitdiff;h=ce559d1

The issue will most likely be fixed in src:x2goclient (4.1.2.2).

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
commit ce559d163a943737fe4160f7233925df2eee1f9a
Author: Mihai Moldovan <[email-masked]>
Date:   Fri Dec 20 20:27:31 2019 +0100

    src/sshprocess.cpp: strip ~/, ~user{,/}, ${HOME}{,/} and $HOME{,/} from destination paths in scp mode. Fixes: #1428.
    
    This was already necessary for pascp (PuTTY-based Windows solution for
    Kerberos support), but newer libssh versions with the CVE-2019-14889
    also interpret paths as literal strings.

diff --git a/debian/changelog b/debian/changelog
index 504d6ae..9f84281 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -135,6 +135,11 @@ x2goclient (4.1.2.2-0x2go1) UNRELEASED; urgency=medium
       sound weird first, but this behavior is consistent between all
       applications - tray icons can be clicked via either button and will
       always trigger a context menu. Let X2Go Client behave the same way.
+    - src/sshprocess.cpp: strip ~/, ~user{,/}, ${HOME}{,/} and $HOME{,/} from
+      destination paths in scp mode. Fixes: #1428. This was already necessary
+      for pascp (PuTTY-based Windows solution for Kerberos support), but newer
+      libssh versions with the CVE-2019-14889 also interpret paths as literal
+      strings.
   * debian/control:
     + Add build-depend on pkg-config.
   * x2goclient.spec:

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 25 Dec 2019 20:22:18 +0000

Hi,

On  Fr 20 Dez 2019 20:32:49 CET, Mihai Moldovan wrote:

>     src/sshprocess.cpp: strip ~/, ~user{,/}, ${HOME}{,/} and  
> $HOME{,/} from destination paths in scp mode. Fixes: #1428.
>

Please note that I am currently working on getting this  
libssh/CVE-2019-14889 robustness patch into Debian [done] and Ubuntu  
[pending].

Mike
-- 

DAS-NETZWERKTEAM
c\o Technik- und Ökologiezentrum Eckernförde
Mike Gabriel, Marienthaler str. 17, 24340 Eckernförde
mobile: +49 (1520) 1976 148
landline: +49 (4351) 850 8940

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de

---

From: [email-masked]
Date: Wed, 25 Dec 2019 22:43:10 +0100

Hallo Mike,
wie siehts mit der Fehlfunktion der Tonübertragung unter Win 10 nach dem großen Update aus?
Die Fehlermeldung, die ich geposted habe, scheint darauf zu beruhen, dass Pulseaudio kein sicheres Verzeichnis anlegen kann.
Konntest Du das Problem auch lösen?
LG Daniel

Hi Mike could you also find a workaround for the pulseaudio issue on latest Win 10 ?
Sound does not work in X2Go because Pulseaudio can't create a safe directory. 
Yours Daniel
(I am no expert and need to use the win binary, but the nightly build before christmas still didn't work).

Sent from MailDroid

-----Original Message-----
From: Mike Gabriel <[email-masked]>
To: Mihai Moldovan <[email-masked]>, [email-masked]
Cc: [email-masked], [email-masked]
Sent: Mi., 25 Dez. 2019 21:25
Subject: [X2Go-Dev] Bug#1428: Bug#1428: X2Go issue (in src:x2goclient) has been marked as pending for release

Hi,

Mike
-- 

DAS-NETZWERKTEAM