X2Go Bug report logs - #1427
Update Tumbleweed packages for Perl 5.30

version graph

Package: x2goserver; Maintainer for x2goserver is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goserver is src:x2goserver.

Reported by: Tristan Miller <psychonaut@nothingisreal.com>

Date: Wed, 11 Dec 2019 21:05:03 UTC

Severity: normal

Tags: rpm-packages

Found in version 4.1.0.4

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1427: Update Tumbleweed packages for Perl 5.30
Reply-To: Tristan Miller <psychonaut@nothingisreal.com>, 1427@bugs.x2go.org
Resent-From: Tristan Miller <psychonaut@nothingisreal.com>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Wed, 11 Dec 2019 21:05:03 +0000
Resent-Message-ID: <handler.1427.B.15760981727862@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: report 1427
X-X2Go-PR-Package: x2goserver
X-X2Go-PR-Keywords: rpm-packages
Received: via spool by submit@bugs.x2go.org id=B.15760981727862
          (code B); Wed, 11 Dec 2019 21:05:03 +0000
Received: (at submit) by bugs.x2go.org; 11 Dec 2019 21:02:52 +0000
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-0.5 required=3.0 tests=BAYES_05,SPF_HELO_PASS
	autolearn=ham autolearn_force=no version=3.4.2
Received: from balrog.mythic-beasts.com (balrog.mythic-beasts.com [IPv6:2a00:1098:0:82:1000:0:2:1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id ABF675DAEA
	for <submit@bugs.x2go.org>; Wed, 11 Dec 2019 22:02:48 +0100 (CET)
Received: from [84.114.224.132] (port=42792 helo=butterfield.nothingisreal.com)
	by balrog.mythic-beasts.com with esmtpa (Exim 4.92.3)
	(envelope-from <psychonaut@nothingisreal.com>)
	id 1if988-0001EV-3k
	for submit@bugs.x2go.org; Wed, 11 Dec 2019 21:02:48 +0000
Received: from pi.nothingisreal.com (localhost [IPv6:::1])
	by butterfield.nothingisreal.com (Postfix) with ESMTP id BCFEE1236D
	for <submit@bugs.x2go.org>; Wed, 11 Dec 2019 22:02:42 +0100 (CET)
Date: Wed, 11 Dec 2019 22:02:38 +0100
From: Tristan Miller <psychonaut@nothingisreal.com>
To: submit@bugs.x2go.org
Message-ID: <20191211220238.3841f18c.psychonaut@nothingisreal.com>
Organization: https://logological.org/
X-Mailer: Claws Mail 3.17.4 (GTK+ 2.24.32; x86_64-suse-linux-gnu)
MIME-Version: 1.0
Content-Type: multipart/signed; boundary="Sig_/tc1q=JCjMT5OOD4HeQi7r0j";
 protocol="application/pgp-signature"; micalg=pgp-sha512
X-BlackCat-Spam-Score: -10
[Message part 1 (text/plain, inline)]
Package: x2goserver
Version: 4.1.0.4
Tags: rpm-packages

Various openSUSE Tumbleweed packages for the X2Go server are built in
such a way that they require Perl 5.28.1. However, Tumbleweed no longer
distributes that version of Perl; it now distributes only Perl 5.30.1.
This means that it is impossible to install these X2Go server packages
on the most recent release of Tumbleweed, and for Tumbleweed systems
where those X2Go server packages were already installed, it is
impossible to upgrade Tumbleweed without removing the X2Go server:

$ sudo zypper dup
[sudo] password for root: 
Loading repository data...
Reading installed packages...
Warning: You are about to do a distribution upgrade with all enabled
repositories. Make sure these repositories are compatible before you
continue. See 'man zypper' for more information about this command.
Computing distribution upgrade...
9 Problems:
Problem:
x2goserver-common-4.1.0.4-0.0x2go1.0.git20191106.1811.heuler.x86_64
requires perl(:MODULE_COMPAT_5.28.1), but this requirement cannot be
provided
Problem: perl-5.28.1-3.4.x86_64 requires perl-base = 5.28.1,
but this requirement cannot be provided
Problem:
perl-X2Go-Server-DB-4.1.0.4-0.0x2go1.0.git20191106.1811.heuler.x86_64
requires perl(:MODULE_COMPAT_5.28.1), but this requirement cannot be
provided
Problem:
perl-X2Go-Server-4.1.0.4-0.0x2go1.0.git20191106.1811.heuler.x86_64
requires perl(:MODULE_COMPAT_5.28.1), but this requirement cannot be
provided
Problem:
perl-X2Go-Log-4.1.0.4-0.0x2go1.0.git20191106.1811.heuler.x86_64
requires perl(:MODULE_COMPAT_5.28.1), but this requirement cannot be
provided
Problem:
x2goserver-4.1.0.4-0.0x2go1.0.git20191106.1811.heuler.x86_64 requires
perl(:MODULE_COMPAT_5.28.1), but this requirement cannot be provided

Simply telling zypper to keep the obsolete packages doesn't work as
this ends up in a rabbit-hole of seemingly irresolvable dependency
issues.
[Message part 2 (application/pgp-signature, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Jul 14 21:08:05 2020; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.