Subject: X2Goclient crashes on plasma on Wayland, on plasma on xorg it works fine

From: Kay Nick <[email-masked]>
Date: Mon, 4 Nov 2019 18:27:43 +0100

Package: x2goclient

Version 4.1.2.1

How to reproduce:

started on command line: plasma on xorg:

[ml@carbon ~]$ x2goclient
x2go-INFO-1> "Starting X2Go Client 4.1.2.1..."
x2go-INFO-4> "Translator: :/i18n/x2goclient_de_de found."
x2go-INFO-4> "Übersetzung: :/i18n/qt_de_de gefunden."
QObject::connect: No such slot ONMainWindow::slotCheckAgentProcess()
x2go-INFO-3> "X2GoClient wurde gestartet."
x2go-INFO-8> "Verbindung mit Server wird gestartet: thor.xx.yyy.de:22"
x2go-INFO-6> "X2GoClient wird geschlossen ..."
QProcess: Destroyed while process ("nxproxy") is still running.
x2go-INFO-7> "Alle Hooks, die beim Beenden von X2GoClient abgearbeitet
werden sollten, wurden abgearbeitet."

started on command line: plasma on wayland:

[ml@carbon ~]$ x2goclient
x2go-INFO-1> "Starting X2Go Client 4.1.2.1..."
x2go-INFO-4> "Translator: :/i18n/x2goclient_de_de found."
x2go-INFO-4> "Übersetzung: :/i18n/qt_de_de gefunden."
QObject::connect: No such slot ONMainWindow::slotCheckAgentProcess()
x2go-INFO-3> "X2GoClient wurde gestartet."
x2go-INFO-8> "Verbindung mit Server wird gestartet: thor.xx.yyy.de:22"
Speicherzugriffsfehler (Speicherabzug geschrieben)

The client machine's OS: Manjaro Linux 64 bit

The client machine's version of X2GoClient: X2GoClient V. 4.1.2.1 (Qt -
5.13.1)

The server's OS: CentOS 7.7 64 Bit

The server's version of the x2goserver package 4.1.0.3

---

From: Orion Poplawski <[email-masked]>
Date: Fri, 13 Dec 2019 19:25:53 -0700

> The server's version of the x2goserver package 4.1.0.3

Tags: patch

See also https://bugzilla.redhat.com/show_bug.cgi?id=1756430#c2

https://wiki.archlinux.org/index.php/X2Go#X2Go_client:_Cannot_connect_to_remote_X2Go_server_from_local_Wayland_session:_%22The_connection_with_the_remote_server_was_shut_down%22

 From b53b8d654c73420fc5cc12e42717ac75a824c974 Mon Sep 17 00:00:00 2001
From: Orion Poplawski <[email-masked]>
Date: Fri, 13 Dec 2019 19:22:13 -0700
Subject: [PATCH] Select X11 backend on wayland

---
  desktop/x2goclient.desktop | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/desktop/x2goclient.desktop b/desktop/x2goclient.desktop
index fbb396d..eeb7c7b 100644
--- a/desktop/x2goclient.desktop
+++ b/desktop/x2goclient.desktop
@@ -2,7 +2,7 @@
  Version=1.0
  Type=Application
  Name=X2Go Client
-Exec=x2goclient
+Exec=env QT_QPA_PLATFORM=xcb x2goclient
  Icon=x2goclient
  StartupWMClass=x2goclient
  X-Window-Icon=x2goclient
--
1.8.3.1

-- 
Orion Poplawski
Manager of NWRA Technical Systems          720-772-5637
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                 https://www.nwra.com/

---

From: Orion Poplawski <[email-masked]>
Date: Fri, 13 Dec 2019 21:02:33 -0700

On 12/13/19 7:25 PM, Orion Poplawski wrote:
>> The client machine's version of X2GoClient: X2GoClient V. 4.1.2.1 (Qt 
>> - 5.13.1)
>>

Of course, this won't help launching from the command line.  Not sure 
how to handle that.