X2Go Bug report logs - #139
x2goclient OS X: password input not working on second connect or in broker-mode

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Anders Bruun Olsen <abo@dsl.dk>

Date: Wed, 6 Mar 2013 09:48:02 UTC

Severity: important

Tags: pending

Merged with 260, 284

Found in versions 4.0.0.4, 4.0.1.1, 4.0.1.0

Fixed in version 4.0.1.2

Done: Mike Gabriel <mike.gabriel@das-netzwerkteam.de>

Bug is archived. No further changes may be made.

Full log


🔗 View this message in rfc822 format

X-Loop: git-admin@x2go.org
Subject: Bug#139: x2goclient: No keyboard input at login in broker-mode on OSX
Reply-To: Anders Bruun Olsen <abo@dsl.dk>, 139@bugs.x2go.org
Resent-From: Anders Bruun Olsen <abo@dsl.dk>
Resent-To: x2go-dev@lists.berlios.de
Resent-CC: X2Go Developers <x2go-dev@lists.berlios.de>
X-Loop: git-admin@x2go.org
Resent-Date: Wed, 06 Mar 2013 09:48:02 +0000
Resent-Message-ID: <handler.139.B.136256261032262@bugs.x2go.org>
Resent-Sender: git-admin@x2go.org
X-X2Go-PR-Message: report 139
X-X2Go-PR-Package: x2goclient
X-X2Go-PR-Keywords: 
Received: via spool by submit@bugs.x2go.org id=B.136256261032262
          (code B); Wed, 06 Mar 2013 09:48:02 +0000
Received: (at submit) by bugs.x2go.org; 6 Mar 2013 09:36:50 +0000
Received: from eu1sys200aog111.obsmtp.com (eu1sys200aog111.obsmtp.com [207.126.144.131])
	by ymir (Postfix) with SMTP id D84F15DB0D
	for <submit@bugs.x2go.org>; Wed,  6 Mar 2013 10:36:49 +0100 (CET)
Received: from mail-oa0-f72.google.com ([209.85.219.72]) (using TLSv1) by eu1sys200aob111.postini.com ([207.126.147.11]) with SMTP
	ID DSNKUTcOMcvHcmskKYB5Iv8Q1Vw/J3nlPSXd@postini.com; Wed, 06 Mar 2013 09:36:50 UTC
Received: by mail-oa0-f72.google.com with SMTP id j6so48214931oag.3
        for <submit@bugs.x2go.org>; Wed, 06 Mar 2013 01:36:48 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=dsl.dk; s=google;
        h=x-received:mime-version:x-received:date:message-id:subject:from:to
         :content-type;
        bh=RC2yVdlRl68JDdvxgCOsh8+gtbPFHTjFX6lfA49Y/0Q=;
        b=gezH/UJGRaL7wsono4aeCaKHe696fLhvfQK+USUqQyvHB+3QmCvhySShuCXQpinxtR
         JQk9MVheGncOE7D/HJJsCB1MPqUPBOKOWDbKID1RPGR8s24M/grvR8S1FAAAVEsrLiNS
         Jvjm0Uaaj2Soqsyipw98KacuK3TMzLP+LCkmk=
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=google.com; s=20120113;
        h=x-received:mime-version:x-received:date:message-id:subject:from:to
         :content-type:x-gm-message-state;
        bh=RC2yVdlRl68JDdvxgCOsh8+gtbPFHTjFX6lfA49Y/0Q=;
        b=Du0FMkV5NRfZqxAIf6ITyFtiiUi2tpavvczOlFniZebucejVJhBwvZHO0ob3r98Ir0
         Jw2bj78xUqZv77pzAbylRY4nNCSic6ayVPaiPIbhQuyu4PBd6Gz6o+9D3zVYB01ts19X
         zeLw923ak0AEbfmvv1pKX/Gxnu5SK5927rRUQ692myLK7o+TRL43IaDvXDF6oJlT1Uvm
         UT5I6jTBU+0Hreq4BPYNR9aj43l4OSFs97pAnO9RD8rrg5jRHbYS5Rp2wODxCH/Im5jd
         WbG0PhtRurGA2WIz7A+MTNRA9PvC+JYAFMLNYyZPfkH3zqWCp9YtSVDuyAk81Pb+EAK9
         OROA==
X-Received: by 10.60.13.1 with SMTP id d1mr22295460oec.55.1362562608557;
        Wed, 06 Mar 2013 01:36:48 -0800 (PST)
MIME-Version: 1.0
X-Received: by 10.60.13.1 with SMTP id d1mr22295452oec.55.1362562608302; Wed,
 06 Mar 2013 01:36:48 -0800 (PST)
Received: by 10.182.95.211 with HTTP; Wed, 6 Mar 2013 01:36:48 -0800 (PST)
Date: Wed, 6 Mar 2013 10:36:48 +0100
Message-ID: <CAFJm-UPJtAmHECoZy8BiVANco0JAXe2LyxLsMJPVfFHxCQZevQ@mail.gmail.com>
From: Anders Bruun Olsen <abo@dsl.dk>
To: submit@bugs.x2go.org
Content-Type: multipart/alternative; boundary=e89a8ff2500840f14404d73e54f3
X-Gm-Message-State: ALoCoQkKnDjF/xT/e1ZcKopf8ZTAb9umCA421+W55znhykPURhN5vL6zbYzC9+WGhYZJ+6q1Tf1vzM/1odcXpRk2Juz0d/6yWcUnP6LXoLKjG67tlWbMr5kn3+p5YTS90wYFhx6hNDb1Z7mquU2B+AE+x0d2M9Zx7Q==
[Message part 1 (text/plain, inline)]
Package: x2goclient
Version: 4.0.0.4
Severity: grave

The newly released version of x2goclient for Mac OSX is unusable when used
in broker-mode.
When started with --broker-url a dialog pops up handling authentication
against the broker. After this is done, you choose a session. This next
authentication dialog is the problem. The cursor is placed in the
login-field and is blinking, but nothing appears when keys are pressed on
the keyboard. The system bell (*dunk*) is chimed upon each keystroke.
Clicking in the field does not change anything. You can place focus in the
password field, but no input happens here either.

I have also tried setting the broker in noauth mode, so auth is only needed
when connecting to the actual terminal servers. The problem is also present
here. No initial auth dialog is displayed (of course), but when a session
is chosen, the auth dialog will not accept any input.

-- 
Anders Bruun Olsen
It-ansvarlig
Det Danske Sprog- og Litteraturselskab
(Society for Danish Language and Literature)
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Fri Dec 13 22:00:09 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.