Subject: X2Go issue (in src:x2gothinclient) has been marked as closed

From: X2Go Release Manager <[email-masked]>
Date: Fri, 29 Nov 2019 04:19:07 +0100 (CET)

close #1364
thanks

Hello,

we are very hopeful that X2Go issue #1364 reported by you
has been resolved in the new release (1.5.0.1) of the
X2Go source project »src:x2gothinclient«.

You can view the complete changelog entry of src:x2gothinclient (1.5.0.1)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2gothinclient.

    http://code.x2go.org/gitweb?p=x2gothinclient.git;a=commitdiff;h=47dc574d21fad5d288dd727f3f87681ca3c670da;hp=1710b77043664388d673d9f89630ad274ab2110b

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2gothinclient.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2gothinclient
Version: 1.5.0.1-0x2go2
Status: RELEASE
Timestamp: 1574997407
Date: Fri, 29 Nov 2019 04:16:47 +0100
Fixes: 1364
Changes:
 x2gothinclient (1.5.0.1-0x2go2) RELEASED; urgency=medium
 .
   [ Mihai Moldovan ]
   * New upstream release (1.5.0.1):
     - management/etc/x2gothinclient_settings: remove heuler from apt line.
     - management/etc/x2gothinclient_settings: add "extras" component.
     - misc: update copyright notices.
     - misc manpages: pre-release version and date updates.
   * usbmount/x2gousbmount:
     - Whitespace- and comment-only changes.
     - Rework x2gothinclientd check.
     - Remove uni_xlate from ntfs and vfat mounts, add utf8 option to vfat
       mounts and document this choice.
   * debian/control:
     + Add hicolor-icon-theme as an alternative to nuvola-icon-theme.
     + Replace lightdm dependency with nodm for now. This breaks MMD! Nodm is a
       bad choice in general, but lightdm has "dependency problems" (requires a
       package that provides the logind virtual package) and is apparently "too
       big". However, nodm is stale software and upstream considered replacing
       it with a lightdm wrapper, so let's see where that gets us...
 .
   [ Stefan Baur ]
   * New upstream release (1.5.0.1):
   * usbmount/x2gousbmount:
     - Pull (most) changes from doc:howto:tce wiki page.
 .
   [ Mike Gabriel ]
   * New upstream release (1.5.0.1):
     - 19_x2gothinclient-minidesktop.gschema.override: Explicitly use MATE-
       specific theming of the desktop UI. (Fixes: #1364).
     - Install minidesktop's background SVG to DATADIR and symlink to it in
       ETCDIR.
     - Provide empty/dummy FreeRDPv2 known_hosts2 file if not
       already there.
     - management/share/etc/x2gothinclient_init.d/010_x2gothinclient-fresh-home:
       Make X2Go Client desktop link executable, so that it becomes a real
       desktop link.
     - minidesktop/init/: Drop init script for mini desktop variant. Always been
       a no-op script.
     - Provide systemd service files for x2gothinclient-cdmanager and
       x2gothinclient-displaymanager.
     - init scripts: Use /run rather than /var/run for placing PID files.
     - minidesktop: Rename LTSP display manager override script to 88-... (from
       60-...). As suggested by Alkis Georgopoulos.
   * debian/rules:
     + Convert to pure debhelper rules file.
     + Remove Qt5 build cruft from cdmanager/powerej/.
   * debian/control:
     + Prefer lightdm over nodm for the minidesktop variant. With lightdm
       the minidesktop is set-up out of the box.
     + Add Rules-Requires-Root: field and set it to "no".
     + Bump Standards-Version: to 4.4.1. No changes needed.
     + Don't use first person plural pronoun in LONG_DESCRIPTION.
     + Add D (any bin:pkg reported by lintian): lsb-base.
   * debian/{control,x2gothinclient.<scripts>}:
     + Drop all transitional packages.
   * debian/x2gothinclient-minidesktop.init:
     + Drop init script, never had functionality.
   * debian/x2gothinclient-*.serivce:
     + Symlink to upstream files.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Fri, 29 Nov 2019 03:20:03 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2gothinclient-minidesktop package:

#1364: MATE-Theming fails for x2gothinclient-minidesktop when installed on Debian Stretch

It has been closed by X2Go Release Manager <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact X2Go Release Manager <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2gothinclient) has been marked as closed
From: X2Go Release Manager <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Fri, 29 Nov 2019 04:19:07 +0100 (CET)

close #1364
thanks

Hello,

light+love

---

Subject: MATE-Theming fails for x2gothinclient-minidesktop when installed on Debian Stretch
From: Stefan Baur <[email-masked]>
To: [email-masked]
Date: Thu, 17 Jan 2019 01:57:34 +0100

package: x2gothinclient-minidesktop

This package contains a file
"/usr/share/glib-2.0/schemas/19_x2gothinclient-minidesktop.gschema.override",
however, according to Mike#1/sunweaver, the themes listed in there are
the wrong ones for a GTK-3 based MATE, thus theming fails, which results
in the Start button displaying the Gnome Foot instead of the MATE logo.

On Debian Jessie (oldstable), MATE is based on GTK-2, and thus it works
fine there.  However, it needs to be changed for Debian Stretch.

Kind Regards,
Stefan Baur

-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243