Subject: Bug#1361: Fwd: [Bug 1665366] New: Cannot run AttributeError: module 'wx' has no attribute 'TaskBarIcon'

From: Orion Poplawski <[email-masked]>
Date: Fri, 11 Jan 2019 10:02:25 -0700

Package: pyhoca-gui

-------- Forwarded Message --------
Subject: [Bug 1665366] New: Cannot run AttributeError: module 'wx' has 
no attribute 'TaskBarIcon'
Date: Fri, 11 Jan 2019 07:15:55 +0000
From: [email-masked]
To: [email-masked]

https://bugzilla.redhat.com/show_bug.cgi?id=1665366

             Bug ID: 1665366
            Summary: Cannot run AttributeError: module 'wx' has no
                     attribute 'TaskBarIcon'
            Product: Fedora
            Version: 29
           Hardware: x86_64
                 OS: Linux
             Status: NEW
          Component: pyhoca-gui
           Severity: high
           Assignee: [email-masked]
           Reporter: [email-masked]
         QA Contact: [email-masked]
                 CC: [email-masked]
   Target Milestone: ---
     Classification: Fedora

Description of problem:
Cannot execute puhoca-gui application because of the changes in wxpython4 -
wx.TaskBarIcon is moved to wx.adv.TaskBarIcon

Version-Release number of selected component (if applicable):
pyhoca-gui-0.5.0.7-6.fc29.noarch
python3-cups-1.9.72-22.fc29.x86_64
python3-setproctitle-1.1.10-9.fc29.x86_64
python3-gobject-base-3.30.4-1.fc29.x86_64
python3-wxpython4-4.0.1-9.fc29.x86_64
python3-x2go-0.6.0.2-1.fc29.noarch

How reproducible:
run pyhoca-gui

Steps to Reproduce:
1. Open command line
2. run pyhoca-gui

Actual results:
Traceback (most recent call last):
   File "/usr/bin/pyhoca-gui", line 35, in <module>
     from pyhoca.wxgui.launcher import PyHocaGUI_Launcher
   File "/usr/lib/python3.7/site-packages/pyhoca/wxgui/launcher.py", 
line 44, in
<module>
     from .frontend import PyHocaGUI
   File "/usr/lib/python3.7/site-packages/pyhoca/wxgui/frontend.py", 
line 42, in
<module>
     from . import taskbar
   File "/usr/lib/python3.7/site-packages/pyhoca/wxgui/taskbar.py", line 
83, in
<module>
     class PyHocaGUI_TaskBarIcon(wx.TaskBarIcon):
AttributeError: module 'wx' has no attribute 'TaskBarIcon'

Expected results:
executed

-- 
You are receiving this mail because:
You are on the CC list for the bug.
You are the assignee for the bug.

---

From: Orion Poplawski <[email-masked]>
Date: Mon, 20 Jan 2020 20:32:42 -0700

I still have no idea how to address this.

-------- Forwarded Message --------
Subject: [Bug 1793077] New: Cannot execute puhoca-gui application, it 
crashes with error message "AttributeError: module 'wx' has no attribute 
'TaskBarIcon'"
Date: Mon, 20 Jan 2020 15:57:49 +0000
From: [email-masked]
To: [email-masked]

https://bugzilla.redhat.com/show_bug.cgi?id=1793077

             Bug ID: 1793077
            Summary: Cannot execute puhoca-gui application, it crashes with
                     error message "AttributeError: module 'wx' has no
                     attribute 'TaskBarIcon'"
            Product: Fedora
            Version: 31
             Status: NEW
          Component: pyhoca-gui
           Assignee: [email-masked]
           Reporter: [email-masked]
         QA Contact: [email-masked]
                 CC: [email-masked]
   Target Milestone: ---
     Classification: Fedora

Description of problem:

Version-Release number of selected component (if applicable):
  python3-wx-siplib-4.19.19-1.fc31.x86_64
  python3-x2go-0.6.1.1-1.fc31.noarch
  nx-libs-3.5.99.20-2.fc31.x86_64
  libXcomp-3.5.99.20-2.fc31.x86_64  python3-bcrypt-3.1.6-3.fc31.x86_64
  nxproxy-3.5.99.20-2.fc31.x86_64
  python3-greenlet-0.4.14-3.fc31.x86_64
  python3-paramiko-2.6.0-2.fc31.noarch
  python3-pynacl-1.3.0-2.fc31.x86_64
  python3-setproctitle-1.1.10-14.fc31.x86_64
  python3-simplejson-3.16.0-3.fc31.x86_64
  python3-gevent-1.3.6-5.fc31.x86_64
  python3-xlib-0.23-5.fc31.noarch
  wxGTK3-3.0.4-10.fc31.x86_64
  wxGTK3-gl-3.0.4-10.fc31.x86_64
  python3-wxpython4-4.0.6-8.fc31.x86_64
  pyhoca-gui-0.5.1.0-1.fc31

How reproducible:
  Each time i run pyhoca-gui it happens

Steps to Reproduce:
1. open a shell 2. run pyhoca-gui
3.

Actual results:
pyhoca-gui Traceback (most recent call last):
   File "/usr/bin/pyhoca-gui", line 39, in <module>
     from pyhoca.wxgui.launcher import PyHocaGUI_Launcher
   File "/usr/lib/python3.7/site-packages/pyhoca/wxgui/launcher.py", 
line 45, in
<module>
     from .frontend import PyHocaGUI
   File "/usr/lib/python3.7/site-packages/pyhoca/wxgui/frontend.py", 
line 43, in
<module>
     from . import taskbar
   File "/usr/lib/python3.7/site-packages/pyhoca/wxgui/taskbar.py", line 
84, in
<module>
     class PyHocaGUI_TaskBarIcon(wx.TaskBarIcon):
AttributeError: module 'wx' has no attribute 'TaskBarIcon'

Expected results:
   Open PyHoca window to connect to X2go server

Additional info:

---

From: Mike Gabriel <[email-masked]>
Date: Tue, 21 Jan 2020 09:17:53 +0000

Hi Orion,

On  Di 21 Jan 2020 04:32:42 CET, Orion Poplawski wrote:

> Subject: [Bug 1793077] New: Cannot execute puhoca-gui application,  
> it crashes with error message "AttributeError: module 'wx' has no  
> attribute 'TaskBarIcon'"

https://code.x2go.org/gitweb?p=pyhoca-gui.git;a=commitdiff;h=fa352bca6b3e422af069a8a258235351a0626f36

Packages the latest upstream (0.6.1.1). It should fully work under  
wxGTK 4.0 and Python3. It also should still work on Python2 and wxGTK  
2.x/3.0, if needed.

Mike
-- 

DAS-NETZWERKTEAM
c\o Technik- und Ökologiezentrum Eckernförde
Mike Gabriel, Marienthaler str. 17, 24340 Eckernförde
mobile: +49 (1520) 1976 148
landline: +49 (4351) 850 8940

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de

---

From: Orion Poplawski <[email-masked]>
Date: Thu, 30 Jan 2020 18:00:56 -0700

On 1/21/20 2:17 AM, Mike Gabriel wrote:
> 
> Packages the latest upstream (0.6.1.1). It should fully work under wxGTK 
> 4.0 and Python3. It also should still work on Python2 and wxGTK 2.x/3.0, 
> if needed.

Thanks.  Shall we close this bug then?

-- 
Orion Poplawski
Manager of NWRA Technical Systems          720-772-5637
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                 https://www.nwra.com/