Subject: Bug#1349: x2goclient not connecting after upgrade

From: Javier Almasoft <[email-masked]>
Date: Mon, 26 Nov 2018 08:52:15 +0100

Package: x2goclient
Version: 4.1.2.1-3
x2goclient fails to connect to a working xgoserver, no matter the
server version.

The client machine is Archlinux 64, upgraded to the latest  version
(as of yesterday).

I have downloaded and compiled from git the x2goclient sourcecode, but
this compiled version don't work
either.

This is the log generated by x2goclient:

---------------------------------------------------------------------------------------------
Copyright (c) 2014-2016 Mihai Moldovan <[email-masked]>
Copyright (c) 2011-2016 Mike Gabriel <[email-masked]>
Copyright (c) 2015-2016 Qindel Group (http://www.qindel.com)

NXCOMP, NX protocol compression and NX extensions to this software
are copyright of the aforementioned persons and companies.

Redistribution and use of the present software is allowed according
to terms specified in the file LICENSE.nxcomp which comes in the
source distribution.

All rights reserved.

NOTE: This software has received contributions from various other
contributors, only the core maintainers and supporters are listed as
copyright holders. Please contact us, if you feel you should be listed
as copyright holder, as well.

NX protocol compression is derived from DXPC project.

Copyright (c) 1995,1996 Brian Pane
Copyright (c) 1996,1997 Zachary Vonler and Brian Pane
Copyright (c) 1999 Kevin Vigor and Brian Pane
Copyright (c) 2000,2003 Gian Filippo Pinzari and Brian Pane

All rights reserved.

See https://github.com/ArcticaProject/nx-libs for more information.

Info: Proxy running in server mode with pid '14626'.
Session: Starting session at 'Fri Nov 23 13:26:45 2018'.
Info: Using errors file
'/home/xxxxx/.x2go/S-xxxxxxx-50-1542975996_stDLXDE_dp24/sessions'.
Info: Using stats file '/home/xxxxx/.x2go/S-50/stats'.
Loop: WARNING! Overriding auxiliary X11 port with new value '1'.
Warning: Overriding auxiliary X11 port with new value '1'.
Info: Using abstract X11 socket in kernel namespace for accessing DISPLAY=:0.
Info: Connecting to remote host 'localhost:31001'.
Info: Connected to remote proxy on FD#5.
Loop: PANIC! Parse error in remote options string 'SSH-2.0-OpenSSH_6.7p1 '.
Error: Parse error in remote options string 'SSH-2.0-OpenSSH_6.7p1 '.
Loop: PANIC! Failure negotiating the session in stage '7'.
Error: Failure negotiating the session in stage '7'.
Loop: PANIC! Wrong version or invalid session authentication cookie.
Error: Wrong version or invalid session authentication cookie.
Session: Terminating session at 'Fri Nov 23 13:26:45 2018'.

Versions of the relevant packages:

nx3-all 3.5.0-4
nxproxy 3.5.99.16-2
x2goclient 4.1.2.1-3
libssh 0.8.5-1
libssh2 1.8.0-3
openssh 7.9p1-1
qt4 4.8.7-26

I can ssh the remote machines without problem, and pyhoca-cli also
works correctly.

Greetings,
Javier Martínez

---

From: Ulrich Sibiller <[email-masked]>
Date: Thu, 3 Jan 2019 10:16:30 +0100

Hmm, looks like a bug in your client side libssh. Can you try to downgrade
it?

Uli

Am Do., 3. Jan. 2019, 08:28 hat Javier Almasoft <[email-masked]>
geschrieben:

> Package: x2goclient
> Version: 4.1.2.1-3
> x2goclient fails to connect to a working xgoserver, no matter the server version.
>
> The client machine is Archlinux 64, upgraded to the latest  version (as of yesterday).
>
> I have downloaded and compiled from git the x2goclient sourcecode, but this compiled version don't work
> either.
>
> Info: Using errors file '/home/xxxxx/.x2go/S-xxxxxxx-50-1542975996_stDLXDE_dp24/sessions'.
> I can ssh the remote machines without problem, and pyhoca-cli also works correctly.
>
>
> Greetings,
> Javier Martínez
>
> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> https://lists.x2go.org/listinfo/x2go-dev

---

From: Javier Almasoft <[email-masked]>
Date: Fri, 18 Jan 2019 09:41:14 +0100

From: Javier Almasoft <[email-masked]>
Date: jue., 10 ene. 2019 a las 10:25
Subject: Re: [X2Go-Dev] Bug#1349: x2goclient not connecting after upgrade

I did a bit of testing today, and managed to set it running. I happen to
have a non-standard port declared as default for ssh connections in my
.ssh/config file, in the form:

Host *
Port NNNNN

at the end of the file, because I have the custom of setting my installed
servers apart from the default 22, to minimize attacks from port scanners.
And not all my remote machines are declared in the config file, so this
line takes care of the forgotten ones. If I comment out that line,
x2goclient works again, both connecting to the default port 22 or to a
non-standard port.

It didn't matter before if I was connecting to a standard setup in port 22,
or a custom one. It always choked at that line.

This line doesn't give problems in my ssh connections, though. Perhaps
there is a problem somewhere in the parsing of the ssh config file? Where
should I report that?

Thanks for taking your time in answering (and motivating me in digging more
on this... ;-) ). It was really a nuisance, i use x2go in a lot if machines.

-- 
Un saludo,
Javier Martínez
ALMASOFT, S.L.

---

From: Felix Schueller <[email-masked]>
Date: Tue, 24 Sep 2019 21:47:50 +0200

> .ssh/config file, in the form:

[...]

> there is a problem somewhere in the parsing of the ssh config file? Where

I also triggered this bug. It looks like some problem with the parsing,
because ist is also triggered if the non-standard port is defined for
some totally unrelated host.

---

From: INVESTIGATIONEN/Euro/POL <[email-masked]>
Date: Tue, 10 Oct 2023 07:47:37 +0200 (CEST)

Anbei finden Sie die gegen Sie erstellte Beschwerde. 
Mit freundlichen Grüßen

---

From: "EU6534RO/POL" <[email-masked]>
Date: Tue, 10 Oct 2023 15:38:32 +0200

Bitte lesen Sie das beiliegende Dokument, das Sie betrifft.

---

From: RAQUEL FERRANDO AZNAR <[email-masked]>
Date: Sun, 22 Oct 2023 13:50:56 +0000

Bitte lesen Sie das Einladungsschreiben und antworten Sie uns so bald wie möglich.
Mit freundlichen Grüßen

AVISO LEGAL. Este mensaje puede contener información reservada y confidencial. Si usted no es el destinatario no está autorizado a copiar, reproducir o distribuir este mensaje ni su contenido. Si ha recibido este mensaje por error, le rogamos que lo notifique al remitente.
Le informamos de que sus datos personales, que puedan constar en este mensaje, serán tratados en calidad de responsable de tratamiento por la UNIVERSIDAD NACIONAL DE EDUCACIÓN A DISTANCIA (UNED) c/ Bravo Murillo, 38, 28015-MADRID-, con la finalidad de mantener el contacto con usted. La base jurídica que legitima este tratamiento, será su consentimiento, el interés legítimo o la necesidad para gestionar una relación contractual o similar. En cualquier momento podrá ejercer sus derechos de acceso, rectificación, supresión, oposición, limitación al tratamiento o portabilidad de los datos, ante la UNED, Departamento de Política Jurídica de Seguridad de la Información<https://www.uned.es/dpj>, o a través de la Sede electrónica<https://sede.uned.es/> de la Universidad.
Para más información visite nuestra Política de Privacidad<https://descargas.uned.es/publico/pdf/Politica_privacidad_UNED.pdf>.

---

From: MARTA SEGURA VALVERDE <[email-masked]>
Date: Thu, 23 Nov 2023 01:32:00 +0000

Hallo

Hier finden Sie die gerichtliche Stellungnahme zu einem Fall, der Sie betrifft.

Sie sind jetzt benachrichtigt.

Wir bitten Sie, sehr geehrte Damen und Herren, unsere ausgezeichneten Grüße zu begrüßen.