Subject: Bug#1328: x2gobroker-daemon does not work with tornado >=5.0

From: "Rogalla, Niels [IT / Ev. Stiftung Augusta]" <[email-masked]>
Date: Mon, 24 Sep 2018 11:26:31 +0000

Package: x2gobroker

Version: 0.0.3.4 (0x2go1+git20180206.1037+8)

When using python2-tornado >= 5.0 with the latest x2gobroker the x2gobroker-daemon does not start and following error message is shown in the log files:

Traceback (most recent call last):
  File "/usr/bin/x2gobroker-daemon", line 306, in <module>
    launch_ioloop()
  File "/usr/bin/x2gobroker-daemon", line 281, in launch_ioloop
    tornado.ioloop.IOLoop.instance().start()
  File "/usr/lib/python2.7/site-packages/tornado/ioloop.py", line 939, in start
    raise RuntimeError("Cannot share PollIOLoops across processes")
RuntimeError: Cannot share PollIOLoops across processes

This issue was tested against tornado versions 5.0.2, 5.1.0 and 5.1.1 and this error always occurs. The last working version of tornado is 4.5.3.

Kind regards,
Niels

Diese E-Mail enthält vertrauliche und/oder rechtlich geschützte Informationen. Wenn Sie nicht der richtige Adressat sind oder diese E-Mail irrtümlich erhalten haben, informieren Sie bitte sofort den Absender und vernichten Sie diese Mail. Das unerlaubte Kopieren sowie die unbefugte Weitergabe dieser Mail ist nicht gestattet.

This e-mail may contain confidential and/or privileged information. If you are not the intended recipient (or have received this e-mail in error) please notify the sender immediately and destroy this e-mail. Any unauthorized copying, disclosure or distribution of the material in this e-mail is strictly forbidden.
________________________________
Sparen Sie pro Seite ca. 200ml Wasser, 2g CO2 und 2g Holz: Danke, dass Sie erst an die Umwelt denken, bevor Sie diese E-Mail ausdrucken.

Augusta-Kranken-Anstalt gGmbH
Ein Unternehmen der Evangelischen Stiftung Augusta
Bergstrasse 26; 44791 Bochum
Geschäftsführer: Dipl.-Kfm. Ulrich Froese, Dipl.-Kfm. Thomas Drathen
Amtsgericht Bochum HRB 3707
Homepage: www.augusta-bochum.de

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 01 Oct 2018 14:12:07 +0000

Hi Niels,

On  Mo 24 Sep 2018 13:26:31 CEST, Rogalla, Niels [IT / Ev. Stiftung  
Augusta] wrote:

> When using python2-tornado >= 5.0 with the latest x2gobroker the  
> x2gobroker-daemon does not start and following error message is  
> shown in the log files:
>
>
>
> This issue was tested against tornado versions 5.0.2, 5.1.0 and  
> 5.1.1 and this error always occurs. The last working version of  
> tornado is 4.5.3.
>
>
>
>
> Kind regards,
> Niels

Please let us get this fixed with the version of x2gobroker you find  
in the nightly builds.

It is very likely, that you will encounter the same issue when using  
x2gobroker from the X2Go nightly builds, but that version should be  
the one to use for testing setups, as it will be release soon.

And before the release, we should get your problem solved.

Thanks+Greets,
Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de