Subject: X2Go issue (in src:x2goserver) has been marked as closed

From: X2Go Release Manager X2Go Release Manager <[email-masked]>
Date: Thu, 29 Nov 2018 05:56:49 +0100 (CET)

close #1325
thanks

Hello,

we are very hopeful that X2Go issue #1325 reported by you
has been resolved in the new release (4.1.0.3) of the
X2Go source project »src:x2goserver«.

You can view the complete changelog entry of src:x2goserver (4.1.0.3)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goserver.

    http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=2f9ba747f837b253b08e35d26d4f7e022e09f6a2;hp=248ee80e769a6ddd2de820d022cc8ee440525dd6

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goserver.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goserver
Version: 4.1.0.3-0x2go1
Status: RELEASE
Date: Thu, 29 Nov 2018 05:55:21 +0100
Fixes: 1322 1325
Changes:
 x2goserver (4.1.0.3-0x2go1) RELEASED; urgency=medium
 .
   [ Mike Gabriel ]
   * New upstream version (4.1.0.3)
     - x2goserver.service: Add Documentation= key.
     - x2goserver/lib/x2gocheckport: chmod a+x.
     - New bin:pkg: x2goserver-desktopsharing. Move all desktop sharing
       integration logic from x2godesktopsharing to x2goserver src:pkg.
     - Don't rely on "ln -sf" to remove a symlink before recreating it. If the
       target is non-writable, this may fail (observed on a Debian stretch
       system). Thus, removing the symlink file first and then recreating it.
     - Massive white-space cleanup (at EOLs).
     - x2goserver/bin/x2goruncommand: Support IceWM as desktop session type.
   * debian/x2goserver*.dirs:
     + Let dirs have a trailing slash in their path (for the human eye merely).
   * debian/copyright:
     + Regenerate auto-generated copyright.in file.
     + Adopt from recent Debian packaging.
     + Add x2goserver.spec.
   * debian/control:
     + Move xfonts-base from D to R. Thanks lintian.
     + Move C (x2goserver) with versioned x2godesktopsharing, to B.
     + Don't depend on essential package without version. Drop bash from D.
     + Bump Standards-Version: to 4.2.1. No changes needed.
     + Mention "client side printing support" also in descr of bin:pkg
       x2goserver-common.
   * debian/*.postinst:
     + Avoid recursive chmod/chown. Recursive chown/chmod is susceptible to
       hardlink attacks on mainline, non-Debian kernels.
   * debian/x2goserver.postinst:
     + Load debconf module, even if not used (Debian Policy demand).
   * debian/*.templates:
     + Move x2goserver and x2goserver-desktopsharing templates into separate
       files.
   * debian/po:
     + Add French translation. Thanks to Jean-Pierre Giraud from the Debian
       project. (Closes DBTS:#905931).
   * lintian:
     + Drop unused debian/x2goserver-printing.lintian-overrides.
   * debian/*: White-space cleanup.
   * x2goserver.spec:
     + Mention "client side printing support" in all pkg descriptions.
     + Regression fix: Use "desktopsharing" package name above its description,
       not copy+pasted "extensions".
     + Regression fix: Make /etc/x2go/desktopsharing be owned by x2goserver-
       desktopsharing.
     + Exclude x2go*-desktopsharing scripts and man page in %files x2goserver.
 .
   [ Mihai Moldovan ]
   * New upstream version (4.1.0.3):
     - x2goserver/lib/x2gocheckport: remove executable flag. This file is STILL
       not meant to be executed directly.
     - libx2go-server-db-perl/Makefile: make sure our {C,LD}FLAGS are always
       appended to the user-provided ones.
     - x2goserver-desktopsharing/bin/x2goterminate-desktopsharing: replace
       historical "egrep" with "grep -E".
     - x2goserver-desktopsharing/bin/x2goterminate-desktopsharing: don't use
       negative exit codes.
     - x2goserver-desktopsharing/bin/x2goterminate-desktopsharing: more curly
       braces, quotes etc.
     - x2goserver-extensions/bin/x2goserver-run-extensions: replace historical
       "egrep" with "grep -E".
     - x2goserver-extensions/bin/x2goserver-run-extensions: don't use negative
       exit codes.
     - x2goserver-extensions/bin/x2goserver-run-extensions: more curly braces,
       quotes etc.
     - x2goserver/bin/x2gofeaturelist: replace historical "egrep" with "grep
       -E".
     - x2goserver/bin/x2gofeaturelist: more curly braces, quotes etc.
     - x2goserver/bin/x2goruncommand: replace historical "egrep" with "grep
       -E".
     - x2goserver/bin/x2goversion: replace historical "egrep" with "grep -E".
     - x2goserver/bin/x2goversion: more curly braces, quotes etc.
     - x2goserver/bin/x2gostartagent: use single quotes instead of double
       quotes for literal strings.
     - x2goserver-x2goagent/etc/x2goagent.options: re-enable BIG-REQUESTS;
       newer nx-libs versions (3.5.99.17+) should handle this much better.
       Fixes: #1325. Fixes: #1321.
     - misc: copyright updates, but for contributors who haven't been active or
       requested not to be bumped.
     - misc: switch to HTTPS-based URLs where appropriate.
     - misc: update Oleksandr's email address.
     - misc manpages: pre-release date update.
     - libx2go-server-db-perl/src/libx2go-server-db-sqlite3-wrapper.c: revamp
       wrapper, alike to what was done in x2gobroker.
   * x2goserver.spec:
     + Pull in openSUSE-release manually on OpenSuSE Tumbleweed to work around
       a bug.
     + Also pass %{__global_{c{,pp},ld}flags} down via {C,LD}FLAGS.
     + Bump nxagent dependency up to 3.5.99.17+.
   * debian/x2goserver-desktopsharing.postinst:
     + More curly braces, quotes etc.
   * debian/x2goserver-desktopsharing.config:
     + More curly braces, quotes etc.
   * debian/x2goserver-desktopsharing.postrm:
     + More curly braces, quotes etc.
   * debian/libx2go-server-db-perl.postinst:
     + Replace historical "egrep" with "grep -E".
   * debian/x2goserver.config:
     + Replace historical "egrep" with "grep -E".
     + More curly braces, quotes etc.
   * debian/control:
     + Bump nxagent dependency up to 3.5.99.17+.
   * debian/copyright{,.in}:
     + Merge copyright entries.
     + Fix links to our wiki and update to HTTPS.
 .
   [ Orion Poplawski ]
   * New upstream version (4.1.0.3):
     - x2goserver{/bin/x2gostartagent,-x2goagent/etc/x2goagent.options}: allow
       setting nxagent nx/nx options on the server via x2goagent.options.
       Fixes: #1322.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Thu, 29 Nov 2018 05:05:06 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver-x2goagent package:

#1325: Nextcloud desktop GUI crashes in XFCE over x2go

It has been closed by X2Go Release Manager X2Go Release Manager <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact X2Go Release Manager X2Go Release Manager <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goserver) has been marked as closed
From: X2Go Release Manager X2Go Release Manager <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Thu, 29 Nov 2018 05:56:49 +0100 (CET)

close #1325
thanks

Hello,

light+love

---

Subject: Nextcloud desktop GUI crashes in XFCE over x2go
From: Thierry Kauffmann <[email-masked]>
To: [email-masked]
Date: Mon, 27 Aug 2018 13:50:38 +0200

Package: x2goserver
Version: 4.1.0.2

Hi,
Nextcloud desktop works well under XFCE over X2go. Syncing is ok and I
get a nice green icon in notification bar.
The GUI used to work perfectly until recently (a few days or weeks). Now
I can't launch the GUI and modify parameters : Nextcloud desktop GUI
crashes immediately.

I get the following log :

|08-27 10:35:45:796 1290 OCC::ownCloudGui::slotShowSettings: void
OCC::ownCloudGui::slotShowSettings() 08-27 10:35:45:853 1290 unknown:
The X11 connection broke: Maximum allowed requested length exceeded
(code 4) XIO: fatal IO error 2 (Aucun fichier ou dossier de ce type) on
X server ":50.0" after 391 requests (391 known processed) with 0 events
remaining. |

Any idea what is going wrong ?

Thierry