X2Go Bug report logs - #1324
x2gomatebindings mess up language settings

Package: x2gomatebindings; Maintainer for x2gomatebindings is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2gomatebindings is src:x2gomatebindings.

Reported by: "Prof. Dr. Reinhold von Schwerin" <dspyr.hsu@gmail.com>

Date: Sun, 26 Aug 2018 11:25:02 UTC

Severity: normal

Reply or subscribe to this bug.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1324; Package x2gomatebindings. (Sun, 26 Aug 2018 11:25:02 GMT) Full text and rfc822 format available.

Acknowledgement sent to "Prof. Dr. Reinhold von Schwerin" <dspyr.hsu@gmail.com>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Sun, 26 Aug 2018 11:25:02 GMT) Full text and rfc822 format available.

Message #5 received at submit@bugs.x2go.org (full text, mbox):

From: "Prof. Dr. Reinhold von Schwerin" <dspyr.hsu@gmail.com>
To: submit@bugs.x2go.org
Subject: x2gomatebindings mess up language settings
Date: Sun, 26 Aug 2018 13:20:13 +0200
[Message part 1 (text/plain, inline)]
Package: x2gomatebindings

Version: 0.0.1.5

(the exact version is 0.0.1.5-0~203~ubuntu18.04.1 for Ubuntu Bionic Beaver)

When I install x2gomatebindings in Ubuntu MATE 18.04.1, the language 
settings are messed up (see attached screenshots). Please note that this 
is inside a VMWare guest on my local machine (in production, this will 
run on an ESX server).

In particular, the system language is de_DE.UTF-8 and the screenshots 
demonstrate that in the file browser caja various standard folders are 
now named in English (Places, Computer, Desktop, File system, Trash, 
Network, Browse network) as opposed to (Orte, Rechner, Schreibtisch, 
Papierkorb, Netzwerk, Netzwerk durchsuchen). Also, the Icon for the home 
folder has been renamed (HDA_0n's Home) as opposed to (Perönlicher 
Ordner von HDA_0n). In the menus, there are a few more of these 
replacements.

I already had the same issue with Ubuntu MATE 14.04 Trusty Tahr, but did 
not investigate further since that was before MATE became an officially 
recognized Ubuntu dialect.

I would like to add that I have another VM in which I installed 
x2goserver and x2goserver-xsession WITHOUT x2gomatebindings and there 
this does not happen. So it is clear that the error must be with the 
MATE bindings. Also, my first impression is that I can connect to the VM 
without the MATE bindings and work with it using the X2Go client just 
fine, but I will have to really test that.


[BionicMATE_noMATEBindings.png (image/png, attachment)]
[BionicMATE_withMATEBindings.png (image/png, attachment)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>:
Bug#1324; Package x2gomatebindings. (Mon, 08 Oct 2018 12:15:01 GMT) Full text and rfc822 format available.

Acknowledgement sent to "m.herweg@gmx.de" <m.herweg@gmx.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>. (Mon, 08 Oct 2018 12:15:02 GMT) Full text and rfc822 format available.

Message #10 received at 1324@bugs.x2go.org (full text, mbox):

From: "m.herweg@gmx.de" <m.herweg@gmx.de>
To: 1324@bugs.x2go.org
Subject: I'm also affected by this bug
Date: Mon, 8 Oct 2018 14:05:10 +0200
I'm also affected by this bug.

x2go remote printing works without x2gomatebindings,
but remote folders create a unusable icon on the desktop that will
confuse users if I don't have x2gomatebindings installed.



Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Fri Dec 14 19:44:37 2018; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system
Copyright (C) 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson.