Subject: X2Go issue (in src:x2goserver) has been marked as closed

From: X2Go Release Manager X2Go Release Manager <[email-masked]>
Date: Thu, 29 Nov 2018 05:56:48 +0100 (CET)

close #1322
thanks

Hello,

we are very hopeful that X2Go issue #1322 reported by you
has been resolved in the new release (4.1.0.3) of the
X2Go source project »src:x2goserver«.

You can view the complete changelog entry of src:x2goserver (4.1.0.3)
below, and you can use the following link to view all the code changes
between this and the last release of src:x2goserver.

    http://code.x2go.org/gitweb?p=x2goserver.git;a=commitdiff;h=2f9ba747f837b253b08e35d26d4f7e022e09f6a2;hp=248ee80e769a6ddd2de820d022cc8ee440525dd6

If you feel that the issue has not been resolved satisfyingly, feel
free to reopen this bug report or submit a follow-up report with
further observations described based on the new released version
of src:x2goserver.

Thanks a lot for contributing to X2Go!!!

light+love
X2Go Git Admin (on behalf of the sender of this mail)

---
X2Go Component: src:x2goserver
Version: 4.1.0.3-0x2go1
Status: RELEASE
Date: Thu, 29 Nov 2018 05:55:21 +0100
Fixes: 1322 1325
Changes:
 x2goserver (4.1.0.3-0x2go1) RELEASED; urgency=medium
 .
   [ Mike Gabriel ]
   * New upstream version (4.1.0.3)
     - x2goserver.service: Add Documentation= key.
     - x2goserver/lib/x2gocheckport: chmod a+x.
     - New bin:pkg: x2goserver-desktopsharing. Move all desktop sharing
       integration logic from x2godesktopsharing to x2goserver src:pkg.
     - Don't rely on "ln -sf" to remove a symlink before recreating it. If the
       target is non-writable, this may fail (observed on a Debian stretch
       system). Thus, removing the symlink file first and then recreating it.
     - Massive white-space cleanup (at EOLs).
     - x2goserver/bin/x2goruncommand: Support IceWM as desktop session type.
   * debian/x2goserver*.dirs:
     + Let dirs have a trailing slash in their path (for the human eye merely).
   * debian/copyright:
     + Regenerate auto-generated copyright.in file.
     + Adopt from recent Debian packaging.
     + Add x2goserver.spec.
   * debian/control:
     + Move xfonts-base from D to R. Thanks lintian.
     + Move C (x2goserver) with versioned x2godesktopsharing, to B.
     + Don't depend on essential package without version. Drop bash from D.
     + Bump Standards-Version: to 4.2.1. No changes needed.
     + Mention "client side printing support" also in descr of bin:pkg
       x2goserver-common.
   * debian/*.postinst:
     + Avoid recursive chmod/chown. Recursive chown/chmod is susceptible to
       hardlink attacks on mainline, non-Debian kernels.
   * debian/x2goserver.postinst:
     + Load debconf module, even if not used (Debian Policy demand).
   * debian/*.templates:
     + Move x2goserver and x2goserver-desktopsharing templates into separate
       files.
   * debian/po:
     + Add French translation. Thanks to Jean-Pierre Giraud from the Debian
       project. (Closes DBTS:#905931).
   * lintian:
     + Drop unused debian/x2goserver-printing.lintian-overrides.
   * debian/*: White-space cleanup.
   * x2goserver.spec:
     + Mention "client side printing support" in all pkg descriptions.
     + Regression fix: Use "desktopsharing" package name above its description,
       not copy+pasted "extensions".
     + Regression fix: Make /etc/x2go/desktopsharing be owned by x2goserver-
       desktopsharing.
     + Exclude x2go*-desktopsharing scripts and man page in %files x2goserver.
 .
   [ Mihai Moldovan ]
   * New upstream version (4.1.0.3):
     - x2goserver/lib/x2gocheckport: remove executable flag. This file is STILL
       not meant to be executed directly.
     - libx2go-server-db-perl/Makefile: make sure our {C,LD}FLAGS are always
       appended to the user-provided ones.
     - x2goserver-desktopsharing/bin/x2goterminate-desktopsharing: replace
       historical "egrep" with "grep -E".
     - x2goserver-desktopsharing/bin/x2goterminate-desktopsharing: don't use
       negative exit codes.
     - x2goserver-desktopsharing/bin/x2goterminate-desktopsharing: more curly
       braces, quotes etc.
     - x2goserver-extensions/bin/x2goserver-run-extensions: replace historical
       "egrep" with "grep -E".
     - x2goserver-extensions/bin/x2goserver-run-extensions: don't use negative
       exit codes.
     - x2goserver-extensions/bin/x2goserver-run-extensions: more curly braces,
       quotes etc.
     - x2goserver/bin/x2gofeaturelist: replace historical "egrep" with "grep
       -E".
     - x2goserver/bin/x2gofeaturelist: more curly braces, quotes etc.
     - x2goserver/bin/x2goruncommand: replace historical "egrep" with "grep
       -E".
     - x2goserver/bin/x2goversion: replace historical "egrep" with "grep -E".
     - x2goserver/bin/x2goversion: more curly braces, quotes etc.
     - x2goserver/bin/x2gostartagent: use single quotes instead of double
       quotes for literal strings.
     - x2goserver-x2goagent/etc/x2goagent.options: re-enable BIG-REQUESTS;
       newer nx-libs versions (3.5.99.17+) should handle this much better.
       Fixes: #1325. Fixes: #1321.
     - misc: copyright updates, but for contributors who haven't been active or
       requested not to be bumped.
     - misc: switch to HTTPS-based URLs where appropriate.
     - misc: update Oleksandr's email address.
     - misc manpages: pre-release date update.
     - libx2go-server-db-perl/src/libx2go-server-db-sqlite3-wrapper.c: revamp
       wrapper, alike to what was done in x2gobroker.
   * x2goserver.spec:
     + Pull in openSUSE-release manually on OpenSuSE Tumbleweed to work around
       a bug.
     + Also pass %{__global_{c{,pp},ld}flags} down via {C,LD}FLAGS.
     + Bump nxagent dependency up to 3.5.99.17+.
   * debian/x2goserver-desktopsharing.postinst:
     + More curly braces, quotes etc.
   * debian/x2goserver-desktopsharing.config:
     + More curly braces, quotes etc.
   * debian/x2goserver-desktopsharing.postrm:
     + More curly braces, quotes etc.
   * debian/libx2go-server-db-perl.postinst:
     + Replace historical "egrep" with "grep -E".
   * debian/x2goserver.config:
     + Replace historical "egrep" with "grep -E".
     + More curly braces, quotes etc.
   * debian/control:
     + Bump nxagent dependency up to 3.5.99.17+.
   * debian/copyright{,.in}:
     + Merge copyright entries.
     + Fix links to our wiki and update to HTTPS.
 .
   [ Orion Poplawski ]
   * New upstream version (4.1.0.3):
     - x2goserver{/bin/x2gostartagent,-x2goagent/etc/x2goagent.options}: allow
       setting nxagent nx/nx options on the server via x2goagent.options.
       Fixes: #1322.

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Thu, 29 Nov 2018 05:05:05 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goserver package:

#1322: RFE: Allow setting nxagent nx/nx options on the server via x2goagent.options

It has been closed by X2Go Release Manager X2Go Release Manager <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact X2Go Release Manager X2Go Release Manager <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: X2Go issue (in src:x2goserver) has been marked as closed
From: X2Go Release Manager X2Go Release Manager <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked]
Date: Thu, 29 Nov 2018 05:56:48 +0100 (CET)

close #1322
thanks

Hello,

light+love

---

Subject: RFE: Allow setting nxagent nx/nx options on the server via x2goagent.options
From: Orion Poplawski <[email-masked]>
To: [email-masked]
Date: Fri, 17 Aug 2018 11:08:14 -0600

Package: x2goserver
Persion: 4.1.0.2
Tags: patch

The attached patch allows the setting of nxagent nx/nx options on the server
via x2goagent.options.  Very useful for being able to set sleep=0.

-- 
Orion Poplawski
Manager of NWRA Technical Systems          720-772-5637
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                 https://www.nwra.com/
>From d3ad2c284cd404286b2764266bed837e3da2ea71 Mon Sep 17 00:00:00 2001
From: Orion Poplawski <[email-masked]>
Date: Fri, 17 Aug 2018 11:04:03 -0600
Subject: [PATCH] Allow setting nxagent nx/nx options on the server via
 x2goagent.options

---
 x2goserver-x2goagent/etc/x2goagent.options |  3 +++
 x2goserver/bin/x2gostartagent              | 11 +++++++----
 2 files changed, 10 insertions(+), 4 deletions(-)

diff --git a/x2goserver-x2goagent/etc/x2goagent.options b/x2goserver-x2goagent/etc/x2goagent.options
index a521d17..b7828b1 100644
--- a/x2goserver-x2goagent/etc/x2goagent.options
+++ b/x2goserver-x2goagent/etc/x2goagent.options
@@ -33,3 +33,6 @@ X2GO_NXAGENT_DEFAULT_OPTIONS+=" -nolisten tcp"
 # Disable BIG-REQUESTS, nx-libs does not implement this extension correctly.
 # Leads to all sorts of weird crashes if left enabled.
 X2GO_NXAGENT_DEFAULT_OPTIONS+=" -extension BIG-REQUESTS"
+
+# Extra nxagent nx/nx options, separated by commas.  For example: sleep=0
+X2GO_NXOPTIONS=""
diff --git a/x2goserver/bin/x2gostartagent b/x2goserver/bin/x2gostartagent
index 88d015c..af1e2c4 100755
--- a/x2goserver/bin/x2gostartagent
+++ b/x2goserver/bin/x2gostartagent
@@ -402,14 +402,17 @@ fi
 typeset xinerama_option='1'
 [[ "${x2go_xinerama}" = '0' ]] && xinerama_option='0'
 
+typeset kbtype_option="${X2GO_KBD_TYPE}"
 if [[ "${X2GO_SET_KBD}" = '0' ]] || [[ "${X2GO_KBD_TYPE}" = 'auto' ]]; then
-	X2GO_HOST="nx/nx,link=${X2GO_LINK},pack=${X2GO_PACK},limit=0,root=${SESSION_DIR},cache=8M,images=32M,type=${X2GO_TYPE},id=${SESSION_NAME},cookie=${X2GO_COOKIE},errors=${SESSION_LOG},kbtype=null/null,${option_geometry}xinerama=${xinerama_option},resize=${X2GO_RESIZE},fullscreen=${X2GO_FULLSCREEN},accept=${REMOTE},listen=${GR_PORT}${clipboard},client=linux,menu=0,state=${STATE_FILE}"
-else
-	X2GO_HOST="nx/nx,link=${X2GO_LINK},pack=${X2GO_PACK},limit=0,root=${SESSION_DIR},cache=8M,images=32M,type=${X2GO_TYPE},id=${SESSION_NAME},cookie=${X2GO_COOKIE},errors=${SESSION_LOG},kbtype=${X2GO_KBD_TYPE},${option_geometry}xinerama=${xinerama_option},resize=${X2GO_RESIZE},fullscreen=${X2GO_FULLSCREEN},accept=${REMOTE},listen=${GR_PORT}${clipboard},client=linux,menu=0,state=${STATE_FILE}"
+	kbtype_option="null/null"
 fi
 
+# Ensure X2GO_NXOPTIONS ends with a , if needed
+if [[ -n "${X2GO_NXOPTIONS}" ]]; then
+	X2GO_NXOPTIONS="${X2GO_NXOPTIONS%,},"
+fi
 
-echo "${X2GO_HOST}:${X2GO_PORT}" >"${SESSION_DIR}/options"
+echo "nx/nx,link=${X2GO_LINK},pack=${X2GO_PACK},limit=0,root=${SESSION_DIR},cache=8M,images=32M,type=${X2GO_TYPE},id=${SESSION_NAME},cookie=${X2GO_COOKIE},errors=${SESSION_LOG},kbtype=${kbtype_option},${option_geometry}xinerama=${xinerama_option},resize=${X2GO_RESIZE},fullscreen=${X2GO_FULLSCREEN},accept=${REMOTE},listen=${GR_PORT}${clipboard},client=linux,menu=0,${X2GO_NXOPTIONS}state=${STATE_FILE}:${X2GO_PORT}" >"${SESSION_DIR}/options"
 
 NX_AGENT=":${X2GO_PORT}"
 SAVED_DISPLAY="${DISPLAY}"
-- 
1.8.3.1