Subject: Bug#1319: PulseAudio does not start

From: "SW@EU" <[email-masked]>
Date: Tue, 14 Aug 2018 08:18:19 +0000

Package: mingw32-pulseaudio
Version: 7.1

Hi,
Windows 10 forced update to 1803 (Pro edition, englisch + German language pack) and x2goclient updated using x2goclient-4.1.2.0-2018.06.22-setup.exe. Since that I have to disable Pulse-Audio because otherwise I get the attached error during any start of the client.
I have in meantime uninstalled the the separate installed 64 Bit VcXsrv because the 32 Bit x2goclient installation has changed files in the 64 Bit VcXsrv installation (is this correct?) and uninstalled x2goclient, rebooted, x2goclient again installed but 64 Bit VcXsrv not again, rebooted, but still the same.

TIA,
Silvio

---

From: jb_x2go <[email-masked]>
Date: Fri, 08 Nov 2019 12:18:40 +0100

​Hi,I have installed the current x2go-client (4.1.2.0) on two Windows computers. Under Win7 the sound works fine. Not under Windows 10, because the program PulseAudio does not start! When starting the program on the command line, these messages appear:
&nbsp;&nbsp; Microsoft Windows [Version 10.0.18362.418]
&nbsp;&nbsp; (c) 2019 Microsoft Corporation. Alle Rechte vorbehalten.

&nbsp;&nbsp; C:\Program Files (x86)\x2goclient\pulse&gt;pulseaudio.exe
&nbsp;&nbsp; W: [(null)] pulsecore/core-util.c: Secure directory creation not supported on this platform.
&nbsp;&nbsp; W: [(null)] pulsecore/core-util.c: Secure directory creation not supported on this platform.
&nbsp;&nbsp; W: [(null)] pulsecore/core-util.c: Secure directory creation not supported on this platform.
&nbsp;&nbsp; W: [(null)] pulsecore/core.c: Failed to allocate shared memory pool. Falling back to a normal memory pool.
&nbsp;&nbsp; E: [(null)] daemon/main.c: Daemon startup without any loaded modules, refusing to work.
&nbsp;&nbsp; W: [(null)] pulsecore/core-util.c: Secure directory creation not supported on this platform.

&nbsp;&nbsp; C:\Program Files (x86)\x2goclient\pulse&gt;

Even in compatibility mode (win 7) PulseAudio cannot be started and I did not find a more current version for Windows on the web.
Greetings from the former home of CeBIT
J. Hartmann