Subject: Bug#1312: QT applications crash with x2go server 4.1.0.2

From: Adrian Bickerstaffe <[email-masked]>
Date: Fri, 5 Oct 2018 06:56:18 +0000

I can verify that this also occurs on my compute servers running Ubuntu 14.04LTS and 16.04LTS.
Commenting the line:

X2GO_NXAGENT_DEFAULT_OPTIONS+=" -extension BIG-REQUESTS"

in x2goagent.options does resolve the issue, *but* there is a comment above that line:

# Disable BIG-REQUESTS, nx-libs does not implement this extension correctly.
# Leads to all sorts of weird crashes if left enabled.

…which unfortunately has proven to be true for my instances. The performance and reliability of x2go has dropped substantially since commenting the line.

Can we please raise the priority of this bug to restore performance?

Regards, Adrian.

---

From: Ulrich Sibiller <[email-masked]>
Date: Mon, 22 Oct 2018 08:55:41 +0200

Can you name some problematic apps that crash with the line commented? I
have a patch that might help. I would like to test a bit.

Uli

Adrian Bickerstaffe <[email-masked]> schrieb am Mo., 22. Okt. 2018,
08:09:

> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> https://lists.x2go.org/listinfo/x2go-dev

---

From: Adrian Bickerstaffe <[email-masked]>
Date: Tue, 23 Oct 2018 00:38:57 +0000

The main one is Rstudio 1.1.456 which was installed from the .deb package available from https://download1.rstudio.org/rstudio-xenial-1.1.456-amd64.deb (64.9MB).

Without the workaround, RStudio fails to launch with the same sort of error reported earlier in this thread. With the workaround, users reported “…quite difficult to navigate, slow response from server. In particular but not only when using R studio. As well as constant flickering of server window” and "The server window is often “flickering”, and response time is very slow."

From: Ulrich Sibiller <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Monday, 22 October 2018 at 4:55 pm
To: Adrian Bickerstaffe <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [X2Go-Dev] Bug#1312: QT applications crash with x2go server 4.1.0.2

Can you name some problematic apps that crash with the line commented? I have a patch that might help. I would like to test a bit.

Uli

Adrian Bickerstaffe <[email-masked]<mailto:[email-masked]>> schrieb am Mo., 22. Okt. 2018, 08:09:
I can verify that this also occurs on my compute servers running Ubuntu 14.04LTS and 16.04LTS.
Commenting the line:

Regards, Adrian.

_______________________________________________
x2go-dev mailing list
[email-masked]<mailto:[email-masked]>
https://lists.x2go.org/listinfo/x2go-dev<https://lists.x2go.org/listinfo/x2go-dev>

---

From: Ulrich Sibiller <[email-masked]>
Date: Tue, 23 Oct 2018 22:52:17 +0200

> Without the workaround, RStudio fails to launch with the same sort of error reported earlier in this thread. With the workaround, users reported “…quite difficult to navigate, slow response from se…

I have tried that version but since I have no R experience I cannot
see any problems - neither with an old nx version nor with the latest
(and greatest ;-) developer version.

Without BIG-REQUESTS it fails with a GL message which indicates that
it is using OpenGL which is slow on NX. Maybe rstudio offers a way to
switch off OpenGL usage. I expect it to be fast then.

I seems there have been ways to configure that in rstudio (see
https://github.com/rstudio/rstudio/issues/3185) but my version 1.1,456
does not offer these settings.

You can TRY adding "-extension GLX" (which disables the GLX extension)
to x2goagent.options and see what happens.

Uli

---

From: Adrian Bickerstaffe <[email-masked]>
Date: Wed, 24 Oct 2018 23:30:44 +0000

Thanks for investigating. I¹ll give those suggestions a try and report
back soon.

On 24/10/18, 7:52 am, "Ulrich Sibiller" <[email-masked]> wrote:

>> The main one is Rstudio 1.1.456 which was installed from the .deb
>>package available from
>>https://download1.rstudio.org/rstudio-xenial-1.1.456-amd64.deb
>>.rstudio.org (64.9MB).
>>
>> Without the workaround, RStudio fails to launch with the same sort of
>>error reported earlier in this thread. With the workaround, users
>>reported ³Šquite difficult to navigate, slow response from server. In
>>particular but not only when using R studio. As well as constant
>>flickering of server window² and "The server window is often
>>³flickering², and response time is very slow."
>

---

From: Adrian Bickerstaffe <[email-masked]>
Date: Fri, 2 Nov 2018 04:58:33 +0000

If I set ³ -extension GLX² and " -extension BIG-REQUESTS², launching
Rstudio produces the error:

    Could not initialize OpenGL for RasterGLSurface, reverting to
RasterSurface.
    rstudio: Fatal IO error 11 (Resource temporarily unavailable) on X
server :53.0.

The daily builds of Rstudio 1.2 appear to have introduced a configuration
option to set the type of renderer (GL, software, etc), but the daily .deb
build won¹t install on Ubuntu 14.04 due to unmet dependencies.