Subject: x2gobroker-ssh : wrong password after password change in interactive mode

From: Walid MOGHRABI <[email-masked]>
Date: Wed, 9 May 2018 16:50:13 +0200 (CEST)

package: x2gobroker-ssh
version: 0.0.4.0-0~1022~ubuntu16.04.1
priority: bug

x2gobroker-ssh supports interactive mode which means that it can reports login interactions to the user such as password changes requests.
Let's say that my user's password has expired, when I login to the broker with x2goclient in broker mode, I'll see a new form asking for my old password and I must type/confirm my new password.
Once done, I'll be granted access to the broker and I'll get my session profiles list on the right sidebar of the client.
Since I'm using --use-broker-pass, I don't have to re-type my password when connecting to a session but in that specific use case, I get an auth error while connecting because of wrong password.

In fact, it appears that the client keeps the first password that has been entered at the broker login prompt (the one that expired) when passing it to the session profile.
Once you get the auth error, you'll be prompted with user/pass for the session profile, if you enter the new password, then it works.

Regards,
Walid Moghrabi

TRAVAUX.COM
BAT I - PARC CEZANNE 2 290 AVENUE GALILEE - CS 80403
13591 AIX EN PROVENCE CEDEX 3
---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you

---

From: Mike Gabriel <[email-masked]>
Date: Tue, 15 May 2018 12:19:11 +0000

Control: tags -1 patch

Hi Walid,

On  Mi 09 Mai 2018 16:50:13 CEST, Walid MOGHRABI wrote:

> x2gobroker-ssh supports interactive mode which means that it can  
> reports login interactions to the user such as password changes  
> requests.
> Let's say that my user's password has expired, when I login to the  
> broker with x2goclient in broker mode, I'll see a new form asking  
> for my old password and I must type/confirm my new password.
> Once done, I'll be granted access to the broker and I'll get my  
> session profiles list on the right sidebar of the client.
> Since I'm using --use-broker-pass, I don't have to re-type my  
> password when connecting to a session but in that specific use case,  
> I get an auth error while connecting because of wrong password.
>
> In fact, it appears that the client keeps the first password that  
> has been entered at the broker login prompt (the one that expired)  
> when passing it to the session profile.
> Once you get the auth error, you'll be prompted with user/pass for  
> the session profile, if you enter the new password, then it works.

Can you please test, if the below patch fixes your issue?

```
diff --git a/src/onmainwindow.cpp b/src/onmainwindow.cpp
index eca9451..5ab1dc4 100644
--- a/src/onmainwindow.cpp
+++ b/src/onmainwindow.cpp
@@ -1142,6 +1142,7 @@ void ONMainWindow::slotChangeBrokerPass()
          return;
      }
      broker->changePassword(passDlg.newPass());
+    config.brokerPass = passDlg.newPass();
      setStatStatus ( tr ( "Connecting to broker" ) );
      stInfo->insertPlainText ( "broker url: "+config.brokerurl );
      setEnabled ( false );
```

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 07 Sep 2018 10:29:09 +0000

Control: reassign -1 x2goclient

HI Walid,

On  Di 15 Mai 2018 14:19:11 CEST, Mike Gabriel wrote:

>> password when connecting to a session but in that specific use  
>> case, I get an auth error while connecting because of wrong password.
>>

I haven't had feedback on the above patch, yet. Can you please test  
it? Thanks.

Mike
-- 

DAS-NETZWERKTEAM

---

From: Walid MOGHRABI <[email-masked]>
Date: Wed, 12 Sep 2018 10:20:48 +0200 (CEST)

> I haven't had feedback on the above patch, yet. Can you please test 

Last time I tried (2~3 weeks ago, just before leaving for vacation), it wasn't working and I made sure to use the latest release at that moment.
It still present the wrong password (the "old" one) to the session and not the new password so it fails while trying to connect at first, then I'm presented a form where I can type my password again (the "new" one this time) and then, it works.

Sorry for not giving you any news lately, these last 2 weeks were just bloated for me, it should be a bit better next week so I'll get back to you at that moment.

Regards,
Walid Moghrabi

TRAVAUX.COM

----- Mail original ----- 

De: "Mike Gabriel" <[email-masked]> 
À: [email-masked] 
Cc: "Walid MOGHRABI" <[email-masked]> 
Envoyé: Vendredi 7 Septembre 2018 12:29:09 
Objet: Re: [X2Go-Dev] Bug#1296: Bug#1296: x2gobroker-ssh : wrong password after password change in interactive mode 

HI Walid, 

Mike 
-- 

DAS-NETZWERKTEAM