Subject: FW: Flickering when maximised in Windows

From: Poppe Koen <[email-masked]>
Date: Thu, 26 Apr 2018 07:34:57 +0000

Package: x2goclient
Version: 4.1.1.1

1. Start a session
=> The image is stable
2. Maximise the window
=> The image is flickering and the remote os seems to be switching back and forth between two slightly different sizes.

The effect is independent of the window size: maximised on a smaller monitor exhibits the same behaviour.

On the server, "session.log" is spammed (about 3x per second) with the following (monitor resolution: 1920x1200)

Info: Screen [0] resized to geometry [1920x1181] fullscreen [0].
Info: Screen [0] resized to geometry [1920x1181] fullscreen [0].
Info: Screen [0] resized to geometry [1920x1181] fullscreen [0].
...

Client:
- OS: Windows 7 SP1 64-bit (Windows classic theme)
- x2goclient: 4.1.1.1

Server:
- OS: Ubuntu 14.04 32-bit
- x2goserver: 4.1.0.0
- x2goserver-common: 4.1.0.0
- x2goserver-extensions: 4.1.0.0
- x2goserver-fmbindings: 4.1.0.0
- x2goserver-printing: 4.1.0.0
- x2goserver-x2goagent: 3.5.99.16
- x2goserver-xsession: 4.1.0.0
- nxagent: 3.5.99.16

_____________

Mail Disclaimer<http://www.vandewiele.com/legal#/mail-disclaimer-en>

---

From: Walid MOGHRABI <[email-masked]>
Date: Wed, 9 May 2018 10:41:08 +0200 (CEST)

Already fixed but still not packaged.

As a workaround, you need to upgrade VcxSrv (the embedded Windows X.org server) to the latest release (https://downloads.sourceforge.net/project/vcxsrv/vcxsrv/1.19.6.4/vcxsrv-64.1.19.6.4.installer.exe) and configure x2goclient to use this version instead of the embedded one until X2Go team build a new release which includes a newer VcxSrv.

Regards,
Walid Moghrabi

TRAVAUX.COM
BAT I - PARC CEZANNE 2 290 AVENUE GALILEE - CS 80403
13591 AIX EN PROVENCE CEDEX 3

----- Mail original ----- 

De: "Poppe Koen" <[email-masked]> 
À: [email-masked] 
Envoyé: Jeudi 26 Avril 2018 09:34:57 
Objet: [X2Go-Dev] Bug#1291: FW: Flickering when maximised in Windows 

Package: x2goclient 
Version: 4.1.1.1 

1. Start a session 
=> The image is stable 
2. Maximise the window 

Client: 

Server: 

_____________ 

Mail Disclaimer<http://www.vandewiele.com/legal#/mail-disclaimer-en> 
_______________________________________________ 
x2go-dev mailing list 
[email-masked] 
https://lists.x2go.org/listinfo/x2go-dev
---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you