Subject: Bug#1290: "Cannot open default display" error with .bashrc argument "setxkbmap de"

From: Daniel Mann <[email-masked]>
Date: Wed, 25 Apr 2018 14:27:43 +0200

Package: x2goclient

Version: 4.1.1.1 (Windows)

When the argument "setxkbmap de" is present in the .bashrc, x2goclient 
states "Cannot open default display".

This issue is resolved when the argument is removed from the .bashrc file.

-- 
Dr. Daniel Mann
M.Sc. Structural Biology
Department of Biophysics
Ruhr University Bochum
Office ND 04/67
Universitaetsstr. 150
D-44780 Bochum

Fon +49(0)234-32-28363
Fax +49(0)234-32-14238

www.daniel-mann.com
www.bph.rub.de

[email-masked]

---

From: Stefan Baur <[email-masked]>
Date: Thu, 26 Apr 2018 13:21:55 +0200

> This issue is resolved when the argument is removed from the .bashrc file.

Sounds like you're calling setxkbmap when there's no display variable set.

Would you please try wrapping the setxkbmap call with
if [ -n "$DISPLAY" ]; then
	setxkbmap de
fi

Also, what you are doing sounds like a workaround for $SOMETHING.

Could it be that you are unaware of the option to enforce a keyboard
mapping using X2GoClient?
If you know of that option, but it doesn't work for you, we'd prefer
receiving a bug report for that, rather than for your intended
workaround that doesn't work. ;-)

Kind Regards,
Stefan Baur

-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243