Subject: Drop file() from pyhoca-cli

From: Orion Poplawski <[email-masked]>
Date: Sat, 14 Apr 2018 11:31:28 -0600

Package: pyhoca-cli
Version: 0.5.0.4

file() is not present in python3.

-- 
Orion Poplawski
Manager of NWRA Technical Systems          720-772-5637
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                 https://www.nwra.com/
diff -up pyhoca-cli-0.5.0.4/setup.py.file pyhoca-cli-0.5.0.4/setup.py
--- pyhoca-cli-0.5.0.4/setup.py.file	2017-09-24 01:58:51.000000000 -0600
+++ pyhoca-cli-0.5.0.4/setup.py	2018-04-13 19:44:37.560837443 -0600
@@ -24,7 +24,7 @@ from setuptools import setup
 
 # silence pyflakes, __VERSION__ is properly assigned below...
 __VERSION__ = '0.0.0.0'
-for line in file(os.path.join('pyhoca', 'cli', '__init__.py')).readlines():
+for line in open(os.path.join('pyhoca', 'cli', '__init__.py'),'r').readlines():
     if (line.startswith('__VERSION__')):
         exec(line.strip())
 PROGRAM_VERSION = __VERSION__

---

From: Mike Gabriel <[email-masked]>
Date: Sat, 14 Apr 2018 19:04:08 +0000

> file() is not present in python3.

Thanks for this, too. Please note that PyHoca-CLI on upstream's master  
branch has been ported to Python3 already.

However, with latest paramiko 2.4, I am unable to get a connection at  
the moment.

WIP, I'd say...

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de