Subject: Re: VcXsrv windows xserver crashes when trying to resume a fullscreen session

From: [email-masked]
Date: Wed, 28 Mar 2018 22:51:32 +0000

I have the same problem even with a single monitor system.

Environment:
- x2goserver 4.1.0.0 (ArchLinux)
- Client: Windows 10 Build 1709
- Desktop: xfce4

Steps to reproduce:

- Open Windows client (4.1.1.1), start a new session with "Connect to local desktop" (resolution does not seem to matter, but I'm using windowed 1650x1010)
- Click "Full access"
- As soon as the "New session" window appears, x2goclient crashes.

Older versions of both the client and server (tried different hardware/distros on the server also) exhibit the same issue.

Backtrace from Dr. Mingw of the debug exe:

vcxsrv.exe caused an Access Violation at location 000000006E34F608 in module MSVCR120.dll Reading from location 0000000006E04648.

Registers:
eax=01e1c71c ebx=07018154 ecx=0000067f edx=00000000 esi=06e04648 edi=07018154
eip=6e34f608 esp=00b3f3e4 ebp=00000147 iopl=0         nv up ei pl nz na po nc
cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00010206

AddrPC   Params
6E34F608 07018154 06E04648 000019FC  MSVCR120.dll!memcpy  [f:\dd\vctools\crt\crtw32\string\i386\memcpy.asm @ 305]
0103B708 00000018 00000000 06BF1F8C  vcxsrv.exe!ErrorF
77231659 00000000 00000000 00000000  ntdll.dll!_RtlpAllocateHeapInternal@16

---

From: Ulrich Sibiller <[email-masked]>
Date: Thu, 29 Mar 2018 06:03:50 +0000

This looks like a bug in vcxsrv. You could try to run an other x server on
Windows (settings menu in the x2go client). Or download the current vcxsrv
1.19.something from SourceForge.

Uli

<[email-masked]> schrieb am Do., 29. März 2018, 00:57:

> - Open Windows client (4.1.1.1), start a new session with "Connect to
> local desktop" (resolution does not seem to matter, but I'm using windowed
> 1650x1010)
> - Click "Full access"
> Older versions of both the client and server (tried different
> hardware/distros on the server also) exhibit the same issue.
>
> vcxsrv.exe caused an Access Violation at location 000000006E34F608 in
> module MSVCR120.dll Reading from location 0000000006E04648.
>
> Registers:
> 6E34F608 07018154 06E04648 000019FC  MSVCR120.dll!memcpy
> [f:\dd\vctools\crt\crtw32\string\i386\memcpy.asm @ 305]
> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> https://lists.x2go.org/listinfo/x2go-dev