Subject: x2gobroker-daemon deb package reinstall/upgrade fails

From: Anders Bruun Olsen <[email-masked]>
Date: Thu, 28 Feb 2013 14:42:54 +0100

Package: x2gobroker-daemon
Version: 0.0.0.5 (compiled from 0.0.0.5 git branch)

$ dpkg -l x2gobroker-daemon
...
ii  x2gobroker-daemon                             0.0.0.5-0~x2go1
                    X2Go http(s) based session broker (daemon)

$ sudo dpkg -i x2gobroker-daemon_0.0.0.5-0~x2go1_all.deb
(Reading database ... 58838 files and directories currently installed.)
Preparing to replace x2gobroker-daemon 0.0.0.5-0~x2go1 (using
x2gobroker-daemon_0.0.0.5-0~x2go1_all.deb) ...
 * Stopping X2Go Session Broker standalone daemon x2gobroker

                                               [ OK ]
Unpacking replacement x2gobroker-daemon ...
Setting up x2gobroker-daemon (0.0.0.5-0~x2go1) ...
Group x2gobroker already exists.
User x2gobroker already exists.
dpkg: error processing x2gobroker-daemon (--install):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for ureadahead ...
Errors were encountered while processing:
 x2gobroker-daemon

If I do a purge of the x2gobroker-daemon package and then install it, it
installs fine.

-- 
Anders Bruun Olsen
It-ansvarlig
Det Danske Sprog- og Litteraturselskab
(Society for Danish Language and Literature)

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 28 Feb 2013 17:15:22 +0100

tag #127 moreinfo
thanks

Hi Anders,

> If I do a purge of the x2gobroker-daemon package and then install it, it

In /debian/x2goserver-daemon.postinst you find a line with set -e  
quite at the beginning of the script.

Can you set this line to set -ex, recompile the package and try to  
reproduce the observed error? There should be plenty of output on the  
console that will point you to the exact line where the postinst  
script fails.

Please report back this bit of information. Send the info to  
[email-masked].

Thanks,
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, rothenstein 5, 24214 neudorf-bornstein
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: Anders Bruun Olsen <[email-masked]>
Date: Fri, 1 Mar 2013 10:17:37 +0100

Problem found:
debian/x2gobroker-daemon.postinst line 38 sets home of user x2gobroker to
be /var/lib/x2go but all other references to the homedir are for
/var/lib/x2gobroker.

2013/2/28 Mike Gabriel <[email-masked]>

>> $ sudo dpkg -i x2gobroker-daemon_0.0.0.5-0~**x2go1_all.deb
>> x2gobroker-daemon_0.0.0.5-0~**x2go1_all.deb) ...
> In /debian/x2goserver-daemon.**postinst you find a line with set -e quite
> at the beginning of the script.
>
> console that will point you to the exact line where the postinst script
> fails.
>
> mail: mike.gabriel@das-netzwerkteam.**de<[email-masked]>,
> http://das-netzwerkteam.de
>
> freeBusy:
> https://mail.das-netzwerkteam.**de/freebusy/m.gabriel%40das-**
> netzwerkteam.de.xfb<https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb>
>

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 01 Mar 2013 10:58:04 +0100

tag #127 pending
thanks

Hi Anders,

> be /var/lib/x2go but all other references to the homedir are for

Thanks again for ploughing through my code...

Committed:
http://code.x2go.org/gitweb?p=x2gobroker.git;a=commitdiff;h=8d008dbadaab7527ccd85580056eb3cbcc16b9fe

Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

---

From: Mike Gabriel <[email-masked]>
Date: Fri, 01 Mar 2013 10:59:46 +0100

> be /var/lib/x2go but all other references to the homedir are for

Argghh... the last commit had an error still... This now fixes it...
http://code.x2go.org/gitweb?p=x2gobroker.git;a=commitdiff;h=a62fb92ed282ca25ded2e7782ee79386f9e68e7d

Mike

-- 

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy: