Subject: X2go server crashes on Ubuntu 16.04 starting at 2018-03-08

From: [email-masked]
Date: Fri, 9 Mar 2018 14:14:41 -0500

Package: nxagent
Version: 3.5.99.15 (From the Official Ubuntu PPA)

Hello,

X2go server crashes on Ubuntu 16.04 starting at 2018-03-08.  I am using Windows 10 as the client.  It happens most often when moving the window from one display screen to a second one.  It also happens after a short time online, usually fewer than 5 minutes.  Perhaps a recent Windows 10 update may have caused this since that's the only thing I have changed on these systems.  I am also mounting my Windows 10 drive through the X2go client.  Sound is disabled.

I'm pretty sure nxagent was updated on March 8 to this version:
NXAGENT - Version 3.5.99.15

Here is what I see in the kernel log (dmesg):

[  194.802419] nxagent[3035]: segfault at 0 ip 0000559edeb9c5fb sp 00007ffcbebf71c0 error 4 in nxagent[559edead1000+432000]
[ 9277.059883] nxagent[23367]: segfault at 0 ip 0000562497ecb5fb sp 00007ffcd24230b0 error 4 in nxagent[562497e00000+432000]
[ 9319.625785] nxagent[24275]: segfault at 0 ip 0000557f7e17f5fb sp 00007ffd7cbda740 error 4 in nxagent[557f7e0b4000+432000]
[ 9696.220810] nxagent[25857]: segfault at 0 ip 00005607d52375fb sp 00007ffc87afbb40 error 4 in nxagent[5607d516c000+432000]
[ 9750.298187] nxagent[26894]: segfault at 0 ip 000055c8f5dbd5fb sp 00007ffef53ee0e0 error 4 in nxagent[55c8f5cf2000+432000]

I don't see anything remarkable on the Windows 10 side.

Thank you for your efforts.

Kris Rehberg

---

From: [email-masked]
Date: Thu, 15 Mar 2018 23:14:26 -0400

I updated both the Windows 10 client and the Ubuntu 16.04 server to the very latest releases and the problem has disappeared.

Thank you for your help.  My server may have been a little too old for the new client version I was using.

 

-----Original Message-----
From: X2Go Bug Tracking System <[email-masked]>
To: krehberg <[email-masked]>
Sent: Fri, Mar 9, 2018 2:15 pm
Subject: Bug#1269: Acknowledgement (X2go server crashes on Ubuntu 16.04 starting at 2018-03-08)

Thank you for filing a new Bug report with X2Go.

This is an automatically generated reply to let you know your message
has been received.

Your message is being forwarded to the package maintainers and other
interested parties for their attention; they will reply in due course.

Your message has been sent to the package maintainer(s):
 X2Go Developers <[email-masked]>

If you wish to submit further information on this problem, please
send it to [email-masked].

Please do not send mail to [email-masked] unless you wish
to report a problem with the Bug-tracking system.

-- 
1269: http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=1269
X2Go Bug Tracking System
Contact [email-masked] with problems