Subject: Bug#1252: ssh broker : load balancing not working

From: Walid MOGHRABI <[email-masked]>
Date: Tue, 13 Feb 2018 18:13:03 +0100 (CET)

package: x2gobroker-ssh
version: 0.0.4.0-0~972~ubuntu16.04.1
priority: bug

Hi,

Tried using x2gobroker-ssh (0.0.4.0-0~972~ubuntu16.04.1) instead of classical http broker and finaly got it working but in ssh mode, load balancing on my server farm is not working, every session is redirected to the same server (the first one) while it is balanced correctly with the http broker on the same broker server.

I would love to send logs but it seems this broker don't produce log files or I couldn't find a way to get them.

Regards,
Walid Moghrabi

TRAVAUX.COM
BAT I - PARC CEZANNE 2 290 AVENUE GALILEE - CS 80403
13591 AIX EN PROVENCE CEDEX 3
---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you

---

From: Mike Gabriel <[email-masked]>
Date: Tue, 15 May 2018 12:22:39 +0000

Control: tags -1 pending

Hi,

On  Di 13 Feb 2018 18:13:03 CET, Walid MOGHRABI wrote:

> Tried using x2gobroker-ssh (0.0.4.0-0~972~ubuntu16.04.1) instead of  
> classical http broker and finaly got it working but in ssh mode,  
> load balancing on my server farm is not working, every session is  
> redirected to the same server (the first one) while it is balanced  
> correctly with the http broker on the same broker server.
>
> I would love to send logs but it seems this broker don't produce log  
> files or I couldn't find a way to get them.
>
>
> Regards,
> Walid Moghrabi

The issue has been a user privilege issue when init system is systemd.

It got fixed by  
https://code.x2go.org/gitweb?p=x2gobroker.git;a=commitdiff;h=00b89c53a793a535657a80b5a14cc05ad70bda82 and possibly follow-up  
commits.

It will be fixed with release 0.0.4.0 of the X2Go Session Broker.

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de