Subject: Bug#1240: broker bug with accentuated characters in password

From: Walid MOGHRABI <[email-masked]>
Date: Wed, 13 Dec 2017 19:29:07 +0100 (CET)

package: x2gobroker
priority: bug

Context : I'm using PAM auth with the X2Gobroker which relies on Samba/Winbind to use ActiveDirectory based authentication.
It works pretty well but some users couldn't auth even though we triple checked their username/password combination.
It appears these users had some accentuated characters in their password so I suppose there is a charset issue there, not sure if the broker uses iso/latin encoding or UTF8.

Regards,
Walid Moghrabi

TRAVAUX.COM
BAT I - PARC CEZANNE 2 290 AVENUE GALILEE - CS 80403
13591 AIX EN PROVENCE CEDEX 3
---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 18 Dec 2017 11:27:54 +0000

Hi Walid, hi all,

On  Mi 13 Dez 2017 19:29:07 CET, Walid MOGHRABI wrote:

> package: x2gobroker
> priority: bug
>
> Context : I'm using PAM auth with the X2Gobroker which relies on  
> Samba/Winbind to use ActiveDirectory based authentication.
> It works pretty well but some users couldn't auth even though we  
> triple checked their username/password combination.
> It appears these users had some accentuated characters in their  
> password so I suppose there is a charset issue there, not sure if  
> the broker uses iso/latin encoding or UTF8.
>
>
> Regards,
> Walid Moghrabi

I will work on this in the second week of January on a contracted basis.

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 12 Feb 2018 15:52:16 +0000

Hi Walid,

> the broker uses iso/latin encoding or UTF8.

Regarding the above issue, can you please test, if an authentication  
via the test tool works?

Steps:

1) Make sure the x2gobroker-authservice is running

2) x2gobroker-testauth --user=<user>

(Password is queried then after having hit <ENTER>.

Does that work? Or does this also fail? (Here it works).

Mike
-- 

DAS-NETZWERKTEAM

---

From: Walid MOGHRABI <[email-masked]>
Date: Mon, 12 Feb 2018 18:38:21 +0100 (CET)

Hi,

Just re-tried and now it works.
Dunno if something has been fixed since when I declared the bug ... maybe the upgrade to Python3.

Regards,
Walid Moghrabi

TRAVAUX.COM

----- Mail original ----- 

De: "Mike Gabriel" <[email-masked]> 
À: "Walid MOGHRABI" <[email-masked]>, [email-masked] 
Envoyé: Lundi 12 Février 2018 16:52:16 
Objet: Re: [X2Go-Dev] Bug#1240: broker bug with accentuated characters in password 

Hi Walid, 

Steps: 

Mike 
-- 

DAS-NETZWERKTEAM

---

From: Mike Gabriel <[email-masked]>
Date: Mon, 12 Feb 2018 20:18:17 +0000

Control: tags -1 pending
Control: fixed -1 0.4.0.0

Hi Walid

> maybe the upgrade to Python3.

Ok. Let's consider this issues resolved by the Python3 switch (which  
makes strings Unicode strings -- always).

Mike
-- 

DAS-NETZWERKTEAM