Subject: x2goclient / pyhoca does not honor ProxyJump in .ssh/config

From: Filip Krikava <[email-masked]>
Date: Tue, 17 Oct 2017 15:01:28 +0200

Package: x2goclient;
Version: 4.1.0.0

Due to the configuration of the university network, I have to first connect
to a frontend, then to a node and then to a VM. To make this easy to use, I
set ProxyJump in my .ssh/config. This works really well for ssh. However,
it does not seem to be recognized by x2go. I have to manually tunnel the
ssh port from the VM on my localhost to be able to connect there via x2go.
The same is for pyhoca-cli 0.5.0.3.

---

From: Mihai Moldovan <[email-masked]>
Date: Tue, 24 Oct 2017 10:08:38 +0200

Control: reassign -1 x2goclient

On 10/17/2017 03:01 PM, Filip Krikava wrote:
> Due to the configuration of the university network, I have to first connect to a
> frontend, then to a node and then to a VM. To make this easy to use, I set
> ProxyJump in my .ssh/config. This works really well for ssh. However, it does
> not seem to be recognized by x2go. I have to manually tunnel the ssh port from
> the VM on my localhost to be able to connect there via x2go. The same is for
> pyhoca-cli 0.5.0.3.

There is currently nothing that we could do about this.

The underlying SSH implementations - libssh for X2Go Client and paramiko for
PyHoca - do not support ProxyJump (yet.)

libssh might at some point do this, paramiko probably won't at all[0].

Mihai

[0] https://github.com/paramiko/paramiko/issues/1018

---

From: Carsten Bockelmann <[email-masked]>
Date: Mon, 27 Jul 2020 10:20:14 +0000

Package: x2goclient
Version: 4.1.2.2-2020.02.13

Similiar to this old bug https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=1225 ProxyJump is ignored under windows.

However, the underlying libssh 0.9.3 now supports ProxyJump and at least in ubuntu 20.04 it works out of the box. This is especially frustrating as host certificates are not supported in libssh which currently blocks any config in x2goclient that directly configures the bastion host as proxy (kex exchange method unsupported).

---

From: Ulrich Sibiller <[email-masked]>
Date: Mon, 27 Jul 2020 12:34:46 +0200

Hi,

I know all this libssh stuff is very frustrating. I have a setup where
libssh 0.9.3 just does not work and no one bothers to build a
x2goclient with the current libssh release (I neither have a windows
compilation setup nor am I doing packaging). However, I have seen a
branch by Mihai (ionic) somewhere (cannot find it right now) where he
seems to have started a version of x2goclient that uses openssh
instead of libssh. Maybe you can ask him for a beta version or support
him in testing.

Uli

On Mon, Jul 27, 2020 at 12:26 PM Carsten Bockelmann
<[email-masked]> wrote:
> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> https://lists.x2go.org/listinfo/x2go-dev

---

From: Carsten Bockelmann <[email-masked]>
Date: Mon, 27 Jul 2020 13:26:45 +0000

Ah sorry, for posting this twice. Had another windows open with the old bug address. :/

Regarding an openssh version: That would be great. Especially if you go the certificate route there seem to be all kinds of problems with other ssh libraries. Certificates are a very neat idea at first, but now more and more problems pop up due to incompatibilities 

Carsten

-----Ursprüngliche Nachricht-----
Von: Ulrich Sibiller <[email-masked]> 
Gesendet: Montag, 27. Juli 2020 12:35
An: Carsten Bockelmann <[email-masked]>; [email-masked]
Betreff: Re: [X2Go-Dev] Bug#1225: Windows x2go client ignores ProxyJump

Hi,

I know all this libssh stuff is very frustrating. I have a setup where libssh 0.9.3 just does not work and no one bothers to build a x2goclient with the current libssh release (I neither have a windows compilation setup nor am I doing packaging). However, I have seen a branch by Mihai (ionic) somewhere (cannot find it right now) where he seems to have started a version of x2goclient that uses openssh instead of libssh. Maybe you can ask him for a beta version or support him in testing.

Uli