Subject: Bug#1224: x2go desktop starts with incorrect resolution on Ubuntu 16.04

From: feng zhang <[email-masked]>
Date: Wed, 11 Oct 2017 18:07:49 -0400

Package: x2goserver
Version: 4.0.1.20-0

Server: Ubuntu 16.04 64-bit
Client: Linux Mint 18.2 Mate 64-bit

The server has Mate desktop and x2gomatebindings installed. The client machine has two monitors. When I configure the x2goclient to "Use whole display" of "Display #2," I would get a desktop of 800x600 upon logging in. If I suspend the session, and then resume it, I would get a desktop that correctly fits the entire monitor (1680x1050.)

When connecting to another server that runs Ubuntu 14.04, this problem doesn't occur.

The "Fullscreen" mode works correctly on both servers.

Thanks,

feng

-- 
-------------------
Feng Zhang, Ph.D.
LumArray, Inc.
15 Ward Street
Somerville, MA 02143
(617)996-5833

---

From: Walid MOGHRABI <[email-masked]>
Date: Thu, 12 Oct 2017 11:00:13 +0200 (CEST)

Most probably, your nx-libs are not up to date.

You should try nx-libs bleeding edge from the Arctica repository.

Follow this procedure to setup your sources.list correctly : https://wiki.x2go.org/doku.php/doc:howto:nx-libs-betatesting

Regards,
Walid Moghrabi

TRAVAUX.COM
BAT I - PARC CEZANNE 2 290 AVENUE GALILEE - CS 80403
13591 AIX EN PROVENCE CEDEX 3

----- Mail original ----- 

De: "feng zhang" <[email-masked]> 
À: [email-masked] 
Envoyé: Jeudi 12 Octobre 2017 00:07:49 
Objet: [X2Go-Dev] Bug#1224: x2go desktop starts with incorrect resolution on Ubuntu 16.04 

Package: x2goserver 
Version: 4.0.1.20-0 

Thanks, 

feng 

-- 
------------------- 
Feng Zhang, Ph.D. 
LumArray, Inc. 
15 Ward Street 
Somerville, MA 02143 
(617)996-5833 
_______________________________________________ 
x2go-dev mailing list 
[email-masked] 
https://lists.x2go.org/listinfo/x2go-dev
---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you