X2Go Bug report logs - #1200
Double clicks not recognized in Qt(4?/5?) applications

version graph

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: Bruno CAPELETO <bruno.capeleto@abcreseau.com>

Date: Thu, 10 Aug 2017 10:25:01 UTC

Severity: normal

Tags: build-win32

Found in version 4.1.0.0

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1200: [X2Go-Dev] Bug#1200: Bug#1200: Environment variables not set
Reply-To: Bruno CAPELETO <bruno.capeleto@abcreseau.com>, 1200@bugs.x2go.org
Resent-From: Bruno CAPELETO <bruno.capeleto@abcreseau.com>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Tue, 05 Sep 2017 08:45:01 +0000
Resent-Message-ID: <handler.1200.B1200.15046009761982@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 1200
X-X2Go-PR-Package: x2goserver
X-X2Go-PR-Keywords: 
Received: via spool by 1200-submit@bugs.x2go.org id=B1200.15046009761982
          (code B ref 1200); Tue, 05 Sep 2017 08:45:01 +0000
Received: (at 1200) by bugs.x2go.org; 5 Sep 2017 08:42:56 +0000
X-Spam-Checker-Version: SpamAssassin 3.4.1 (2015-04-28) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=3.0 tests=BAYES_00,DKIM_SIGNED,
	DKIM_VALID,HTML_MESSAGE,URIBL_BLOCKED autolearn=ham autolearn_force=no
	version=3.4.1
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id 039995DACB
	for <1200@bugs.x2go.org>; Tue,  5 Sep 2017 10:42:52 +0200 (CEST)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id MqbGsgQe-ycn for <1200@bugs.x2go.org>;
	Tue,  5 Sep 2017 10:42:47 +0200 (CEST)
Received: from mail-vk0-x232.google.com (mail-vk0-x232.google.com [IPv6:2607:f8b0:400c:c05::232])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id BB4A95DAC8
	for <1200@bugs.x2go.org>; Tue,  5 Sep 2017 10:42:46 +0200 (CEST)
Received: by mail-vk0-x232.google.com with SMTP id x85so5777138vkx.5
        for <1200@bugs.x2go.org>; Tue, 05 Sep 2017 01:42:46 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=abcreseau-com.20150623.gappssmtp.com; s=20150623;
        h=mime-version:in-reply-to:references:from:date:message-id:subject:to
         :cc;
        bh=dQTkKrGKaF20Mk2jIObRqWCUb07kHHlW2r3sjxnfEPg=;
        b=dkEvRAdF+U4TkHfj1MGvyTLZIsJkmlzWeZ2JT42y2hzn2Dos5Xwltu4vdgVg+UNRGw
         rkLEOa5OXNGvfUu3pZxWYEzS4KQyb/ewQXQ6S/XKyvwWwbesch5ZeVp+OTsl2695U1P4
         f0E0y21tEKj4bwfcPmkZLxRRXgj8mUHqLQyUaPXNvA/IpzA2/bsbz8z4Id+3SH6aLZnu
         +lN90hQZ1D+oCq8VFx9RLCKUU6uXClMxN/+RjZ52n6+Q6jSMiZucLqoQtuc5LZEUjEuV
         5inyh6YybzH5rcegy/xjNWhP3mxWhbeJF0bvljw0yFAPV6Vt8MCBaxQUoZOAPVJgJ9eM
         kS4w==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=1e100.net; s=20161025;
        h=x-gm-message-state:mime-version:in-reply-to:references:from:date
         :message-id:subject:to:cc;
        bh=dQTkKrGKaF20Mk2jIObRqWCUb07kHHlW2r3sjxnfEPg=;
        b=dJQBFmlYq29q1Pra8pTH7h5pGJe4wx9ZWr5ZF7weq5hjxBK8n1STEcNxqdmeNLS436
         j5cuHQKzrARR3VHH1JivQWxNF+oKXqYcqqN2Vko3NRRhQY9d4MGKy/0UXcmEv0Mh9dDd
         EP9PKo/BcOdjczq/ecvzvzaGV7/eICd3nZNkR5fxJE1t3BNHU+3lGd4RpwgAjzX/XQ/2
         63KPoVSX3aufLKpDk0mvaFA+erkgytVU6IY3jq867+/JxdK8Dh7ZJkancvxxD299zMS4
         Cf0j9NY9KLZgSwdXtQyIgYcwgt5n+TBNAoEU9pLUKdcyxkCeQ0shtZUvAeeip96PhKw2
         Y1BQ==
X-Gm-Message-State: AHPjjUgJ4RaM7/tiv5mlhWfmLBFpzYKQUXk2NVzH2vTK7q+58vYjsfIM
	Kqp13dzMH4cljNGcSBncuG4+Xv9RYKhB
X-Google-Smtp-Source: ADKCNb4N8rUaSgtAtglqe7q/UWzMHSusYEyu+m9hXQJMt28HKI8SWhTe3Xe7VuZlcQrKIP52YZPppaOT/Gz1nUH/bjM=
X-Received: by 10.31.204.194 with SMTP id c185mr1805528vkg.126.1504600965229;
 Tue, 05 Sep 2017 01:42:45 -0700 (PDT)
MIME-Version: 1.0
Received: by 10.31.94.214 with HTTP; Tue, 5 Sep 2017 01:42:44 -0700 (PDT)
X-Originating-IP: [78.233.84.236]
In-Reply-To: <CABa3fk7KB7ZYpuVBMOAXifm8V8LjoYweeKzO84-BSeT4rs1NjQ@mail.gmail.com>
References: <CABa3fk4QCDwjuqZbXPzMWDqd0vrpJGVYAEZzm1VBKoAis8n=zg@mail.gmail.com>
 <5e2e5f4b-b445-09d5-1834-ad53f845a03e@ionic.de> <CABa3fk7jruJbtVzhC=zUd1gcVwJr88inRvX-z8e9N_gkLZ9tew@mail.gmail.com>
 <CABa3fk5qReW5skVWqahTTmYyyNy-hN8Op1qU4n15zO2jJz9YeQ@mail.gmail.com>
 <21445d8f-0208-1d84-b664-0ad6fc3c31cf@ionic.de> <CABa3fk6xixQ1xvPQDNaekQ_XWbpQtKHBYJa3zSfADfA9-aznHw@mail.gmail.com>
 <59ae4597.06981c0a.d2c4b.2b4d@mx.google.com> <CABa3fk7B4o54NigPNXB=RD-XcUu_foin6+LhSQDZC5jw=bNNtQ@mail.gmail.com>
 <CABa3fk7KB7ZYpuVBMOAXifm8V8LjoYweeKzO84-BSeT4rs1NjQ@mail.gmail.com>
From: Bruno CAPELETO <bruno.capeleto@abcreseau.com>
Date: Tue, 5 Sep 2017 10:42:44 +0200
Message-ID: <CABa3fk66-r+=y-u3STVjUJBeY4p-3D7H3yb5Y8r=-_o+EaQV7w@mail.gmail.com>
To: Bruno CAPELETO <bruno.capeleto@abcreseau.com>, 1200@bugs.x2go.org
Cc: Ulrich Sibiller <ulrich.sibiller@gmail.com>, Mihai Moldovan <ionic@ionic.de>
Content-Type: multipart/alternative; boundary="94eb2c07d33a0fc14505586d36fd"
[Message part 1 (text/plain, inline)]
Found : in sshd_config, one must use the "UsePAM yes" directive

I do not really see the link with the locales, and on top of that that open
some security holes I guess.
For example, adding this instruction I had to add additional instructions
to forbid the password authentication.

Conclusions for the reported bugs :
1. locales are set properly
2. I do not have the LXDE error "no session for pid..." anylonger
3. single app mode seems to work for my software (no crash so far)
4. I could not test right now ; I guess that one is related to something
else...


2017-09-05 9:28 GMT+02:00 Bruno CAPELETO <bruno.capeleto@abcreseau.com>:

> The issue came from my home-made sshd_config file.
>
> I still work it up and will give here the solution in a few minutes.
>
>
> 2017-09-05 9:07 GMT+02:00 Bruno CAPELETO <bruno.capeleto@abcreseau.com>:
>
>> I did dpkg-reconfigure locales as root.
>>
>> Then I get :
>>
>> ~# locale
>> LANG=fr_FR.UTF-8
>> LANGUAGE=
>> LC_CTYPE="fr_FR.UTF-8"
>> LC_NUMERIC="fr_FR.UTF-8"
>> LC_TIME="fr_FR.UTF-8"
>> LC_COLLATE="fr_FR.UTF-8"
>> LC_MONETARY="fr_FR.UTF-8"
>> LC_MESSAGES="fr_FR.UTF-8"
>> LC_PAPER="fr_FR.UTF-8"
>> LC_NAME="fr_FR.UTF-8"
>> LC_ADDRESS="fr_FR.UTF-8"
>> LC_TELEPHONE="fr_FR.UTF-8"
>> LC_MEASUREMENT="fr_FR.UTF-8"
>> LC_IDENTIFICATION="fr_FR.UTF-8"
>> LC_ALL=
>>
>>
>> But when I ssh with my user login (my x2go user), I get :
>>
>> ~#locale
>> LANG=
>> LANGUAGE=
>> LC_CTYPE="POSIX"
>> LC_NUMERIC="POSIX"
>> LC_TIME="POSIX"
>> LC_COLLATE="POSIX"
>> LC_MONETARY="POSIX"
>> LC_MESSAGES="POSIX"
>> LC_PAPER="POSIX"
>> LC_NAME="POSIX"
>> LC_ADDRESS="POSIX"
>> LC_TELEPHONE="POSIX"
>> LC_MEASUREMENT="POSIX"
>> LC_IDENTIFICATION="POSIX"
>> LC_ALL=
>>
>>
>> Obviously the dpkg-reconfigure locales did not set the locales
>> system-wide.
>> I am working in this direction, still any help is appreciated (even if it
>> now looks like a ssh/locales-related issue...)
>>
>>
>> 2017-09-05 8:35 GMT+02:00 Ulrich Sibiller <ulrich.sibiller@gmail.com>:
>>
>>> Maybe you could provide a VM with the non-working Installation so we can
>>> have a look at it.
>>>
>>> Uli
>>> ------------------------------
>>> Von: Bruno CAPELETO <bruno.capeleto@abcreseau.com>
>>> Gesendet: ‎05.‎09.‎2017 08:10
>>> An: Mihai Moldovan <ionic@ionic.de>
>>> Cc: 1200@bugs.x2go.org
>>> Betreff: [X2Go-Dev] Bug#1200: Environment variables not set
>>>
>>> Dear Mihai,
>>>
>>> What good piece of news to start the day with !!!
>>>
>>> So you do not see that "bug" on a fresh install. Unfortunately I see it,
>>> and also on a fresh install. It is even worse : I see it on 3 fresh server
>>> installs :
>>> - Ubuntu 14.04.4 LTS (old installation)
>>> - Debian GNU/Linux 8
>>> - Debian GNU/Linux 9
>>>
>>> So it seems that I do not install the same way as the others. Let me
>>> give the details :
>>> - installation in text mode (as these are remote servers)
>>> - installation of LXDE *only* (tasksel : LXDE and ssh)
>>> - installation of X2Go
>>>
>>> On the 2 systems I could test locally (Debian 8 and Debian 9), the
>>> French locales are set properly when the user starts a local X session (the
>>> menu is in French).
>>> However, on a remote X2Go session, the menu always appears in English
>>> (no need to start the software).
>>>
>>> Thanks for your help,
>>> Bruno
>>>
>>> 2017-09-05 5:34 GMT+02:00 Mihai Moldovan <ionic@ionic.de>:
>>>
>>>> On 09/04/2017 05:44 PM, Bruno CAPELETO wrote:
>>>> > People in Laurux's forum have reported this software works in single
>>>> app mode
>>>> > but on an Ubuntu server.
>>>>
>>>> Okay, I have just tried to reproduce your issues in a new, fresh Debian
>>>> Stretch
>>>> VM. Only installed the core system, x2goserver, x2goserver-xsession,
>>>> lxde and
>>>> gambas3.
>>>>
>>>> Then (since I installed the system using the en_US.utf8 locale), ran
>>>> dpkg-reconfigure locales, selected fr_FR.* to be generated and set the
>>>> default
>>>> locale to fr_FR.utf8.
>>>>
>>>> Started up a new X2Go session (desktop session, LXDE) and was greeted
>>>> by a
>>>> French-speaking LXDE instance (with some English text from the clipboard
>>>> manager, that does not seem to have a French localization. No problem.)
>>>>
>>>> Afterwards, started gambas3 in the LXDE desktop session. Worked fine.
>>>> And showed
>>>> up in French.
>>>>
>>>>
>>>> Next up: started gambas3 in single application mode. Came up fine and
>>>> in French.
>>>>
>>>>
>>>> And just for fun, I then went on, downloaded Laurux3.tar.gz from the
>>>> website
>>>> (since this software doesn't seem to be packaged within Debian
>>>> directly...),
>>>> installed gambas3-gb-qt4 and gambas3-gb-qt4-ext (since it looked like
>>>> these
>>>> modules were missing) and started Laurux3.gambas in the LXDE instance.
>>>> It
>>>> greeted me in French with a dialog to setup MySQL. I skipped this and
>>>> Gambas3-Laurux started up. Again, everything was in French.
>>>>
>>>> Last thing: started /home/ionic/applications/Laurux3/Laurux3.gambas
>>>> (obviously
>>>> the path I extracted it to) in a single application session. Again, I
>>>> was
>>>> greeted by the dialog to create a MySQL database. Skipped this, and
>>>> Laurux-Gambas came up. All in French. It looked weird, but that's
>>>> because in
>>>> single application mode, we don't yet have an XSETTINGS daemon running
>>>> that
>>>> would enable Qt4 to look up its theme settings, so a ugly fallback
>>>> theme is
>>>> being used by default.
>>>>
>>>>
>>>> So far, I'm unable to reproduce any issue (and curiously, the Laurux
>>>> version
>>>> from their homepage seems to be using Qt4 instead of Qt5 as well, so I
>>>> wonder
>>>> how you came up with Qt4 before.)
>>>>
>>>> I wasn't able to test the double-clicking issue, since all tests were
>>>> carried
>>>> out using X2Go Client on Linux.
>>>>
>>>>
>>>> I'd like to understand why your env variables are not being set
>>>> correctly, but
>>>> it doesn't seem to be systematic X2Go bug. With a cleanly installed
>>>> system, this
>>>> does not seem to happen.
>>>>
>>>>
>>>>
>>>> Mihai
>>>>
>>>>
>>>
>>
>> _______________________________________________
>> x2go-dev mailing list
>> x2go-dev@lists.x2go.org
>> https://lists.x2go.org/listinfo/x2go-dev
>>
>
>
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Feb 5 04:33:36 2023; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.