Subject: Multihead fullscreen not working with TCE client in displaymanager mode

From: Walid MOGHRABI <[email-masked]>
Date: Mon, 24 Jul 2017 15:16:07 +0200 (CEST)

Package: x2gothinclient 
Version: 4.1.0.0-2017.03.11

Using latest Arctica's NX-Libs xrandr support is far better and multihead support in fullscreen mode with the Linux x2goclient works like a charm.
For example, with MATE, the panels are restricted to the first screen and the second one is acting like a real secondary screen in extended desktop mode with working boundaries when putting applications in fullscreen (ie. they don't extend to the whole display as before but they are restricted to their including screen).

So with the Linux client installed on a desktop (I'm personaly using Ubuntu 16.04 + Unity desktop) it works great whereas, in TCE / Displaymanager mode, multiple monitors are supported but the desktop is stretched as if it was only one big screen and not 2 separated screens.

Any idea why, using the same base OS and libs (Ubuntu 16.04 + X2Go client "Heuler" + Arctica libs) I get different multiscreen support ?
I think this is related to randr support but I don't know what differs and why it behaves differently on one case and the other.

Regards,
Walid Moghrabi

TRAVAUX.COM
BAT I - PARC CEZANNE 2 290 AVENUE GALILEE - CS 80403
13591 AIX EN PROVENCE CEDEX 3
---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you

---

From: Ulrich Sibiller <[email-masked]>
Date: Mon, 24 Jul 2017 16:23:20 +0200

I suspect the X server in TCE does not offer proper XINERAMA support.
So nxagent does not know about multiple monitors. You can check with
xdpyinfo -ext XINERAMA on the TCE X server (don't know how to access
that.)

On Mon, Jul 24, 2017 at 3:16 PM, Walid MOGHRABI
<[email-masked]> wrote:
> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> https://lists.x2go.org/listinfo/x2go-dev

---

From: Walid MOGHRABI <[email-masked]>
Date: Mon, 24 Jul 2017 18:04:05 +0200 (CEST)

Doesn't seems to be this ... here is the output (truncated) from the TCE and from my laptop ... they are very similar :

========================================================================
TCE output
========================================================================
name of display:    :0
version number:    11.0
vendor string:    The X.Org Foundation
vendor release number:    11804000
X.Org version: 1.18.4
maximum request size:  16777212 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    7
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 4, bits_per_pixel 8, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 15, bits_per_pixel 16, scanline_pad 32
    depth 16, bits_per_pixel 16, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
    depth 32, bits_per_pixel 32, scanline_pad 32
keycode range:    minimum 8, maximum 255
focus:  window 0x600005, revert to Parent
number of extensions:    29
    BIG-REQUESTS
    Composite
    DAMAGE
    DOUBLE-BUFFER
    DPMS
    DRI2
    GLX
    Generic Event Extension
    MIT-SCREEN-SAVER
    MIT-SHM
    Present
    RANDR
    RECORD
    RENDER
    SECURITY
    SGI-GLX
    SHAPE
    SYNC
    X-Resource
    XC-MISC
    XFIXES
    XFree86-DGA
    XFree86-VidModeExtension
    XINERAMA
    XInputExtension
    XKEYBOARD
    XTEST
    XVideo
    XVideo-MotionCompensation
default screen number:    0
number of screens:    1

screen #0:
  dimensions:    3840x1080 pixels (1016x285 millimeters)
  resolution:    96x96 dots per inch
  depths (7):    24, 1, 4, 8, 15, 16, 32
========================================================================

========================================================================
Laptop output
========================================================================
name of display:    :0
version number:    11.0
vendor string:    The X.Org Foundation
vendor release number:    11804000
X.Org version: 1.18.4
maximum request size:  16777212 bytes
motion buffer size:  256
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    7
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 4, bits_per_pixel 8, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 15, bits_per_pixel 16, scanline_pad 32
    depth 16, bits_per_pixel 16, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
    depth 32, bits_per_pixel 32, scanline_pad 32
keycode range:    minimum 8, maximum 255
focus:  window 0x6e0686a, revert to Parent
number of extensions:    29
    BIG-REQUESTS
    Composite
    DAMAGE
    DOUBLE-BUFFER
    DPMS
    DRI2
    DRI3
    GLX
    Generic Event Extension
    MIT-SCREEN-SAVER
    MIT-SHM
    Present
    RANDR
    RECORD
    RENDER
    SECURITY
    SGI-GLX
    SHAPE
    SYNC
    X-Resource
    XC-MISC
    XFIXES
    XFree86-DGA
    XFree86-VidModeExtension
    XINERAMA
    XInputExtension
    XKEYBOARD
    XTEST
    XVideo
default screen number:    0
number of screens:    1

screen #0:
  dimensions:    3840x1080 pixels (1016x286 millimeters)
  resolution:    96x96 dots per inch
  depths (7):    24, 1, 4, 8, 15, 16, 32
========================================================================

What is strange is that in both cases, here is only one screen detected which aggregates both monitors.	

Regards,
Walid Moghrabi

TRAVAUX.COM

----- Mail original ----- 

De: "Ulrich Sibiller" <[email-masked]> 
À: "Walid MOGHRABI" <[email-masked]>, [email-masked] 
Envoyé: Lundi 24 Juillet 2017 16:23:20 
Objet: Re: [X2Go-Dev] Bug#1197: Multihead fullscreen not working with TCE client in displaymanager mode 

---

---

From: Stefan Baur <[email-masked]>
Date: Mon, 24 Jul 2017 18:40:04 +0200

> Using latest Arctica's NX-Libs xrandr support is far better and multihead support in fullscreen mode with the Linux x2goclient works like a charm.
[...]
> So with the Linux client installed on a desktop (I'm personaly using Ubuntu 16.04 + Unity desktop) it works great whereas, in TCE / Displaymanager mode, multiple monitors are supported but the desk…

Are you sure your custom TCE build includes the Arctica NX-Libs?
I would suggest logging in to a running TCE and comparing the output of
"dpkg -l".

Kind Regards,
Stefan Baur

-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: Walid MOGHRABI <[email-masked]>
Date: Mon, 24 Jul 2017 18:55:32 +0200 (CEST)

Here is what I get :

root@TCE-CLIENT-DELL-VOSTRO230-33H4W4J:~# dpkg -l | grep nx
ii  nxproxy                            2:3.5.99.8-0.1+git20170630.2313+16.04.release.1                                  amd64        NX proxy

Regards,
Walid Moghrabi

TRAVAUX.COM

----- Mail original ----- 

De: "Stefan Baur" <[email-masked]> 
À: "Walid MOGHRABI" <[email-masked]>, [email-masked] 
Envoyé: Lundi 24 Juillet 2017 18:40:04 
Objet: Re: [X2Go-Dev] Bug#1197: Multihead fullscreen not working with TCE client in displaymanager mode 

[...] 

Kind Regards, 
Stefan Baur

---

From: Stefan Baur <[email-masked]>
Date: Mon, 24 Jul 2017 18:57:23 +0200

> ii  nxproxy                            2:3.5.99.8-0.1+git20170630.2313+16.04.release.1                                  amd64        NX proxy

And the laptop/machine where everything works the way you want it is
running which version of that package?

-Stefan

---

From: Ulrich Sibiller <[email-masked]>
Date: Mon, 24 Jul 2017 20:35:20 +0200

If I understand correctly  TCE is not the side where the nxagent is
running. So the version oft nx-libs there does not matter.

I am wondering how the connection from the laptop can generate xinerama
info as the laptop's xserver, that must provide the data, does not. Please
post a log oft the nxagent startup. And the output oft xdpyinfo -ext
XINERAMA within the session.

Uli

Am 24.07.2017 18:50 schrieb "Stefan Baur" <[email-masked]>:

Am 24.07.2017 um 15:16 schrieb Walid MOGHRABI:

> Using latest Arctica's NX-Libs xrandr support is far better and multihead
support in fullscreen mode with the Linux x2goclient works like a charm.
[...]
> So with the Linux client installed on a desktop (I'm personaly using
Ubuntu 16.04 + Unity desktop) it works great whereas, in TCE /
Displaymanager mode, multiple monitors are supported but the desktop is
stretched as if it was only one big screen and not 2 separated screens.

Kind Regards,
Stefan Baur

---

From: Walid MOGHRABI <[email-masked]>
Date: Mon, 24 Jul 2017 21:49:41 +0200 (CEST)

Well, I'll do this tomorrow.
The only thing I can tell is that multihead IS working on my laptop and I was quite sceptical too when I saw the output from my laptop ... I would have thought that it would list 2 separate screens at least and not on huge aggregated one.

Are there any requirements for randr to work with X2Go and Arctica libs on the client side ?
Maybe there are some tools/libs missing on the TCE side.
I saw that x11-xserver-utils where missing on my TCE side which means xrandr tool was missing and I couldn't use it.
Anyway, installing it changed a thing (before, the second screen was black when the broker logon was there, now it is blue and the screen ordering is different) but it didn't changed anything once the X2Go session was opened (still MATE Desktop stretched on both screens and only 1 huge monitor seen by the screen utility).

Regards,
Walid Moghrabi

TRAVAUX.COM

----- Mail original ----- 

De: "Ulrich Sibiller" <[email-masked]> 
À: "Stefan Baur" <[email-masked]>, [email-masked] 
Envoyé: Lundi 24 Juillet 2017 20:35:20 
Objet: [X2Go-Dev] Bug#1197: Bug#1197: Bug#1197: Multihead fullscreen not working with TCE client in displaymanager mode 

If I understand correctly TCE is not the side where the nxagent is running. So the version oft nx-libs there does not matter. 

I am wondering how the connection from the laptop can generate xinerama info as the laptop's xserver, that must provide the data, does not. Please post a log oft the nxagent startup. And the output oft xdpyinfo -ext XINERAMA within the session. 

Uli 

Am 24.07.2017 18:50 schrieb "Stefan Baur" < [email-masked] >: 

[...] 

Kind Regards, 
Stefan Baur

---

From: Walid MOGHRABI <[email-masked]>
Date: Tue, 25 Jul 2017 11:42:47 +0200 (CEST)

Hi,

Here a log files taken  from the x2goserver when logged from my laptop (where it works) and from my tce (where it works badly).
I also attach the xdpyinfo output taken from within the x2go session from my laptop and from my tce ... As you will see, they are strictly identical.

In the log files, apparently, RANDR and XINERAMA support is enabled in both cases.

Regards,
Walid Moghrabi

TRAVAUX.COM

----- Mail original ----- 

De: "Walid MOGHRABI" <[email-masked]> 
À: [email-masked], [email-masked] 
Envoyé: Lundi 24 Juillet 2017 21:49:41 
Objet: [X2Go-Dev] Bug#1197: Bug#1197: Bug#1197: Bug#1197: Multihead fullscreen not working with TCE client in displaymanager mode 

Regards, 
Walid Moghrabi 

TRAVAUX.COM 

----- Mail original ----- 

Uli 

[...] 

Kind Regards, 
Stefan Baur

---

From: Ulrich Sibiller <[email-masked]>
Date: Tue, 25 Jul 2017 13:23:14 +0200

Thanks.

First, both sessions do not offer xinerama to their clients.
Second: I mean the session log from nxagent, not from x2go. I cannot
check here for the correct filename. It is somewhere in ~/.x2go on the
server and starts similar to the following. Please also post the
xrandr output from within the session.
-------------------------------------
NXAGENT - Version 3.5.0
Copyright (C) 2001, 2011 NoMachine.

                                  See http://www.nomachine.com/ for
more information.
Info: Agent running with pid '2948'.
Session: Starting session at 'Tue Jul 25 13:19:14 2017'.

                              Info: Using alpha channel in render
extension.

Info: Not using local device configuration changes.

                                ...
-------------------------------------

I am a bit puzzled now. Is your x2goclient configuration really
absolutely identical for both setups? Can you retry the (working)
laptop session with a fresh user profile?

Uli

---

From: Walid MOGHRABI <[email-masked]>
Date: Tue, 25 Jul 2017 14:30:34 +0200 (CEST)

I'm sorry but I don't find anything looking similar in my ~/.x2go folder (nor anywhere else in my home in fact ...)

Here are the xrandr output from my laptop and from my TCE ... there you see a real difference.

Regards,
Walid Moghrabi

TRAVAUX.COM

----- Mail original ----- 

De: "Ulrich Sibiller" <[email-masked]> 
À: "Walid MOGHRABI" <[email-masked]>, [email-masked] 
Envoyé: Mardi 25 Juillet 2017 13:23:14 
Objet: Re: [X2Go-Dev] Bug#1197: Bug#1197: Bug#1197: Bug#1197: Bug#1197: Multihead fullscreen not working with TCE client in displaymanager mode 

Thanks. 

... 

Uli 

---

---

From: Walid MOGHRABI <[email-masked]>
Date: Tue, 25 Jul 2017 14:42:57 +0200 (CEST)

Mea culpa, finally found the logs you asked for, please find them attached.

Regards,
Walid Moghrabi

TRAVAUX.COM

----- Mail original ----- 

Thanks. 

... 

Uli 

---