Subject: Multihead fullscreen not working with Windows x2goclient

From: Walid MOGHRABI <[email-masked]>
Date: Wed, 19 Jul 2017 12:04:51 +0200 (CEST)

Package: x2gothinclient 
Version: 4.1.0.0-2017.03.11

Using latest Arctica's NX-Libs xrandr support is far better and multihead support in fullscreen mode with the Linux x2goclient works like a charm.
For example, with MATE, the panels are restricted to the first screen and the second one is acting like a real secondary screen in extended desktop mode with working boundaries when putting applications in fullscreen (ie. they don't extend to the whole display as before but they are restricted to their including screen).

So with the Linux client it works great whereas, with the latest Windows client, it doesn't work at all.
Asking the client to use fullscreen in a multihead setup leads to the client going fullscreen on one screen only as if you had chosen "display x" except that you can't choose the display, it will take the main one in any case.

Would be great to fix this, I suppose this is related to the VcxSrv component.

Regards,
Walid Moghrabi

TRAVAUX.COM
BAT I - PARC CEZANNE 2 290 AVENUE GALILEE - CS 80403
13591 AIX EN PROVENCE CEDEX 3
---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you

---

From: Ulrich Sibiller <[email-masked]>
Date: Sat, 22 Jul 2017 23:10:35 +0200

> Would be great to fix this, I suppose this is related to the VcxSrv component.

I suspect the same. VcxSrv has an option for multiple monitors. In
X2GoClient go to the settings menu at the top and change the xserver
setting to "I want to use an other X server". Normally VcxSrv is
preset. You can then extend the lower config line by "-multimonitor"
(or was it "-multimonitors"). Does ist work?

You can run VcxSrv /? from as cmd window. It will print the help to a
logfile and tell you where to find it. In the help you can find some
more options regarding screen sizes, maybe you can solve the problem
with them.

I do not have a windows machine with multiple monitors so I cannot test here.

Uli