Subject: Bug#1194: TERM variable not set

From: Patryk P <[email-masked]>
Date: Sat, 15 Jul 2017 08:16:11 +0000

Package: X2Go Client v. 4.1.0.0 (Qt - 4.8.6.) for windows 7 32bit

Console output:

---

From: Mihai Moldovan <[email-masked]>
Date: Sat, 12 Mar 2022 15:43:53 +0100

Control: reassign -1 x2goclient 4.1.0.0
Control: tag -1 invalid
Control: close -1

* On 7/15/17 10:16 AM, Patryk P wrote:
> 2017-07-15 10_15_28-X2Go Client (Debug).png

Not a bug within X2Go Client.

Your shell startup scripts (likely something like ~/.bashrc, ~/.bash_profile,
~/.profile or the like) use commands that expect TERM to be set correctly, which
is only the case for interactive sessions.

X2Go Client does not use interactive sessions.

Wrap code that might need an interactive session or terminal in if tty -s; then
...; fi or something like this in your startup scripts.

Mihai

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Sat, 12 Mar 2022 14:45:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the x2goclient package:

#1194: TERM variable not set

It has been closed by Mihai Moldovan <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mihai Moldovan <[email-masked]> by
replying to this email.

-- 
1194: https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=1194
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Re: [X2Go-Dev] Bug#1194: TERM variable not set
From: Mihai Moldovan <[email-masked]>
To: [email-masked]
Date: Sat, 12 Mar 2022 15:43:53 +0100

Mihai

Subject: TERM variable not set
From: Patryk P <[email-masked]>
To: [email-masked]
Date: Sat, 15 Jul 2017 08:16:11 +0000

Console output: