Subject: Makefile: not installing etc/x2goplugin-apache.conf anywhere

From: Mike Gabriel <[email-masked]>
Date: Wed, 28 Jun 2017 09:58:40 +0000

Package: x2goclient
Version: 4.1.0.0
Severity: minor

Hi,

I am currently converting the Debian x2goclient package to actually  
use those files in the package that are placed into DESTDIR by the the  
make install target of the main Makefile in x2goclient's tarball.

I stumble over the below issue when doing that:

```
dh_install
dh_install: Cannot find (any matches for) "etc/x2goplugin-apache.conf"  
(tried in "." and "debian/tmp")
dh_install: x2goplugin-provider missing files: etc/x2goplugin-apache.conf
dh_install: missing files, aborting
```

Obviously, etc/x2goplugin-apache.conf needs to be handled in Makefile  
at make install.

Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de

---

From: Mike Gabriel <[email-masked]>
Date: Wed, 28 Jun 2017 10:04:37 +0000

Control: close -1
Control: tags -1 not-a-bug

Hi

On  Mi 28 Jun 2017 11:58:40 CEST, Mike Gabriel wrote:

> use those files in the package that are placed into DESTDIR by the  
> the make install target of the main Makefile in x2goclient's tarball.
>
> dh_install: Cannot find (any matches for)  
> "etc/x2goplugin-apache.conf" (tried in "." and "debian/tmp")
> Obviously, etc/x2goplugin-apache.conf needs to be handled in  
> Makefile at make install.
>
> Mike

Ignore the noise. The debian/x2goplugin-provider.install file was  
flawed on my end.

Mike
-- 

DAS-NETZWERKTEAM