X2Go Bug report logs - #1181
Unable to logout of KDE4 when a PolicyKit prompt is up

version graph

Package: nx-libs; Maintainer for nx-libs is X2Go Developers <x2go-dev@lists.x2go.org>;

Reported by: Mike DePaulo <mikedep333@gmail.com>

Date: Sat, 27 May 2017 16:10:02 UTC

Severity: normal

Found in version

Full log

🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1181: Unable to logout of KDE4 when a PolicyKit prompt is up
Reply-To: Mike DePaulo <mikedep333@gmail.com>, 1181@bugs.x2go.org
Resent-From: Mike DePaulo <mikedep333@gmail.com>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Sat, 27 May 2017 16:10:02 +0000
Resent-Message-ID: <handler.1181.B.14959011443174@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: report 1181
X-X2Go-PR-Package: nx-libs
Received: via spool by submit@bugs.x2go.org id=B.14959011443174
          (code B); Sat, 27 May 2017 16:10:02 +0000
Received: (at submit) by bugs.x2go.org; 27 May 2017 16:05:44 +0000
X-Spam-Checker-Version: SpamAssassin 3.4.1 (2015-04-28) on
X-Spam-Level: *
X-Spam-Status: No, score=1.2 required=3.0 tests=BAYES_50,DKIM_SIGNED,
	autolearn_force=no version=3.4.1
Received: from localhost (localhost [])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id 989A75DAD3
	for <submit@bugs.x2go.org>; Sat, 27 May 2017 18:05:43 +0200 (CEST)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([])
	by localhost (ymir.das-netzwerkteam.de []) (amavisd-new, port 10024)
	with ESMTP id Oq4r3SliebMx for <submit@bugs.x2go.org>;
	Sat, 27 May 2017 18:05:36 +0200 (CEST)
Received: from mail-lf0-f48.google.com (mail-lf0-f48.google.com [])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 9553D5DA96
	for <submit@bugs.x2go.org>; Sat, 27 May 2017 18:05:36 +0200 (CEST)
Received: by mail-lf0-f48.google.com with SMTP id m18so18204787lfj.0
        for <submit@bugs.x2go.org>; Sat, 27 May 2017 09:05:36 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20161025;
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=1e100.net; s=20161025;
X-Gm-Message-State: AODbwcDhzA1sOoWdv1ZNDNCtVpkKb/KRzNDQzJGiVhH2p+qq2aCwJlhc
X-Received: by with SMTP id n101mr1630311lfi.93.1495901135898;
 Sat, 27 May 2017 09:05:35 -0700 (PDT)
MIME-Version: 1.0
Received: by with HTTP; Sat, 27 May 2017 09:05:35 -0700 (PDT)
From: Mike DePaulo <mikedep333@gmail.com>
Date: Sat, 27 May 2017 12:05:35 -0400
Message-ID: <CAMKht8gsBDMvZkpMo8xbLdYOKdOZWnFaUSL1_5cM2Bv=t3=g8g@mail.gmail.com>
To: "submit@bugs.x2go.org" <submit@bugs.x2go.org>
Content-Type: multipart/alternative; boundary="001a114056acd31b7c0550839fca"
[Message part 1 (text/plain, inline)]
Package: nx-libs

Note: This bug might actually be in x2goserver instead.

1. You connect to a KDE4 server
2. You maximize the session
3. #2 This triggers a PolicyKit prompt "Authentication is required to
create a color managed device"
4. You select to log out of KDE
5. The screen does not turn black. There is a log out dialog, but it is
actually hidden behind the PolicyKit prompt.
6. You are unable to click the log out button in the log out dialog because
it is not visible. Hitting escape does not help either. You are unable to
move the PolicyKit prompt.

Note: In the absence of the PolicyKit dialog, the screen still does not
turn black.

Note: #3. Is a nuisance in and of itself. It is related to the fact that
PolicyKit applies different rules for physical logins (active) vs remote
logins (inactive.) It is especially a nuisance because you have to click
"cancel" repeatedly. However, it is not what I am reporting as a bug.

If you have a local session, this bug does not occur:
3. Trigger a PolicyKit prompt by opening up a terminal and running `pkexec
vi` for example.
5. The screen turns black, and the log out dialog appears.
6. You click the log out button and all is well.

This can be worked around by moving the PolicyKit prompt before logging
out, or by hitting "cancel" repeatedly.

I am confident this can be worked around also by writing new PolicyKit
rules that prevent the "color managed device" prompt. I will post how soon.
However, other PolicyKit prompts can presumably still cause this issue.

Server configuration 1: CentOS 7.3 with KDE4 & EPEL's x2goserver
& nxagent
Server configuration 2: CentOS 7.3 with KDE4 & nightly x2goserver &
nxagent (from the copr repo mikedep333/nx-libs-3.6)
Client 1: Fedora 25 x64 with Fedora's x2goclient & nxproxy
Client 2: Windows 10 1703 x64 with X2Go Client
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.

X2Go Developers <owner@bugs.x2go.org>. Last modified: Tue Jun 25 15:38:18 2024; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.