Subject: Bug#1180: "Failed to restore all the required visuals" when switching from VcXsrv 1.19.2.0 to 1.17.0.0-3

From: Mike DePaulo <[email-masked]>
Date: Sat, 27 May 2017 11:46:20 -0400

Package: x2goclient
Version: 4.1.0.0
Tags: +build-win32

When you do the following:
1. Replace x2goclient's VcXsrv folder with that upstream VcXsrv 1.19.2.0
2. Start an X2Go session
3. Suspend the session.
4. Replace x2goclient's VcXsrv folder with its default version, 1.17.0.0-3
(X2Go/Arctica builds)
5. Reconnect & resume the X2Go session

You get the error message:
Failed to restore all the required visuals
And the session fails to resume.

Yes, this is the same symptom as bug #891, but under different
circumstances.
https://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=891

I am sure it could be reproduced if you were to specify VcXsrv 1.19.2.0 as
an external X server instead.

Server: RHEL 7.3 with EPEL's x2goserver 4.0.1.20-1.el7 &
nxagent 3.5.0.32-3.el7 & xfce 4.12.1
Client System: Windows 10 1703 x64

---

From: Ulrich Sibiller <[email-masked]>
Date: Sun, 28 May 2017 10:42:58 +0200

> And the session fails to resume.

You are downgrading the X server in this scenario. The older X might
indeed have fewer/other visuals, so that behaviour could be correct.

Howewer, nx 3.5.99.x has a feature called
"tolerancechecks=strict/safe/risky/bypass" that might help here.

Uli