Subject: x2goplugin / x2goplugin-provider Failed to connect: Permission denied

From: "Justin St. Marie" <[email-masked]>
Date: Sun, 30 Apr 2017 16:02:23 -0400

Package: x2goserver
Version: 4.0.1.20-1.el7.x86_64

Package: x2goplugin-provider
Version: 4.1.0.0-1.el7.x86_64

Package: x2goplugin
Version: 4.1.0.0-1.el7.x86_64

All packages are from the official EPEL 7 repository.

When trying to log in using the firefox plugin, the error is:  Failed to
connect: Permission denied.  The same credentials work with the x2go client.

I used the example X2Go Demo config file, only changing server=IPaddress.

---

From: Ulrich Sibiller <[email-masked]>
Date: Mon, 8 May 2017 19:14:46 +0200

AFAIK npapi plugin support has been removed in Firefox 52 so the x2go plugin will not work anymore. 

Uli

Vom Smartphone gesendet.

----- Ursprüngliche Nachricht -----
Von: "Justin St. Marie" <[email-masked]>
Gesendet: ‎08.‎05.‎2017 17:33
An: "[email-masked]" <[email-masked]>
Betreff: [X2Go-Dev] Bug#1170: x2goplugin / x2goplugin-provider Failed toconnect: Permission denied

Package: x2goserver

Package: x2goplugin

When trying to log in using the firefox plugin, the error is:  Failed to connect: Permission denied.  The same credentials work with the x2go client.

---

From: "Justin St. Marie" <[email-masked]>
Date: Mon, 8 May 2017 13:25:40 -0400

I'm using 52 ESR, the last version that will ever support npapi.  52
non-ESR already blocks it.

The only other thing I noticed is that the packaged x2goserver is a
different version than the plugin and plugin-provider.  Packages for other
distros all match to 4.1.0.  Does the x2go server version have to match the
plugin and plugin-provider version?

On Mon, May 8, 2017 at 1:14 PM, Ulrich Sibiller <[email-masked]>
wrote:

> ------------------------------
> Von: Justin St. Marie <[email-masked]>
> An: [email-masked]

---

From: Ulrich Sibiller <[email-masked]>
Date: Mon, 8 May 2017 19:34:59 +0200

On Mon, May 8, 2017 at 7:25 PM, Justin St. Marie <[email-masked]> wrote:
> I'm using 52 ESR, the last version that will ever support npapi.  52 non-ESR
> already blocks it.

Ok. So let's track down if this is a server or client issue.  Do you
see any evidence on the server of the connection?

> plugin and plugin-provider version?

Sorry, I really do not know.

Uli

---

From: Orion Poplawski <[email-masked]>
Date: Mon, 8 May 2017 14:10:51 -0600

> I used the example X2Go Demo config file, only changing server=IPaddress.

It doesn't work in SELinux enforcing mode.  You'll need to change the client
to permissive or use audit2allow to create a module.

-- 
Orion Poplawski
Technical Manager                          720-772-5637
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       [email-masked]
Boulder, CO 80301                   http://www.nwra.com