Subject: Bug#1167: More details

From: "Petronic, Mark" <[email-masked]>
Date: Fri, 19 May 2017 14:44:19 +0000

We are running Windows 7 using VmWare Virtual Desktop (VDI). So, my x2go
client runs on that Windows desktop. The crash is actually happening in vcxsrv.ex
and I was able to obtain the following additional information:

(1) The VDI admins updated some VDI runtimes on our VDI desktop instances to
    VMWare version 6 around the time we started to experience this crash

(2) Here is a more detailed dump of some debug information I found:

Problem signature:
  Problem Event Name:  APPCRASH
  Application Name:  vcxsrv.exe
  Application Version:  1.17.0.0
  Application Timestamp: 55b5056a
  Fault Module Name:  vm3dum.dll
  Fault Module Version: 8.15.1.46
  Fault Module Timestamp: 57112640
  Exception Code:  40000015
  Exception Offset:  00026b27
  OS Version: 6.1.7601.2.1.0.256.4
  Locale ID: 1033
  Additional Information 1: f5d8
  Additional Information 2: f5d85880320133c2803765541f044878
  Additional Information 3: 4651
  Additional Information 4: 4651b47fc82bdc83b534297b987ba7e7

---

From: Ulrich Sibiller <[email-masked]>
Date: Sat, 20 May 2017 12:06:55 +0200

On Fri, May 19, 2017 at 4:44 PM, Petronic, Mark
<[email-masked]> wrote:
> vm3dum.dll

Googling for vm3dum.dll reveals a lot of crashes related to that
vmware dll. So I suppose it has nothing to do with x2go but with your
vmware. Some post suggest upgrading vmware-tools so please try that
and see if the crashes go away.

Also you could try moving the virtual machine to another host (or
maybe a vmware player or workstation) and check if the crashes
persist.

Uli

---

From: "Petronic, Mark" <[email-masked]>
Date: Sat, 20 May 2017 20:52:51 +0000

Yes, I noticed the same thing when I was googling around for clues. We are running the latest version of vmware-tools and I believe, when we moved to vmware version 6 this started happening around that time but we were not able to correlate it then and a number of updates have been applied since then. I had the VM admins build me an image with the older version of the tools last week but I still experienced the crash. IMO, given the popup error refers to a crash related to a pure virtual function, it would seem that this very well might be breakage in some vmware DLL API that is not acting in a backwards compatible manner.  Just a guess. Also, this only occurs when I configure the vcxsrv in rootless mode. I might try your suggestion by trying to run the image on a player. I already know it happens on different hosts as we have a number of hosts supporting the VDI instances and we float around day to day. I've confirmed it happens on different hosts in that way. Thanks for you suggestions and input!

Mark

________________________________
From: Ulrich Sibiller <[email-masked]>
Sent: Saturday, May 20, 2017 6:06:55 AM
To: Petronic, Mark; [email-masked]
Subject: Re: [X2Go-Dev] Bug#1167: More details

Uli