Subject: Bug#1151: (Arctica) Bad keyboard mapping after session resume

From: Walid MOGHRABI <[email-masked]>
Date: Fri, 3 Mar 2017 16:18:38 +0100 (CET)

Package: x2goserver
Version: 4.1.0.0

When using Arctica repo (deb http://packages.arctica-project.org/ubuntu xenial main) with libnx 3.5.99.4 (and previous)
if you suspend a session where your keyboard mapping was azerty - FR for example, when you resume the session, the keyboard mapping becomes qwerty - US.

I suppose US keymap is the default one but it seems restoring the session doesn't retain this environment setting while it works as expected with X2Goserver without Arctica.

Best regards,

Walid Moghrabi
	
---
DISCLAIMER: This e-mail is private and confidential and may contain proprietary or legally privileged information. It is for the intended recipient only. If you have received this email in error, please notify the author by replying to it and then destroy it. If you are not the intended recipient you must not use, disclose, distribute, copy, print or rely on this e-mail or any attachment. Thank you

---

From: Mihai Moldovan <[email-masked]>
Date: Fri, 3 Mar 2017 17:31:21 +0100

> if you suspend a session where your keyboard mapping was azerty - FR for example, when you resume the session, the keyboard mapping becomes qwerty - US.

Please upgrade to the newest nightly version of x2goserver.

The problem should be fixed there. I'll add reference to this ticket later tonight.

Mihai

---

From: Walid MOGHRABI <[email-masked]>
Date: Tue, 7 Mar 2017 10:39:10 +0100 (CET)

Hi,

Tested latest x2goserver from the Heuler ppa (4.1.0.0-0~1388~ubuntu16.04.1) today but that didn't fix the problem.
Suspending/resuming session still lose the keyboard layout with Arctica libs.

Regards,
Walid Moghrabi

TRAVAUX.COM
BAT I - PARC CEZANNE 2 290 AVENUE GALILEE - CS 80403
13591 AIX EN PROVENCE CEDEX 3

----- Mail original ----- 

De: "Mihai Moldovan" <[email-masked]> 
À: "Walid MOGHRABI" <[email-masked]>, [email-masked] 
Envoyé: Vendredi 3 Mars 2017 17:31:21 
Objet: Re: (Arctica) Bad keyboard mapping after session resume 

Mihai
---

---

From: Mihai Moldovan <[email-masked]>
Date: Tue, 7 Mar 2017 10:41:32 +0100

Control: reopen -1

> Suspending/resuming session still lose the keyboard layout with Arctica libs.

Yes, thanks. Sephi told me about that yesterday. I'll have to investigate further.

Mihai

---

From: Mihai Moldovan <[email-masked]>
Date: Thu, 9 Mar 2017 09:35:54 +0100

> Yes, thanks. Sephi told me about that yesterday. I'll have to investigate further.

There have been multiple issues. The newest nightly works for me, though. Please
retest.

Mihai