Subject: Bug#1150: x2goclient on windows creates host_rsa_key, sshd wants host_dsa_key

From: Enrqiue Perez-Terron <[email-masked]>
Date: Fri, 17 Feb 2017 21:43:30 +0100

Package: x2goclient
Version: 4.0.5.2

Error: message: 
SSH daemon failed to open its public host key

Circumstances:
I just installed the windows client on a Windows 10, 64-bit PC, 
defined a session (which uses a key file for authentication
and logs into an Ubuntu server given by IP address, where I had 
just installed the x2go server, and additionally installed gnome) 
and launched the session.

Afterward the directory C:/Users/Enrique/.x2go/etc contained the following files:

ssh_host_rsa_key
ssh_host_rsa_key.pub
sshd_config

Using cygwin on the same windows PC, I ran this command:

ssh-keygen -t dsa -b 1024 -N "" -f "C:/Users/Enrique/.x2go/etc/ssh_host_dsa_key" -q

After this, I restarted x2goclient, and the error message did not appear.

Looking at the source, it appears that the error message is emitted by
ONMainWindow::createRSAKey(), when it fails to open the file given
by the QFile object "rsa".

I observed that the createRSAKey() conditionally sets the file name on 
the object to ssh_host_dsa_key.pub, if compiled for Windows.

However, ONMainWindow::startWinServers() seems to be called unconditionally 
with RSA_KEY_TYPE, creating the rsa key file only.

I don't know why the file name in question is changed to *_dsa_* on Windows,
but if there is a good reason, the call to generateHostKey() 
in startWinServers should probably be modified accordingly. StartWinServers()
appears to be called only when compiled for Windows.

(For the record, even after running the ssh-keygen command, x2goclient
still appears to fail at starting a local sshd server, but I have not yet
investigated that. Perhaps listening on the socket port 7022 needs a 
privilege or raised "integrity label" on Windows. A black window appears,
but disappears after a while.)

Regards,
Enrique

---

From: Mihai Moldovan <[email-masked]>
Date: Sun, 26 Feb 2017 05:52:30 +0100

Control: forcemerge -1 1105

There have been extensive changes in how X2Go Client generates keys and starts
sshd. This report is a duplicate of a few others. Please test 4.1.0.0 once
binary builds are available.

Mihai

---

From: Same Day Pros <[email-masked]>
Date: Tue, 25 Aug 2020 20:39:51 +0000

Same Day Pros

												On Demand Same Day Service Professionals.

						

	

							

										 Hi  Hallo tуp! Iсh suche Sex in deiner Stаdt und iсh wunschtе du fickst miсh: https://ecuadortenisclub.com/nbhjg321644?o=ADULT-DATING,

								
									
										Thank you for contacting on Same Day Pros. We have received your message and would like to thank you for writing to us. If your inquiry is urgent, please call us to talk to one of our staff members. Otherwise, we will reply by email as soon as possible.

								

														Thanks & Regards,

													
														Same Day Pros team

													
														-------------------------------

								

										Need Help? Write to us at [email-masked].

							

						

												
													
														Connect to us :

																	

																				

																					

															

									

				

										

														You have received this email because you have an account registered at
														samedaypros.com. This is a commercial email from samedaypros.com

								

					

											

													

													
														© 2020 Same Day Pros.

---

From: [email-masked]
Date: Wed, 10 Dec 2025 12:18:55 +0000

Dear oil buyer, this is urgent information's of exported products for sale.
We have, Jet Fuel, EN590, LNG, LGP, D6, AGO and PMS available for sales in FOB/CIF Bases, same as well to other product on sales on CIF/FOB, mainly deliver in a timely manner for a ready company to purchase.

You can trust in Gazaqgaz to help you for any fuel inquiries.

Ruslan.

---

From: "ULYATU OIL AND GAS" <[email-masked]>
Date: Tue, 17 Feb 2026 08:17:30 -0800 (PST)

Sir/Madam,

We Ulytau Oil and Gas , is a distinguished mandate representing several major refineries in Kazakhstan, Poland and Russia. Our titleholder producer refineries are renowned for exporting high-quality petroleum derivatives globally. We are reaching out to explore potential business opportunities and establish a mutually beneficial partnership. Our refineries are equipped and ready to fulfill your purchase orders, delivering products to any safe world port on CIF and FOB transaction terms.

We take pride in offering a diverse range of premium products, including: Fuel A1, Aviation Jet, Low Sulfur Diesel EN590 D2, Gasoline, Automotive Gas Oil (AGO), Liquefied Natural Gas (LNG), Liquefied Petroleum Gas (LPG), Virgin Fuel Oil D6, EN590, Petroleum Coke, FUEL OIL

etc. (All these and more are currently available).

For your convenience, we can attach our detailed Soft Corporate Offer (SCO) if you request. If any of the listed products align with your current requirements or if you have specific inquiries, we invite you to express your interest by replying to this email.

Our team is committed to providing timely and efficient responses to ensure a smooth and transparent collaboration. We are sure that our products will meet and exceed your expectations, contributing to the success of your operations.

Thank you for considering Ulytau Oil and Gas as your trusted partner. We look forward to the possibility of working together and building a long-lasting, successful business relationship.

Warm Regards,

Kimurov Ramil Rashidovich

Sales & Export Director

WhatsApp: +1 (656) 203-1265

[email-masked]

[email-masked]

ULYTAU OIL AND GAS

Principal Mandate to End-Seller

Note: If you have received this message in your SPAM/BULK folder, It is simply because your ISP has introduced restrictions. We ask that you treat it as important.