X2Go Bug report logs - #1149
ValueError: CTR mode needs counter parameter, not IV

version graph

Package: pyhoca-cli; Maintainer for pyhoca-cli is X2Go Developers <x2go-dev@lists.x2go.org>; Source for pyhoca-cli is src:pyhoca-cli.

Reported by: Markus <markus@eserver.homelinux.org>

Date: Fri, 17 Feb 2017 12:40:01 UTC

Severity: normal

Merged with 1148

Found in version

Full log

🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1149: [X2Go-Dev] ValueError: CTR mode needs counter parameter, not IV
Reply-To: Markus <markus@eserver.homelinux.org>, 1149@bugs.x2go.org
Resent-From: Markus <markus@eserver.homelinux.org>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Tue, 21 Feb 2017 10:40:01 +0000
Resent-Message-ID: <handler.1149.B1149.148767342920806@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 1149
X-X2Go-PR-Package: pyhoca-cli
Received: via spool by 1149-submit@bugs.x2go.org id=B1149.148767342920806
          (code B ref 1149); Tue, 21 Feb 2017 10:40:01 +0000
Received: (at 1149) by bugs.x2go.org; 21 Feb 2017 10:37:09 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
X-Spam-Status: No, score=-0.0 required=3.0 tests=BAYES_20 autolearn=ham
Received: from localhost (localhost [])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id 0BE995DC13
	for <1149@bugs.x2go.org>; Tue, 21 Feb 2017 11:37:08 +0100 (CET)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([])
	by localhost (ymir.das-netzwerkteam.de []) (amavisd-new, port 10024)
	with ESMTP id s2xDOa9cll2X for <1149@bugs.x2go.org>;
	Tue, 21 Feb 2017 11:37:00 +0100 (CET)
X-Greylist: delayed 399 seconds by postgrey-1.34 at ymir.das-netzwerkteam.de; Tue, 21 Feb 2017 11:37:00 CET
Received: from sophos.c3bo.org (sophos.c3bo.org [])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id ADA355DC12
	for <1149@bugs.x2go.org>; Tue, 21 Feb 2017 11:37:00 +0100 (CET)
Received: from mx1.c3bo.org ([]:42720)
	by sophos.c3bo.org with esmtps (TLSv1.2:DHE-RSA-AES256-GCM-SHA384:256)
	(Exim 4.82_1-5b7a7c0-XX)
	(envelope-from <markus@eserver.homelinux.org>)
	id 1cg7hw-0000rl-2Y
	for 1149@bugs.x2go.org; Tue, 21 Feb 2017 11:30:09 +0100
Received: from eserver.homelinux.org (eserver.homelinux.org [])
	by mx1.c3bo.org (Postfix) with ESMTPS id 2BF3C8EE49
	for <1149@bugs.x2go.org>; Tue, 21 Feb 2017 11:30:07 +0100 (CET)
Received: from [] (dslc-082-083-055-210.pools.arcor-ip.net [])
	by eserver.homelinux.org (Postfix) with ESMTPSA id 555AB502710
	for <1149@bugs.x2go.org>; Tue, 21 Feb 2017 11:30:06 +0100 (CET)
X-CTCH-RefID: str=0001.0A0C0204.58AC16B1.0029,ss=1,re=0.000,recu=0.000,reip=0.000,cl=1,cld=1,fgs=0
To: 1149@bugs.x2go.org
References: <e1a0e38d-1ae9-4673-b25f-b8e635c99bf1@eserver.homelinux.org>
From: Markus <markus@eserver.homelinux.org>
Message-ID: <aacd43f1-0e43-6152-f684-1f078633dbda@eserver.homelinux.org>
Date: Tue, 21 Feb 2017 11:30:34 +0100
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101
MIME-Version: 1.0
In-Reply-To: <3b8c0302-5734-e5cf-52f0-ba8314570719@ionic.de>
Content-Type: text/plain; charset=windows-1252
Content-Transfer-Encoding: 7bit
without changing anything, pyhoca-cli works for me now, but it displays
a warning:

FutureWarning: CTR mode needs counter parameter, not IV
  self._cipher = factory.new(key, *args, **kwargs)"

When I tried it today, a window poped up asking me for my passphrase
which I need for something else...

And it worked.

But I dont use a keyfile or this passphrase for this x2go related server.

Maybe this information is useful.

But all thinks work for now.


Am 20.02.2017 um 04:07 schrieb Mihai Moldovan:
> Control: merge -1 1148
> On 17.02.2017 01:38 PM, Markus wrote:
>> Package: pyhoca-cli
>> Version:
>> (sorry for repost, I subscribed now to the mailinglist)
>> Hi,
>> pyhoca-cli stopped working for me. I expected it to ask me for password,
>> but instead it raises an exception.
>> I don't know what happened, because this worked all the time. And I
>> think I didn't change anything.
>> The error message is: "ValueError: CTR mode needs counter parameter, not IV"
> Probably an incompatibility issue with newer versions of Paramiko. Will have to
> look into this.
> Mihai

Send a report that this bug log contains spam.

X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Feb 1 22:54:03 2023; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.