Subject: [pulseaudio] main.c: User-configured server at localhost, refusing to start/autospawn

From: Robert Kudyba <[email-masked]>
Date: Mon, 30 Jan 2017 16:03:33 -0500

Package: x2goserver
Version: 4.0.1.20-1 
This is on Fedora 25, 4.8.16-300.fc25.x86_64 kernel. Certain users trigger the following errors in /var/log/messages when audio is not disabled:
pulseaudio[]: [pulseaudio] main.c: User-configured server at localhost:, refusing to start/autospawn.

Seems related to http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=161 <http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=161> and https://bugzilla.redhat.com/show_bug.cgi?id=830406 <https://bugzilla.redhat.com/show_bug.cgi?id=830406> which is closed.

---

From: Robert Kudyba <[email-masked]>
Date: Mon, 30 Jan 2017 16:06:45 -0500

The process looks like this when running: ps -Afl|grep x2go:

0 S user   10824     1  0  80   0 - 43867 hrtime 12:06 ?        00:00:31 /usr/lib64/nx/../x2go/bin/x2goagent -extension XFIXES -nolisten tcp -nolisten tcp -dpi 192 -D -auth /u/erdos/students/user/.Xauthority -geometry 800x600 -name X2GO-user-54-1485795996_stDMATE_dp32 :54
0 S user   11027     1  0  80   0 - 29094 wait   12:06 ?        00:00:00 /bin/bash /usr/bin/x2goruncommand 54 10824 user 54-1485795996_stDMATE_dp32 49339 mate-session nosnd D

> On Jan 30, 2017, at 4:05 PM, X2Go Bug Tracking System <[email-masked]> wrote:
> 
> Thank you for filing a new Bug report with X2Go.
> 
> This is an automatically generated reply to let you know your message
> has been received.
> 
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
> 
> Your message has been sent to the package maintainer(s):
> X2Go Developers <[email-masked]>
> 
> If you wish to submit further information on this problem, please
> send it to [email-masked].
> 
> Please do not send mail to [email-masked] unless you wish
> to report a problem with the Bug-tracking system.
> 
> -- 
> 1143: https://urldefense.proofpoint.com/v2/url?u=http-3A__bugs.x2go.org_cgi-2Dbin_bugreport.cgi-3Fbug-3D1143&d=DwIFaQ&c=aqMfXOEvEJQh2iQMCb7Wy8l0sPnURkcqADc2guUW8IM&r=X0jL9y0sL4r4iU_qVtR3lLNo4tOL1ry_m7-psV3GejY&m=yZQOxbPyRiUBnpSpRxeif4KeNW8tyLJldXOhmtAlf8k&s=1dgFGLNVPKM_rZMgm3k6gmDEle9XkkwTFu9xXCyC5Wo&e= 
> X2Go Bug Tracking System
> Contact [email-masked] with problems

---

From: Robert Kudyba <[email-masked]>
Date: Mon, 30 Jan 2017 16:08:41 -0500

Related packages:
Installed Packages
Name        : x2goagent
Arch        : x86_64
Epoch       : 0
Version     : 3.5.0.32
Release     : 4.fc24
Size        : 37 k
Repo        : @System
From repo   : @commandline
Summary     : X2Go Agent
URL         : http://x2go.org/
License     : GPLv2+
Description : X2Go agent functionality has been completely incorporated into
            : nxagent's code base. If the nxagent binary is executed under the name
            : of "x2goagent", the X2Go functionalities get activated.
            : 
            : The x2goagent package is a wrapper that activates X2Go branding in
            : nxagent. Please refer to the nxagent package's description for more
            : information on NX.

Name        : x2goserver
Arch        : x86_64
Epoch       : 0
Version     : 4.0.1.20
Release     : 1.fc25
Size        : 309 k
Repo        : @System
From repo   : @commandline
Summary     : X2Go Server
URL         : http://www.x2go.org
License     : GPLv2+
Description : X2Go is a server based computing environment with
            :     - session resuming
            :     - low bandwidth support
            :     - session brokerage support
            :     - client side mass storage mounting support
            :     - audio support
            :     - authentication by smartcard and USB stick
            : 
            : This package contains the main daemon and tools for X2Go server-side session
            : administrations.

Name        : x2goserver-xsession
Arch        : x86_64
Epoch       : 0
Version     : 4.0.1.20
Release     : 1.fc25
Size        : 8.7 k
Repo        : @System
From repo   : @commandline
Summary     : X2Go Server Xsession runner
URL         : http://www.x2go.org
License     : GPLv2+
Description : X2Go is a server based computing environment with
            :    - session resuming
            :    - low bandwidth support
            :    - session brokerage support
            :    - client side mass storage mounting support
            :    - audio support
            :    - authentication by smartcard and USB stick
            : 
            : This X2Go server add-on enables Xsession script handling
            : when starting desktop sessions with X2Go.
            : 
            : Amongst others the parsing of Xsession scripts will
            : enable desktop-profiles, ssh-agent startups, gpgagent
            : startups and many more Xsession related features on
            : X2Go session login automagically.