Subject: No environment variable available for testing in .bash_profile or .bashrc

From: Ted Toal <[email-masked]>
Date: Tue, 10 Jan 2017 13:17:15 -0800

Package: NXAGENT
Version: 3.5.0

I would like to bypass setting of certain environment variables in .bash_profile if I’m connecting via x2go, but it appears there are no environment variables I can test in .bash_profile to determine if this is an x2go session. After the session starts, some x2go environment variables are there, but not while .bash_profile is executing.

---

From: Rick Benkstein <[email-masked]>
Date: Tue, 10 Jan 2017 22:12:12 +0000

Ted,

I have made my software switchable between GUI non-GUI by examining the DISPLAY variable - if it is NULL then x2go is not being used.

Rick Benkstein

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ted Toal
Sent: Tuesday, January 10, 2017 3:17 PM
To: [email-masked]
Subject: [X2Go-Dev] Bug#1134: No environment variable available for testing in .bash_profile or .bashrc

Package: NXAGENT
Version: 3.5.0

I would like to bypass setting of certain environment variables in .bash_profile if I’m connecting via x2go, but it appears there are no environment variables I can test in .bash_profile to determine if this is an x2go session. After the session starts, some x2go environment variables are there, but not while .bash_profile is executing.
_______________________________________________
x2go-dev mailing list
[email-masked]
http://lists.x2go.org/listinfo/x2go-dev

---

From: Stefan Baur <[email-masked]>
Date: Tue, 10 Jan 2017 23:28:31 +0100

> I have made my software switchable between GUI non-GUI by examining the DISPLAY variable - if it is NULL then x2go is not being used.

Unless, of course, you are occasionally using a local X session, or
regular X forwarding, where this approach will bite you in the
posterior, falsely assuming that you're running an X2Go session when
it's regular X.

The deeper-rooted issue here is that X2Go-specific variables are only
set when a session is run in fullscreen or windowed mode, displaying an
entire desktop.

For single/published applications, no such X2Go-specific variable is set.

However, you can check if:

the command x2golistsessions is executable (=we're on an X2GoServer -
important in case of NFS-mounted home directories)

AND the DISPLAY variable is set

AND client DISPLAY and SSH client IP match an X2Go session marked as "R"
for running.

See <http://wiki.x2go.org/doku.php/doc:howto:ssh-agent-workaround>,
section "# Part that runs in X2Go session", for an example where you
could lift the required code.

What you don't need is the part that checks for a file named
"~/.x2go/agent", so just remove that part.

Kind Regards,
Stefan

-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: Ted Toal <[email-masked]>
Date: Tue, 10 Jan 2017 14:41:20 -0800

DISPLAY is null (not defined) when x2go is running, as well as when it isn't, in my case.
—
Ted Toal, Postdoctoral Researcher
Carvajal-Carmona Lab
4502 GBSF, One Shields Ave
Davis, CA  956626  (530) 263-5986
[email-masked]

> On Jan 10, 2017, at 2:12 PM, Rick Benkstein <[email-masked]> wrote:
> 
> Ted,
>

---

From: Ted Toal <[email-masked]>
Date: Tue, 10 Jan 2017 14:44:32 -0800

I’m running in windowed mode (XFCE) through x2go and XQuartz.  The DISPLAY environment variable is not set. 

—

> On Jan 10, 2017, at 2:28 PM, Stefan Baur <[email-masked]> wrote:
>

---

From: Rick Benkstein <[email-masked]>
Date: Tue, 10 Jan 2017 22:44:12 +0000

Sorry – I am using headless servers that never have X running on them – That solution is limited.

Rick Benkstein

From: Ted Toal [mailto:[email-masked]]
Sent: Tuesday, January 10, 2017 4:41 PM
To: Rick Benkstein <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [X2Go-Dev] Bug#1134: No environment variable available for testing in .bash_profile or .bashrc

[email-masked]<mailto:[email-masked]>

On Jan 10, 2017, at 2:12 PM, Rick Benkstein <[email-masked]<mailto:[email-masked]>> wrote:

Ted,

Rick Benkstein

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Ted Toal
Sent: Tuesday, January 10, 2017 3:17 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [X2Go-Dev] Bug#1134: No environment variable available for testing in .bash_profile or .bashrc

Package: NXAGENT
Version: 3.5.0

I would like to bypass setting of certain environment variables in .bash_profile if I’m connecting via x2go, but it appears there are no environment variables I can test in .bash_profile to determine if this is an x2go session. After the session starts, some x2go environment variables are there, but not while .bash_profile is executing.
_______________________________________________
x2go-dev mailing list
[email-masked]<mailto:[email-masked]>
http://lists.x2go.org/listinfo/x2go-dev