Subject: Bug#1132: Color issue with x2go not present in NX with certain applications

From: "Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc]" <[email-masked]>
Date: Mon, 9 Jan 2017 14:13:52 +0000

Package: x2goclient
Version: 4.0.5.2

Connecting to remote RHEL system using x2go has color issues with certain panels of an application on that system. When connecting via NoMachine the panels show up as they should, black background, white text. However with x2go the panel shows up as a grey background with black text, and some text are just black boxes (the major issue is the black boxes obscuring text).

I noticed a bug along these lines from back in 2013 (#262 ) (http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=262)

Brian Town
Landsat 8
Goddard Space Flight Center
[sig]

---

From: Stefan Baur <[email-masked]>
Date: Mon, 9 Jan 2017 17:49:40 +0100

Hi, Brian!

First of all, welcome to X2Go!  You're actually the third NASA employee
hitting our list (the other two were from JSC-EG311 and JPL-392K).
Sorry, that doesn't mean you've won a prize. ;-)

Some things I would like to ask you to do/try:

1) Please let us know the name of the software that has these issues
with X2Go; if it is non-free and/or something NASA developed internally,
you might want to get the developers of that software involved as well
so they can talk to ours.
Screenshots would help, too - but please remember to black out
confidential information that might be visible on it.

2) Please try different slider settings and image compression algorithms
in the connection settings.  Maybe it only affects JPG, or only PNG, ...

3) Also, please try running the software with X2Go in single
application/published application mode (IOW, rootless mode) vs.
fullscreen/windowed mode.  This is becahse parts of the screen drawing
process work differently in rootless mode.

4) If you have a chance to run this software along with X2Go in a
separate testing environment, you could try following these steps and
see if it changes anything - but please do not do this on a production
system:
http://wiki.x2go.org/doku.php/doc:howto:nx-libs-betatesting
(Note that at present, this probably only works for Debian-based
distributions, not for Redhat - but if you have a test lab available to
you, you could "ssh -X brian@redhat-test-box" from the Debian box within
the X2Go session.)

5) We'd love to hear how you use or intend to use X2Go, so we can
publish your testimonial on our success stories page in the wiki.
Since you seem to be working with weather satellites, that sounds like a
rather interesting use case for X2Go.

Last, I hope you don't mind that I mention this ...

<shameless plug>
X2Go also has a commercial side, where various companies - including my
own - offer support contracts with guaranteed response times as well as
consultancy and paid-for development work if someone wants to see a bug
fixed or a new feature added in a certain time frame. What makes my
company special is, IMHO:

1) I'm the current X2Go Project/Community Coordinator, so the
development lead and the developers tend to listen to me.
2) As far as I know, we are the only company providing X2Go support that
isn't a one-man-show.
3) We sub-contract other developers from the X2Go community on demand,
so you only have one person you need to talk to - me - and you will only
receive one invoice, even if the task involved several freelance or
part-time X2Go developers.

Our hourly rate for consultancy work and fixing issues outside of a
support contract is 110 EUR. With a support contract, you get guaranteed
response times (starting at 400 EUR/month for 24h response time during
business hours in the CET/CEST time zone from Monday to Friday, German
holidays excluded) and lower hourly rates if you buy a certain amount of
hours in advance.
</shameless plug>

Kind Regards,
Stefan Baur

Am 09.01.2017 um 15:13 schrieb Town, Brian A. (GSFC-428.0)[Embedded
Flight Systems, Inc]:
> Package: x2goclient
> 
> Version: 4.0.5.2
> 
>  
> 
> Connecting to remote RHEL system using x2go has color issues with
> certain panels of an application on that system. When connecting via
> NoMachine the panels show up as they should, black background, white
> text. However with x2go the panel shows up as a grey background with
> black text, and some text are just black boxes (the major issue is the
> black boxes obscuring text).
> 
>  
> 
> I noticed a bug along these lines from back in 2013 (#262 )
> (http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=262)
> 
>  
> 
> Brian Town
> 
> Landsat 8
> 
> sig
> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> http://lists.x2go.org/listinfo/x2go-dev
> 

-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: "Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc]" <[email-masked]>
Date: Mon, 9 Jan 2017 16:58:29 +0000

Darn was hoping to have won the prize! Haha

I have tested a few different compression/slider options but still going through and see what each option gives me in. The software being used is open source for NASA missions I believe but closed outside of that, so not sure what all I can share on that just yet, I'll have to check.

I did notice that selecting the "local desktop" option via the client on x2go provides me with the correct color, however it also produces a great deal of lag. Is the local desktop option doing basic VNC connection or Xforwarding? I couldn't find any information on that.

I'm utilizing x2go in conjunction with a LTSP set up. If I use basic Xforwarding through the terminal I get the colors I need displayed properly. I'm not sure exactly where it's hanging up through the x2go client window.

For the unix_kde_depth option, is there a setting to have it exceed 24? Some blogs I've noticed people their session.log files showing unix_kde_depth32 however mine is always at 24 and unsure where that setting would be located at.

Brian Town
Landsat 8

-----Original Message-----
From: Stefan Baur [mailto:[email-masked]] 
Sent: Monday, January 09, 2017 11:50 AM
To: Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc] <[email-masked]>; [email-masked]
Subject: Re: [X2Go-Dev] Bug#1132: Color issue with x2go not present in NX with certain applications

Hi, Brian!

First of all, welcome to X2Go!  You're actually the third NASA employee hitting our list (the other two were from JSC-EG311 and JPL-392K).
Sorry, that doesn't mean you've won a prize. ;-)

1) Please let us know the name of the software that has these issues with X2Go; if it is non-free and/or something NASA developed internally, you might want to get the developers of that software involved as well so they can talk to ours.
Screenshots would help, too - but please remember to black out confidential information that might be visible on it.

2) Please try different slider settings and image compression algorithms in the connection settings.  Maybe it only affects JPG, or only PNG, ...

3) Also, please try running the software with X2Go in single application/published application mode (IOW, rootless mode) vs.
fullscreen/windowed mode.  This is becahse parts of the screen drawing process work differently in rootless mode.

4) If you have a chance to run this software along with X2Go in a separate testing environment, you could try following these steps and see if it changes anything - but please do not do this on a production
system:
http://wiki.x2go.org/doku.php/doc:howto:nx-libs-betatesting
(Note that at present, this probably only works for Debian-based distributions, not for Redhat - but if you have a test lab available to you, you could "ssh -X brian@redhat-test-box" from the Debian box within the X2Go session.)

5) We'd love to hear how you use or intend to use X2Go, so we can publish your testimonial on our success stories page in the wiki.
Since you seem to be working with weather satellites, that sounds like a rather interesting use case for X2Go.

<shameless plug>
X2Go also has a commercial side, where various companies - including my own - offer support contracts with guaranteed response times as well as consultancy and paid-for development work if someone wants to see a bug fixed or a new feature added in a certain time frame. What makes my company special is, IMHO:

1) I'm the current X2Go Project/Community Coordinator, so the development lead and the developers tend to listen to me.
2) As far as I know, we are the only company providing X2Go support that isn't a one-man-show.
3) We sub-contract other developers from the X2Go community on demand, so you only have one person you need to talk to - me - and you will only receive one invoice, even if the task involved several freelance or part-time X2Go developers.

Our hourly rate for consultancy work and fixing issues outside of a support contract is 110 EUR. With a support contract, you get guaranteed response times (starting at 400 EUR/month for 24h response time during business hours in the CET/CEST time zone from Monday to Friday, German holidays excluded) and lower hourly rates if you buy a certain amount of hours in advance.
</shameless plug>

Kind Regards,
Stefan Baur

--
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364 Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: Ulrich Sibiller <[email-masked]>
Date: Tue, 10 Jan 2017 15:34:20 +0100

On Mon, Jan 9, 2017 at 5:58 PM, Town, Brian A. (GSFC-428.0)[Embedded
> For the unix_kde_depth option, is there a setting to have it exceed 24? Some blogs I've noticed people their session.log files showing unix_kde_depth32 however mine is always at 24 and unsure where…

Color issues might have to do with the rgb file not being found (or
being incomplete). IIRC we have fixed something in the coming 3.6.x
release in this regard. Please test if the problem persists with
current nx beta,
http://wiki.x2go.org/doku.php/doc:howto:nx-libs-betatesting.

You could also check if one of these rgb files exist (add .txt
extension). They are searched in this order:

static char* nxAltRgbPaths[] = {"/etc/x2go/rgb", \
                                "/usr/share/x2go/rgb", \
                                "/usr/local/share/x2go/rgb", \
                                "/etc/nxagent/rgb", \
                                "/usr/share/nx/rgb", \
                                "/usr/local/share/nx/rgb", \
                                "/usr/NX/share/rgb", \
                                "/usr/share/X11/rgb", \
                                "/etc/X11/rgb"};

So if you find one compare it to the one you real X server is using
(should be visible in /var/log/Xorg.0.log).

Or maybe, instead of checking all this: simply copy the rgb.txt from
your X server to /etc/x2go/rgb.txt and retry.

Uli

---

From: "Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc]" <[email-masked]>
Date: Mon, 16 Jan 2017 16:25:36 +0000

I forgot to mention by the looks of your link is testing currently only working on debian based systems? We’re using Rhel6 systems with x2goserver installed on them. I did notice in the git repo for Artica nxlibs there is a section for building out a rpm. Little out of my depth here though so I might be not looking at the correct thing.

> On Jan 9, 2017, at 11:58 AM, Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc] <[email-masked]> wrote:
>

---

From: Stefan Baur <[email-masked]>
Date: Mon, 16 Jan 2017 17:28:33 +0100

Hi Brian,

I was under the impression that at present, they only support Debian and
its derivatives, but maybe that has changed.  Let's see if we can get an
Arctica developer (see CC) to chime in and comment on the feasibility of
testing X2Go together with the Arctica NX-lib nightlies on RHEL6. :-)

-Stefan

Am 16.01.2017 um 17:25 schrieb Town, Brian A. (GSFC-428.0)[Embedded

---

From: "Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc]" <[email-masked]>
Date: Tue, 24 Jan 2017 13:26:05 +0000

My apologies but not seeing this sooner, we were told by the software devs that the program does source the rgb.txt file for color values. I must have completely missed this email somehow but will test out what was said.

Brian Town
Landsat 8

-----Original Message-----
From: Ulrich Sibiller [mailto:[email-masked]] 
Sent: Tuesday, January 10, 2017 9:34 AM
To: Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc] <[email-masked]>; [email-masked]
Subject: Re: [X2Go-Dev] Bug#1132: Bug#1132: Color issue with x2go not present in NX with certain applications

> For the unix_kde_depth option, is there a setting to have it exceed 24? Some blogs I've noticed people their session.log files showing unix_kde_depth32 however mine is always at 24 and unsure where…

Color issues might have to do with the rgb file not being found (or being incomplete). IIRC we have fixed something in the coming 3.6.x release in this regard. Please test if the problem persists with current nx beta, http://wiki.x2go.org/doku.php/doc:howto:nx-libs-betatesting.

You could also check if one of these rgb files exist (add .txt extension). They are searched in this order:

So if you find one compare it to the one you real X server is using (should be visible in /var/log/Xorg.0.log).

Or maybe, instead of checking all this: simply copy the rgb.txt from your X server to /etc/x2go/rgb.txt and retry.

Uli

---

From: "Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc]" <[email-masked]>
Date: Mon, 30 Jan 2017 14:59:33 +0000

There was a /usr/share/X11/rgb.txt file on the remote system, I copied it's concents also to /etc/x2go/rgb and still having issues. The main issue I Have narrowed down is that it's xterm. If I open up a terminal on remote system and run a "xterm -bg 'white' -fg 'black'" it comes up with "Color name not defined" errors, as it can't find a reference to those values. If I run xterm with the actual values instead of the color name though it opens fine.

I'm not exactly sure why x2go sessions are not working with the files in place.

Brian Town
Landsat 8

-----Original Message-----
From: Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc] 
Sent: Tuesday, January 24, 2017 8:26 AM
To: [email-masked]' <[email-masked]>; [email-masked]
Subject: RE: [X2Go-Dev] Bug#1132: Bug#1132: Color issue with x2go not present in NX with certain applications

Brian Town
Landsat 8

-----Original Message-----
From: Ulrich Sibiller [mailto:[email-masked]] 
Sent: Tuesday, January 10, 2017 9:34 AM
To: Town, Brian A. (GSFC-428.0)[Embedded Flight Systems, Inc] <[email-masked]>; [email-masked]
Subject: Re: [X2Go-Dev] Bug#1132: Bug#1132: Color issue with x2go not present in NX with certain applications

Uli

---

From: INVESTIGATIONEN/Euro/POL <[email-masked]>
Date: Tue, 10 Oct 2023 07:47:37 +0200 (CEST)

Anbei finden Sie die gegen Sie erstellte Beschwerde. 
Mit freundlichen Grüßen

---

From: "EU6534RO/POL" <[email-masked]>
Date: Tue, 10 Oct 2023 15:38:53 +0200

Bitte lesen Sie das beiliegende Dokument, das Sie betrifft.

---

From: RAQUEL FERRANDO AZNAR <[email-masked]>
Date: Sun, 22 Oct 2023 13:50:56 +0000

Bitte lesen Sie das Einladungsschreiben und antworten Sie uns so bald wie möglich.
Mit freundlichen Grüßen

AVISO LEGAL. Este mensaje puede contener información reservada y confidencial. Si usted no es el destinatario no está autorizado a copiar, reproducir o distribuir este mensaje ni su contenido. Si ha recibido este mensaje por error, le rogamos que lo notifique al remitente.
Le informamos de que sus datos personales, que puedan constar en este mensaje, serán tratados en calidad de responsable de tratamiento por la UNIVERSIDAD NACIONAL DE EDUCACIÓN A DISTANCIA (UNED) c/ Bravo Murillo, 38, 28015-MADRID-, con la finalidad de mantener el contacto con usted. La base jurídica que legitima este tratamiento, será su consentimiento, el interés legítimo o la necesidad para gestionar una relación contractual o similar. En cualquier momento podrá ejercer sus derechos de acceso, rectificación, supresión, oposición, limitación al tratamiento o portabilidad de los datos, ante la UNED, Departamento de Política Jurídica de Seguridad de la Información<https://www.uned.es/dpj>, o a través de la Sede electrónica<https://sede.uned.es/> de la Universidad.
Para más información visite nuestra Política de Privacidad<https://descargas.uned.es/publico/pdf/Politica_privacidad_UNED.pdf>.

---

From: MARTA SEGURA VALVERDE <[email-masked]>
Date: Thu, 23 Nov 2023 01:32:00 +0000

Hallo

Hier finden Sie die gerichtliche Stellungnahme zu einem Fall, der Sie betrifft.

Sie sind jetzt benachrichtigt.

Wir bitten Sie, sehr geehrte Damen und Herren, unsere ausgezeichneten Grüße zu begrüßen.