Subject: Re: Bug#410: Segfault of _X11TransWritev in libNX_X11.so.6 with libQtGui

From: Mike Gabriel <[email-masked]>
Date: Mon, 30 Jun 2014 20:02:58 +0000

close #410
close #113
close #467
thanks

Hi Sven,

On  Mo 30 Jun 2014 15:32:14 UTC, Sven Willenberger wrote:

>> """ (quoted from above...)
>> +       # Provide means for Xinerama support in NX/X2Go sessions. This
>> +       # This also requires two post-install symlinks:
>> +       # (DESTDIR)$(NXLIBDIR)/X11/Xinerama/libNX_X11.so.6 ->
>> /usr/<libdir>/libX11.so.6
>> +       # (DESTDIR)$(NXLIBDIR)/X11/Xinerama/libNX_Xext.so.6 ->
>> /usr/<libdir>/libXext.so.6
>> """

> I went ahead and changed the PKGBUILD file (Archlinux's package
> building spec file) to include the symlinks as you pointed out (and as
> are contained as comments in the Makefile) and rebuilt the package. It
> works!! (pyQt, PySide, vlc all work now). That was the fix that was
> needed and will report this to the package maintainers.

Great that we could track this down...

@all: X2Go BTS issues #113, #410 and #467 have been identified as  
packaging issues on Archlinux. For further reference, see here:

https://bugs.archlinux.org/task/41037

Sven, thanks for your help and providing your distro-specific  
expertise on this...
Mike
-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976 148

GnuPG Key ID 0x25771B31
mail: [email-masked], http://das-netzwerkteam.de

freeBusy:
https://mail.das-netzwerkteam.de/freebusy/m.gabriel%40das-netzwerkteam.de.xfb

---

From: [email-masked] (X2Go Bug Tracking System)
Date: Mon, 30 Jun 2014 20:05:02 +0000

This is an automatic notification regarding your Bug report
which was filed against the nxagent package:

#113: X11TransWritev in libNX_X11.so.6 causes VLC crash

It has been closed by Mike Gabriel <[email-masked]>.

Their explanation is attached below along with your original report.
If this explanation is unsatisfactory and you have not received a
better one in a separate message then please contact Mike Gabriel <[email-masked]> by
replying to this email.

-- 
X2Go Bug Tracking System
Contact [email-masked] with problems

Subject: Re: Bug#410: Segfault of _X11TransWritev in libNX_X11.so.6 with libQtGui
From: Mike Gabriel <[email-masked]>
To: Sven Willenberger <[email-masked]>
Cc: [email-masked], [email-masked]
Date: Mon, 30 Jun 2014 20:02:58 +0000

close #410
close #113
close #467
thanks

Hi Sven,

DAS-NETZWERKTEAM

GnuPG Key ID 0x25771B31

freeBusy:

Subject: X11TransWritev in libNX_X11.so.6 causes VLC crash
From: Rob <[email-masked]>
To: [email-masked]
Date: Thu, 31 Jan 2013 13:46:03 +0100

Package: x2goserver
Version: 4.0.0.0-0~640~precise1

when loading vlc a Segmentation fault is caused.
This only happens since i switched from FreeNX
to x2go. 

Server: Ubuntu 12.10 - XFCE - 3.2.0-36-generic #57-Ubuntu SMP x86_64
current windows and linux clients both tested.

VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
[0x130d108] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Segmentation fault (core dumped)

GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2.1) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /usr/bin/vlc...(no debugging symbols found)...done.
(gdb) run

Starting program: /usr/bin/vlc 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
[New Thread 0x7ffff7fdd700 (LWP 13622)]
[0x605108] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[New Thread 0x7fffee505700 (LWP 13623)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0x7fffee505700 (LWP 13623)]
0x00007fffe7957be0 in _X11TransWritev () from /usr/lib/nx/X11/libNX_X11.so.6

-- 
Best regards,
 Rob                          mailto:[email-masked]