X2Go Bug report logs - #112
Mac Os X keyboard bug: NumLockMask always set, keyboard unusable

Package: x2goclient; Maintainer for x2goclient is X2Go Developers <x2go-dev@lists.x2go.org>; Source for x2goclient is src:x2goclient.

Reported by: benjamin milde <bmilde@gmail.com>

Date: Wed, 30 Jan 2013 18:48:01 UTC

Severity: normal

Full log

Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

Received: (at submit) by bugs.x2go.org; 30 Jan 2013 18:35:16 +0000
From bmilde@gmail.com  Wed Jan 30 19:35:16 2013
Received: from mail-ie0-f169.google.com (mail-ie0-f169.google.com [])
	by ymir (Postfix) with ESMTPS id 3E3A95DB16
	for <submit@bugs.x2go.org>; Wed, 30 Jan 2013 19:35:16 +0100 (CET)
Received: by mail-ie0-f169.google.com with SMTP id c14so1614739ieb.28
        for <submit@bugs.x2go.org>; Wed, 30 Jan 2013 10:35:14 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
        d=gmail.com; s=20120113;
MIME-Version: 1.0
X-Received: by with SMTP id us19mr4268912igb.84.1359570914376;
 Wed, 30 Jan 2013 10:35:14 -0800 (PST)
Received: by with HTTP; Wed, 30 Jan 2013 10:35:14 -0800 (PST)
Date: Wed, 30 Jan 2013 19:35:14 +0100
Message-ID: <CA+yVNSOHsoQekUiUuyGWibTqfs5vm8cvkm8j4tJe=o-VsNexJg@mail.gmail.com>
Subject: Mac Os X keyboard bug: NumLockMask always set, keyboard unusable
From: benjamin milde <bmilde@gmail.com>
To: submit@bugs.x2go.org
Cc: Michael Nagel <ubuntu@nailor.devzero.de>
Content-Type: multipart/alternative; boundary=e89a8f3b9d5f65fb1d04d485c55c
[Message part 1 (text/plain, inline)]
Package: *
Version: various versions tried out, see below

* Buggy package name not known. I suspect a problem with nx-libraries.

I can supply further information for the mac os x keyboard bug in x2go. I
think I had this problem already ~2 years ago, when I first tried out x2go.
All pressed client keys produce wrong key events on the host. Its a real
show-stopper since it makes x2go basically totally unusable for me and

See also this post on the x2go mailing list
There, Michael had the same problem I observe with:

Server Side: Ubuntu 12.04 with x2goserver from the
stable PPA
Client Side: Mac OS X 10.6.8 with x2goclient from the x2go website
Keyboard Layout: en_us everywhere, and in x2goclient I checked "Keep
current keyboard Settings"

I'm using Mac OS X 10.8.2, XQuarz 2.7.4 and also x2goclient I
also tried changing x2goserver from stable PPA to 4.1.0 from git. Also
toggling "Keep current keyboard Settings" does not make a difference.
Server is also a ubuntu machine, but could cross-check this with a Debian
install (and see if the same error occurs there).

The problem is that keystate changes while it is transferred to the host:

MAC:   state 0x0, keycode 26 (keysym 0x31, 1), same_screen YES,
LINUX: state 0x10, keycode 26 (keysym 0x65, e), same_screen YES,

This makes the keyboard unusable, since every client keycode gives a wrong
keysym on the host. The mask 0x10 is set for all key events sent to the
host, every time.

Looking around in X's headers I found:

defined in <X.h>
/* Key masks. Used as modifiers to GrabButton and GrabKey, results of
   state in various key-, mouse-, and button-related events. */
#define ShiftMask               (1<<0)
#define LockMask                (1<<1)
#define ControlMask             (1<<2)
#define Mod1Mask                (1<<3)
#define Mod2Mask                (1<<4)
#define Mod3Mask                (1<<5)
#define Mod4Mask                (1<<6)
#define Mod5Mask                (1<<7)

So keystate 0x10 means the keyevent has Mod2Mask set.

defined in <xorg/atKeynames.h> (but don't think it's a standard X11 header)
#define AltMask         Mod1Mask
#define NumLockMask     Mod2Mask
#define AltLangMask     Mod3Mask
#define KanaMask        Mod4Mask
#define ScrollLockMask  Mod5Mask

Which appears to be a NumLockMask. This makes sense since 'dfg' gives the
numbers '124', i.e. indicating that I have some sort of Numpad overlay in
the middle of the keyboard on the host.

For what is worth, a found similar bug report with no machines remote

 "For instance, the Delete key was now comma, all the letters were
transposed, general chaos. "

I can also confirm that backspace is comma, so this seems to be the same
NumLockMask problem. Every key is garbled, but not randomly.

The same problems apparently appears here in a bug report in XQuartz. They
think its not their fault:


"From my experience using NX in Linux, NX is badly designed. It sends
keycodes instead of KeySyms to the remote NX session.
 This causes the remote session to behave badly, unless you install the
local keyboard map into the remote X session.
It is a problem with NX and not the X server. However, that should have no
effect on the local keyboard mapping. "

If someone could point me in the right direction, I would be glad to help.
And as I have no need for the Mod2Mask, as a temporary fix, I would be fine
to ignore this mask on the server side and hard code xkey->state &= ~(1u <<
4); somewhere.

Has someone an idea how to further investigate this issue? Is there someone
who can report a working keyboard with Mac Os X as client?
[Message part 2 (text/html, inline)]

Send a report that this bug log contains spam.

X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Mar 29 15:44:32 2020; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.