Subject: x2gobroker-ssh big delay in session status recovery

From: Miguel Quero <[email-masked]>
Date: Tue, 20 Dec 2016 12:55:21 +0100

Package: x2gobroker
Version: 0.0.3.1

When x2gobroker-ssh is used with system with not IPv6 configured, this generate very big delays in x2gobroker listsession task.

Before some research, the problem become from x2gobroker.utils portscan function.

This function propagates a delay in all agents call because it tests first the IPV6 connection:

/ip_proto = 0////try:////socket.getaddrinfo(addr, None, socket.AF_INET6)////ip_proto = 6////except socket.gaierror:////try:////socket.getaddrinfo(addr, None, socket.AF_INET)////ip_proto = 4////except socket.gaierror:////# we can't find a valid address for this host, so returning a failure...////return False /This will be fixed testing IPv4 first or more easily, setting a new option in config to select the ip protocol.

Best regards.

-- 
Miguel Quero | One eSecurity | www.one-esecurity.com
M: +34 608 36 17 05
Europe (Spain): +34 911 011 000
PGP: 0x34AA 050B D15C 7593 5671 3748 40C6 8E95 6C5A 40D3

---

From: Mike Gabriel <[email-masked]>
Date: Thu, 13 Sep 2018 12:27:15 +0000

Dear Miguel,

> Package: x2gobroker
> Version: 0.0.3.1
>
> When x2gobroker-ssh is used with system with not IPv6 configured,  
> this generate very big delays in x2gobroker listsession task.
>
> /ip_proto = 0////try:////socket.getaddrinfo(addr, None,  
> socket.AF_INET6)////ip_proto = 6////except  
> socket.gaierror:////try:////socket.getaddrinfo(addr, None,  
> socket.AF_INET)////ip_proto = 4////except socket.gaierror:////# we  
> can't find a valid address for this host, so returning a  
> failure...////return False /This will be fixed testing IPv4 first or  
> more easily, setting a new option in config to select the ip protocol.
>

A while ago you reported the above issue.

I tested this now.

The portscan function in x2gobroker.utils is really fast when  
detecting that a remote host is not IPv6 supportive. It basically is a  
fast DNS query.

Is it so, that your client system has IPv4 disabled entirely (in the  
kernel)? Or what exactly did you mean by "When x2gobroker-ssh is used  
with system with not IPv6 configured..."?

I am willing to do more test, please provide more info. You possibly  
also have found a fix meanwhile. If so, I'd be happy, if you could  
share it.

Thanks
Mike

-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: [email-masked], http://das-netzwerkteam.de