Subject: x2go session disconnects causing an issue with a program or caused by an issue with a program

From: Ulrich Langenbach <[email-masked]>
Date: Sun, 18 Dec 2016 20:11:16 +0100

Package: x2goclient
Version: 4.0.5.2-0~1205~ubuntu14.04.1
severity: critical

The session disconnects at some 'arbitrary' point in a way. Today I hit the 
issue whilest running the client in debug mode: x2goclient --debug and got 
this message (line 119 in the attached log):

x2go-DEBUG-../src/onmainwindow.cpp:6014> Proxy wrote on stderr: "Error: Can't 
add a message of 4143380232 bytes to write buffer.
Error: Assuming error handling data in context [B].
Session: Terminating session at 'Sun Dec 18 18:48:08 2016'.

One of the instances of the program run within the remote session stopped 
working with an internal error.
Sometimes the session crashes completely so that also the servers X session is 
gone, although that might be a different issue.

I run an up-to-date Ubuntu 14.04.5 LTS (kernel 3.13.0-105-generic, libc 
2.19-0ubuntu6.9) and X2Go Client 4.0.5.2 installed via 
http://ppa.launchpad.net/x2go/stable/ubuntu.

This is really annoying, especially as this may ruin some hours of work and/or 
compute. The bug seems to be only triggered by one of our most used EDA tools, 
Vivado, especially in its version 2016.2.

As this issue is probably complicated to reproduce, find and fix, a workaround 
is also very appreciated.

Thank you very much!

Ulrich

---

From: Stefan Baur <[email-masked]>
Date: Mon, 19 Dec 2016 19:53:00 +0100

> is also very appreciated.

My guess is that you're seeing these crashes due to the age of the
libraries we currently ship.

Would you be able to set up a test server, where you could install the
nightly builds of X2GoServer, and patch the latest version of the
NX-Libs (currently in development over at the Arctica Project) into that?

Note that this is something you should not be doing on a production
server, unless you have a full backup you can fall back to, fast, in
case of errors.

If so, please "ping back", and we'll see to provide you with detailed
instructions.

Kind Regards,
Stefan Baur

-- 
BAUR-ITCS UG (haftungsbeschränkt)
Geschäftsführer: Stefan Baur
Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243

---

From: Ulrich Langenbach <[email-masked]>
Date: Tue, 20 Dec 2016 17:09:45 +0100

Hi Stefan,

we can setup an extra box with ubuntu 14.04 to test this issue.

We already compiled the sources as provded via the Arctica Project github repo 
for ubuntu trusty into deb packages. On our testbox we would install the x2go 
packages from the nightly (heuler) ppa and afterwards the custom build nx-
libs.

Is this the way you would like us to test the new library setup?

Thank you,
Ulrich

Am Montag, 19. Dezember 2016, 19:53:00 schrieb Stefan Baur:
> > This is really annoying, especially as this may ruin some hours of work
> > and/or compute. The bug seems to be only triggered by one of our most
> > used EDA tools, Vivado, especially in its version 2016.2.
> > 
> > As this issue is probably complicated to reproduce, find and fix, a
> > workaround is also very appreciated.
> 

-- 
Ulrich Langenbach
[email-masked]
Skype: ulangenbach

Missing Link Electronics
http://www.missinglinkelectronics.com
Skype: missing.link.electronics
Office DE: +49 (731) 141 149-0
Office US: +1  (408) 475-1490

---

From: Stefan Baur <[email-masked]>
Date: Tue, 20 Dec 2016 18:04:55 +0100

Hi Ulrich,

that is indeed how you should proceed, IMO.
Mihai or Mike#1 (see CC) should be able to tell you exactly which
packages out of the NX-lib bundle you should install (some end in -dev
or -debug; not sure if you should install them to help the devs gain
meaningful output in case it still crashes, or if you should not install
them to make the installation as X2Go-ish as possible).

Kind Regards,
Stefan Baur

---

From: Stefan Baur <[email-masked]>
Date: Wed, 21 Dec 2016 15:17:13 +0100

> them to make the installation as X2Go-ish as possible).

Mike#1 contacted me via IRC and said that you need the following
packages from Arctica NX-Libs on the server:

nxagent, libnx-x11-6, libxcomp3, libxcompshad3, and nx-x11-common

Kind Regards,
Stefan Baur

---

From: Ulrich Langenbach <[email-masked]>
Date: Wed, 04 Jan 2017 18:56:03 +0100

Hi Stefan,

happy new year! :)

Thank you for your instructions. We have been on holidays the last two weeks, 
but we will do some further investigation when we resume operations next week.

Kind Regards,
Ulrich

Missing Link Electronics

---

From: Stefan Baur <[email-masked]>
Date: Wed, 4 Jan 2017 19:09:15 +0100

Hi Ulrich,

we now have a Wiki plage explaining how to Betatest the new NX-Libs for
Debian and Ubuntu.

If you visit
http://wiki.x2go.org/doku.php/doc:howto:nx-libs-betatesting next week,
the two main authors should have had enough time to iron out any bugs
that stem from me merging their instructions into one wiki page.

-Stefan

Am 04.01.2017 um 18:56 schrieb Ulrich Langenbach:
> _______________________________________________
> x2go-dev mailing list
> [email-masked]
> http://lists.x2go.org/listinfo/x2go-dev
>

---

From: Ulrich Langenbach <[email-masked]>
Date: Wed, 15 Feb 2017 18:56:45 +0100

Hi,

some time passed, but finally I found the time to do a testrun on a dedicated 
setup based on upstream arctica libraries my colleague compiled to deb 
packages and installed on a VM. The currently tested version is a bit outdated 
from branch 3.6.x:
---- snip ----
nx-libs$ git log -1
commit 9acd13e50c3bde9105f6143922028f0de0d4ae50
Author: Mike Gabriel <[email-masked]>
Date:   Mon Dec 19 15:03:09 2016 +0100

release 3.5.99.3
nx-libs$ git remote -v
origin  git://github.com/ArcticaProject/nx-libs.git (fetch)
origin  git://github.com/ArcticaProject/nx-libs.git (push)
---- snip ----

The behavior is the same as before, the session dies at some time during some 
interaction with the tools window. I tried 64k-png and 15m-jpeg-9 modes with 
the same outcome, see attached logs for details.

Ulrich

Missing Link Electronics
Am Mittwoch, 4. Januar 2017, 18:05:02 CET schrieb X2Go Bug Tracking System:
> Thank you for the additional information you have supplied regarding
> this Bug report.
> 
> This is an automatically generated reply to let you know your message
> has been received.
> 
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
> 
> Your message has been sent to the package maintainer(s):
>  X2Go Developers <[email-masked]>
> 
> If you wish to submit further information on this problem, please
> send it to [email-masked].
> 
> Please do not send mail to [email-masked] unless you wish
> to report a problem with the Bug-tracking system.

---

From: Ulrich Langenbach <[email-masked]>
Date: Wed, 05 Apr 2017 15:11:40 +0200

Hi,

as some time passed by, is there any news about this issue?

Thank you!

Regards,
Ulrich

Missing Link Electronics
Am Mittwoch, 15. Februar 2017, 18:56:45 CEST schrieb Ulrich Langenbach:
> Hi,
> 
> some time passed, but finally I found the time to do a testrun on a
> dedicated setup based on upstream arctica libraries my colleague compiled
> to deb packages and installed on a VM. The currently tested version is a
> bit outdated from branch 3.6.x:
> ---- snip ----
> nx-libs$ git log -1
> The behavior is the same as before, the session dies at some time during
> some interaction with the tools window. I tried 64k-png and 15m-jpeg-9
> modes with the same outcome, see attached logs for details.
> 
> Ulrich
> --
> Ulrich Langenbach

---

From: Ulrich Sibiller <[email-masked]>
Date: Thu, 21 Mar 2019 19:25:37 +0100

Well, this is 2 years old and an lot happened since then. Among other
fixes we have fixed an issue with Big-Requests, which might be the
culprit here.

So can you test with the current 3.5.99.19 release of the nx-libs?

Uli

---

From: Ulrich Sibiller <[email-masked]>
Date: Thu, 21 Mar 2019 19:28:52 +0100

Also you might want to check this blog post which explicitly describes
running Vivado with x2go on AWS

Uli