X2Go Bug report logs - #1125
Remote printing not working in Debian Jessie

version graph

Package: cups-x2go; Maintainer for cups-x2go is X2Go Developers <x2go-dev@lists.x2go.org>;

Reported by: JR <jrpique@baseinf.com>

Date: Fri, 16 Dec 2016 19:50:02 UTC

Severity: normal

Found in version 3.0.1.3-0x2go1+git20161129.135+8.main.1

Full log


🔗 View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1125: [X2Go-Dev] Bug#1125: Bug#1125: Bug#1125: Remote printing not working in Debian Jessie
Reply-To: "Sebastian T." <dpbasti@wp.pl>, 1125@bugs.x2go.org
Resent-From: "Sebastian T." <dpbasti@wp.pl>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Wed, 21 Dec 2016 17:30:01 +0000
Resent-Message-ID: <handler.1125.B1125.148234132028121@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 1125
X-X2Go-PR-Package: cups-x2go
X-X2Go-PR-Keywords: 
Received: via spool by 1125-submit@bugs.x2go.org id=B1125.148234132028121
          (code B ref 1125); Wed, 21 Dec 2016 17:30:01 +0000
Received: (at 1125) by bugs.x2go.org; 21 Dec 2016 17:28:40 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-2.0 required=3.0 tests=BAYES_00,DKIM_SIGNED,
	DKIM_VALID,DKIM_VALID_AU,FREEMAIL_FROM,URIBL_BLOCKED autolearn=ham
	version=3.3.2
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id 082B35DAA3
	for <1125@bugs.x2go.org>; Wed, 21 Dec 2016 18:28:39 +0100 (CET)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id uxLtCLnPM+fS for <1125@bugs.x2go.org>;
	Wed, 21 Dec 2016 18:28:31 +0100 (CET)
X-Greylist: delayed 400 seconds by postgrey-1.34 at ymir.das-netzwerkteam.de; Wed, 21 Dec 2016 18:28:31 CET
Received: from mx4.wp.pl (mx4.wp.pl [212.77.101.11])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id B273C5DA86
	for <1125@bugs.x2go.org>; Wed, 21 Dec 2016 18:28:31 +0100 (CET)
Received: (wp-smtpd smtp.wp.pl 3646 invoked from network); 21 Dec 2016 18:21:50 +0100
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=wp.pl; s=1024a;
          t=1482340910; bh=LFriP5tqxvI/lJ58GBmEUf7LEvko+n9jpR31lXUt3Hg=;
          h=From:To:Subject;
          b=VW+Jf9wjRfvO7nTufoON33kR/mKCZj+yz0aHEMetrp8H2OVVNb56YlmAhHaaCmk64
           0OVL+FXKmzg/UJSTNcTyhAJ+6w2F1Lz7LYnFz4RF0olBldB/2XjtTMqqNHQUoIlxOe
           6tJIeZRryszRK2EGsZDFf+f7Z+bXrQErZ1njIMNQ=
Received: from unknown (HELO laprus.localnet) (dpbasti@wp.pl@[178.212.43.190])
          (envelope-sender <dpbasti@wp.pl>)
          by smtp.wp.pl (WP-SMTPD) with ECDHE-RSA-AES256-GCM-SHA384 encrypted SMTP
          for <x2go@hemsing.eu>; 21 Dec 2016 18:21:50 +0100
From: "Sebastian T." <dpbasti@wp.pl>
To: Chris <x2go@hemsing.eu>, 1125@bugs.x2go.org
Date: Wed, 21 Dec 2016 18:21:45 +0100
Message-ID: <10088227.bKZboZK6FI@laprus>
User-Agent: KMail/5.3.2 (Linux/4.4.36-8-default; KDE/5.26.0; x86_64; ; )
In-Reply-To: <3455d80c-adac-38b0-edc3-037a6a675e1a@hemsing.eu>
References: <20161216204146.f1bdcc0b625a16e446cca0f3@baseinf.com> <20161221120010.0529e0c60bb46f612cf6d87b@baseinf.com> <3455d80c-adac-38b0-edc3-037a6a675e1a@hemsing.eu>
MIME-Version: 1.0
Content-Type: multipart/signed; boundary="nextPart2754444.a9MGgxSM6f"; micalg="pgp-sha1"; protocol="application/pgp-signature"
X-WP-MailID: cf24482da654074222e51959a208924c
X-WP-AV: skaner antywirusowy Poczty Wirtualnej Polski
X-WP-SPAM: NO 000000A [cXOU]                               
[Message part 1 (text/plain, inline)]
or a lack of reverse tunnel can also cause printing issue as I reported here 
http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=1105

fix is already committed but not yet in release.

Dnia środa, 21 grudnia 2016 12:30:56 CET Chris pisze:
> Hi JR,
> 
> have you read:
> http://bugs.x2go.org/cgi-bin/bugreport.cgi?bug=694
> 
> That buf has been there since 2014. Nobody cares.
> It might be your problem.
> 
> BR
> Chris
> 
> Am 21.12.2016 um 12:00 schrieb JR:
> > Hi Stefan,
> > 
> > I tried the options discussed without success.
> > It is strange, perhaps this Windows XP has a problem.
> > So I can I will test different scenarios and I will notify the results.
> > 
> > Thank you very much.
> > 
> > Kind Regards,
> > 
> > JR
> > 
> > On Mon, 19 Dec 2016 19:48:37 +0100
> > 
> > Stefan Baur <X2Go-ML-1@baur-itcs.de> wrote:
> >> Am 16.12.2016 um 20:41 schrieb JR:
> >>> Package: cups-x2go
> >>> Version: 3.0.1.3-0x2go1+git20161129.135+8.main.1
> >>> 
> >>> I tried printing on the local PC from the x2goclient without success.
> >>> x2goclient gives no message.
> >>> 
> >>> I installed x2goserver-printing,  cups, cups-x2go and I  have installed
> >>> x2go virtual printer.
> >>> 
> >>> This happens to me only in Q4OS 1.18-Orion (Debian Jessie based). In
> >>> Q4OS 2.2-Scorpion (Debian Stretch based) it works perfectly.
> >>> 
> >>> For more details, please give a look at:
> >>> 
> >>> http://www.q4os.org/forum/viewtopic.php?id=1261
> >> 
> >> I followed that thread and the reason why you can't print at all is
> >> SystemD-related, not X2Go-related.  For various reasons, I don't think
> >> too highly of SystemD, and I strongy doubt that we'll add a patch to
> >> X2Go to fix something that is actually SystemD's fault.
> >> 
> >> Now, why you still can't print from Windows XP after applying that
> >> configuration change, that's another issue, and one that will have to be
> >> investigated.
> >> 
> >> Please check that the settings under Options/Settings/Printing match
> >> between your Linux client (where remote printing works after applying
> >> the fix) and your Windows client for your initial test.
> >> 
> >> After that, please try changing the Windows client setting to "View as
> >> PDF" instead of printing directly.  If that doesn't work, either, then
> >> you're either missing a default PDF viewing/printing application (you
> >> can try SumatraPDF if you don't want something as bloated as Adobe
> >> Reader) on the client, or there's something wrong in getting the data
> >> processed.
> >> 
> >> For that, I would suggest running the debug version of X2GoClient.exe
> >> and logging its output to a file, then attaching that file to the bug
> >> report by e-mailing it to: 1125@bugs.x2go.org
> >> 
> >> Kind Regards,
> >> Stefan Baur
> > 
> > _______________________________________________
> > x2go-dev mailing list
> > x2go-dev@lists.x2go.org
> > http://lists.x2go.org/listinfo/x2go-dev
> 
> _______________________________________________
> x2go-dev mailing list
> x2go-dev@lists.x2go.org
> http://lists.x2go.org/listinfo/x2go-dev
[signature.asc (application/pgp-signature, inline)]

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Feb 8 13:14:42 2023; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.