X2Go Bug report logs - #1125
Remote printing not working in Debian Jessie

version graph

Package: cups-x2go; Maintainer for cups-x2go is X2Go Developers <x2go-dev@lists.x2go.org>;

Reported by: JR <jrpique@baseinf.com>

Date: Fri, 16 Dec 2016 19:50:02 UTC

Severity: normal

Found in version 3.0.1.3-0x2go1+git20161129.135+8.main.1

Full log


đź”— View this message in rfc822 format

X-Loop: owner@bugs.x2go.org
Subject: Bug#1125: [X2Go-Dev] Bug#1125: Remote printing not working in Debian Jessie
Reply-To: JR <jrpique@baseinf.com>, 1125@bugs.x2go.org
Resent-From: JR <jrpique@baseinf.com>
Resent-To: x2go-dev@lists.x2go.org
Resent-CC: X2Go Developers <x2go-dev@lists.x2go.org>
X-Loop: owner@bugs.x2go.org
Resent-Date: Wed, 21 Dec 2016 11:10:02 +0000
Resent-Message-ID: <handler.1125.B1125.14823184281222@bugs.x2go.org>
Resent-Sender: owner@bugs.x2go.org
X-X2Go-PR-Message: followup 1125
X-X2Go-PR-Package: cups-x2go
X-X2Go-PR-Keywords: 
Received: via spool by 1125-submit@bugs.x2go.org id=B1125.14823184281222
          (code B ref 1125); Wed, 21 Dec 2016 11:10:02 +0000
Received: (at 1125) by bugs.x2go.org; 21 Dec 2016 11:07:08 +0000
X-Spam-Checker-Version: SpamAssassin 3.3.2 (2011-06-06) on
	ymir.das-netzwerkteam.de
X-Spam-Level: 
X-Spam-Status: No, score=-1.9 required=3.0 tests=BAYES_00,URIBL_BLOCKED
	autolearn=ham version=3.3.2
Received: from localhost (localhost [127.0.0.1])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTP id 7FBCD5DAA3
	for <1125@bugs.x2go.org>; Wed, 21 Dec 2016 12:07:01 +0100 (CET)
X-Virus-Scanned: Debian amavisd-new at ymir.das-netzwerkteam.de
Received: from ymir.das-netzwerkteam.de ([127.0.0.1])
	by localhost (ymir.das-netzwerkteam.de [127.0.0.1]) (amavisd-new, port 10024)
	with ESMTP id Zmc6C7BT4Him for <1125@bugs.x2go.org>;
	Wed, 21 Dec 2016 12:06:54 +0100 (CET)
X-Greylist: delayed 385 seconds by postgrey-1.34 at ymir.das-netzwerkteam.de; Wed, 21 Dec 2016 12:06:54 CET
Received: from vz10.tacf.cat (vz10.tacf.cat [188.165.128.192])
	by ymir.das-netzwerkteam.de (Postfix) with ESMTPS id 67D055DA86
	for <1125@bugs.x2go.org>; Wed, 21 Dec 2016 12:06:51 +0100 (CET)
Received: (qmail 10433 invoked from network); 21 Dec 2016 11:00:10 +0000
Received: from 204.red-79-158-197.dynamicip.rima-tde.net (HELO xiket)
	(79.158.197.204)
	by vz10.tacf.cat with ESMTPA; 21 Dec 2016 11:00:10 +0000
Date: Wed, 21 Dec 2016 12:00:10 +0100
From: JR <jrpique@baseinf.com>
To: 1125@bugs.x2go.org
Message-Id: <20161221120010.0529e0c60bb46f612cf6d87b@baseinf.com>
In-Reply-To: <5e9c36bf-680f-7d55-724a-6f3464a11050@baur-itcs.de>
References: <20161216204146.f1bdcc0b625a16e446cca0f3@baseinf.com>
	<5e9c36bf-680f-7d55-724a-6f3464a11050@baur-itcs.de>
Organization: Base informĂ tica, SCP
X-Mailer: Sylpheed 3.5.1 (GTK+ 2.24.23; i686-pc-mingw32)
Mime-Version: 1.0
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
X-PPP-Message-ID: <20161221110010.10431.88946@vz10.tacf.cat>
X-PPP-Vhost: baseinf.com
Hi Stefan,

I tried the options discussed without success.
It is strange, perhaps this Windows XP has a problem.
So I can I will test different scenarios and I will notify the results.

Thank you very much.

Kind Regards,

JR

On Mon, 19 Dec 2016 19:48:37 +0100
Stefan Baur <X2Go-ML-1@baur-itcs.de> wrote:

> Am 16.12.2016 um 20:41 schrieb JR:
> > Package: cups-x2go
> > Version: 3.0.1.3-0x2go1+git20161129.135+8.main.1
> > 
> > I tried printing on the local PC from the x2goclient without success.
> > x2goclient gives no message.
> > 
> > I installed x2goserver-printing,  cups, cups-x2go and I  have installed x2go virtual printer. 
> > 
> > This happens to me only in Q4OS 1.18-Orion (Debian Jessie based). In Q4OS 2.2-Scorpion (Debian Stretch based) it works perfectly.
> > 
> > For more details, please give a look at:
> > 
> > http://www.q4os.org/forum/viewtopic.php?id=1261
> 
> I followed that thread and the reason why you can't print at all is
> SystemD-related, not X2Go-related.  For various reasons, I don't think
> too highly of SystemD, and I strongy doubt that we'll add a patch to
> X2Go to fix something that is actually SystemD's fault.
> 
> Now, why you still can't print from Windows XP after applying that
> configuration change, that's another issue, and one that will have to be
> investigated.
> 
> Please check that the settings under Options/Settings/Printing match
> between your Linux client (where remote printing works after applying
> the fix) and your Windows client for your initial test.
> 
> After that, please try changing the Windows client setting to "View as
> PDF" instead of printing directly.  If that doesn't work, either, then
> you're either missing a default PDF viewing/printing application (you
> can try SumatraPDF if you don't want something as bloated as Adobe
> Reader) on the client, or there's something wrong in getting the data
> processed.
> 
> For that, I would suggest running the debug version of X2GoClient.exe
> and logging its output to a file, then attaching that file to the bug
> report by e-mailing it to: 1125@bugs.x2go.org
> 
> Kind Regards,
> Stefan Baur
> 
> -- 
> BAUR-ITCS UG (haftungsbeschränkt)
> Geschäftsführer: Stefan Baur
> Eichenäckerweg 10, 89081 Ulm | Registergericht Ulm, HRB 724364
> Fon/Fax 0731 40 34 66-36/-35 | USt-IdNr.: DE268653243
> 

Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Wed Feb 8 13:27:23 2023; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.