X2Go Bug report logs - #1111
SLES 11.3 - x2go-extras - pwgen-2.06-90.3 - Header V4 RSA/SHA1 signature: BAD, key ID

Package: packages.x2go.org; Maintainer for packages.x2go.org is x2go-dev@lists.x2go.org;

Reported by: "Olaf Matthaei" <o.matthaei@narz-avn.de>

Date: Thu, 10 Nov 2016 06:50:02 UTC

Severity: normal

Tags: moreinfo

Done: Mihai Moldovan <ionic@ionic.de>

Bug is archived. No further changes may be made.

Toggle useless messages

View this report as an mbox folder, status mbox, maintainer mbox


Report forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>, owner@bugs.x2go.org:
Bug#1111; Package x2goserver version: 4.0.1.19-0. (Thu, 10 Nov 2016 06:50:02 GMT) (full text, mbox, link).


Acknowledgement sent to "Olaf Matthaei" <o.matthaei@narz-avn.de>:
New Bug report received and forwarded. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>, owner@bugs.x2go.org. (Thu, 10 Nov 2016 06:50:02 GMT) (full text, mbox, link).


Message #5 received at submit@bugs.x2go.org (full text, mbox, reply):

From: "Olaf Matthaei" <o.matthaei@narz-avn.de>
To: <submit@bugs.x2go.org>
Subject: Package: x2goserver Version: 4.0.1.19-0 SLES 11.3 - x2go-extras - pwgen-2.06-90.3 - Header V4 RSA/SHA1 signature: BAD, key ID
Date: Thu, 10 Nov 2016 07:41:10 +0100
[Message part 1 (text/plain, inline)]
Package: x2goserver Version: 4.0.1.19-0

The Machine is an virtuell SUSE SLES 11 SP 3, fresh installed to document
the error. I know this E-Mail :
http://lists.x2go.org/pipermail/x2go-dev/2016-June/011193.html

The Problem is : 
Installation of pwgen-2.06-90.3 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error:
/var/cache/zypp/packages/x2go-extras/pwgen-2.06-90.3.x86_64.rpm: Header V4
RSA/SHA1 signature: BAD, key ID 9c6b0b2b
error: /var/cache/zypp/packages/x2go-extras/pwgen-2.06-90.3.x86_64.rpm
cannot be installed.

This are the steps:

linux-0xmj:~ # zypper addrepo
http://download.opensuse.org/repositories/devel:languages:perl/SLE_11_SP3/de
vel:languages:perl.repo
Adding repository 'perl modules (SLE_11_SP3)' [done]
Repository 'perl modules (SLE_11_SP3)' successfully added
Enabled: Yes
Autorefresh: No
GPG check: Yes
URI:
http://download.opensuse.org/repositories/devel:/languages:/perl/SLE_11_SP3/

linux-0xmj:~ # zypper refresh
Retrieving repository 'perl modules (SLE_11_SP3)' metadata [\]

New repository or package signing key received:
Key ID: DCCA98DDDCEF338C
Key Name: devel:languages:perl OBS Project
<devel:languages:perl@build.opensuse.org>
Key Fingerprint: 36F0AC0BCA9D8AF2871703C5DCCA98DDDCEF338C
Key Created: Thu Dec 18 23:36:03 2014
Key Expires: Sat Feb 25 23:36:03 2017
Repository: perl modules (SLE_11_SP3)

Do you want to reject the key, trust temporarily, or trust always? [r/t/a/?]
(r): a
Retrieving repository 'perl modules (SLE_11_SP3)' metadata [done]
Building repository 'perl modules (SLE_11_SP3)' cache [done]
All repositories have been refreshed.
linux-0xmj:~ # rpm --import http://packages.x2go.org/pub.key
linux-0xmj:~ # zypper ar http://packages.x2go.org/sle/11.3/extras/x86_64
If only one argument is used, it must be a URI pointing to a .repo file.
addrepo (ar) [options] <URI> <alias>
addrepo (ar) [options] <file.repo>

Add a repository to the sytem. The repository can be specified by its URI or
can be read from specified .repo file (even remote).

  Command options:
-r, --repo <file.repo>  Just another means to specify a .repo file to read.
-t, --type <type>       Type of repository (yast2, rpm-md, plaindir).
-d, --disable           Add the repository as disabled.
-c, --check             Probe URI.
-C, --no-check          Don't probe URI, probe later during refresh.
-n, --name <name>       Specify descriptive name for the repository.
-k, --keep-packages     Enable RPM files caching.
-K, --no-keep-packages  Disable RPM files caching.
-g, --gpgcheck          Enable GPG check for this repository.
-G, --no-gpgcheck       Disable GPG check for this repository.
-f, --refresh           Enable autorefresh of the repository.

linux-0xmj:~ # zypper ar http://packages.x2go.org/sle/11.3/extras/x86_64
x2go-extras
Adding repository 'x2go-extras' [done]
Repository 'x2go-extras' successfully added
Enabled: Yes
Autorefresh: No
GPG check: Yes
URI: http://packages.x2go.org/sle/11.3/extras/x86_64

linux-0xmj:~ # zypper ar http://packages.x2go.org/sle/11.3/main/x86_64
x2go-release
Adding repository 'x2go-release' [done]
Repository 'x2go-release' successfully added
Enabled: Yes
Autorefresh: No
GPG check: Yes
URI: http://packages.x2go.org/sle/11.3/main/x86_64

linux-0xmj:~ # zypper refresh
Repository 'perl modules (SLE_11_SP3)' is up to date.
Retrieving repository 'x2go-extras' metadata [done]
Building repository 'x2go-extras' cache [done]
Retrieving repository 'x2go-release' metadata [done]
Building repository 'x2go-release' cache [done]
All repositories have been refreshed.
linux-0xmj:~ # zypper install x2goserver
Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following NEW packages are going to be installed:
  Mesa dbus-1-x11 desktop-data-SLED fonts-config ft2demos fuse
  hicolor-icon-theme icewm icewm-lite libNX_X11-6 libNX_Xcomposite1
  libNX_Xdamage1 libNX_Xdmcp6 libNX_Xext6 libNX_Xfixes3 libNX_Xinerama1
  libNX_Xpm4 libNX_Xrandr2 libNX_Xrender1 libNX_Xtst6 libXcomp3 libXcompext3
  libXcompshad3 libasound2 libdrm libfuse2 libmysqlclient_r15 libpciaccess0
  libpixman-1-0 libpq5 libqt4 libqt4-qt3support libqt4-sql libqt4-sql-mysql
  libqt4-x11 nx-libs nxagent perl-Capture-Tiny perl-Config-Simple
perl-DBD-Pg
  perl-DBD-SQLite perl-DBI perl-File-BaseDir perl-File-Which perl-Try-Tiny
  pkg-config pwgen sax2 sax2-ident sax2-libsax sax2-libsax-perl sax2-tools
  sles-admin_de sles-deployment_de sles-installquick_de sles-manuals_en
sshfs
  x2goagent x2goserver x2goserver-extensions x2goserver-xsession xdg-menu
  xkeyboard-config xorg-x11 xorg-x11-driver-input xorg-x11-driver-video
  xorg-x11-driver-video-radeonhd xorg-x11-fonts-core xorg-x11-libXdmcp
  xorg-x11-libXfixes xorg-x11-libXmu xorg-x11-libXp xorg-x11-libXpm
  xorg-x11-libXprintUtil xorg-x11-libXrender xorg-x11-libXv
xorg-x11-libfontenc
  xorg-x11-libs xorg-x11-libxkbfile xorg-x11-server xorg-x11-xauth xterm

The following recommended packages were automatically selected:
  dbus-1-x11 ft2demos libqt4-sql-mysql

The following packages need additional customer contract to get support:
  libmysqlclient_r15 libpq5

The following packages are not supported by their vendor:
  libNX_X11-6 libNX_Xcomposite1 libNX_Xdamage1 libNX_Xdmcp6 libNX_Xext6
  libNX_Xfixes3 libNX_Xinerama1 libNX_Xpm4 libNX_Xrandr2 libNX_Xrender1
  libNX_Xtst6 libXcomp3 libXcompext3 libXcompshad3 nx-libs nxagent
  perl-Capture-Tiny perl-Config-Simple perl-DBD-Pg perl-DBI
perl-File-BaseDir
  perl-File-Which perl-Try-Tiny pwgen sshfs x2goagent x2goserver
  x2goserver-extensions x2goserver-xsession

82 new packages to install.
Overall download size: 109.0 MiB. After the operation, additional 232.8 MiB
will be used.
Continue? [y/n/?] (y): y
Retrieving package fonts-config-20080121-25.21.noarch (1/82), 34.0 KiB
(123.0 KiB unpacked)
Retrieving package hicolor-icon-theme-0.10-102.22.noarch (2/82), 35.0 KiB
(48.0 KiB unpacked)
Retrieving package sles-admin_de-11.3-0.9.2.noarch (3/82), 3.3 MiB (5.3 MiB
unpacked)
Retrieving package sles-deployment_de-11.3-0.9.2.noarch (4/82), 5.1 MiB (6.5
MiB unpacked)
Retrieving package sles-installquick_de-11.3-0.7.2.noarch (5/82), 6.4 MiB
(6.8 MiB unpacked)
Retrieving package sles-manuals_en-11.3-0.21.1.noarch (6/82), 14.5 MiB (21.9
MiB unpacked)
Retrieving package dbus-1-x11-1.2.10-3.27.1.x86_64 (7/82), 34.0 KiB (30.0
KiB unpacked)
Retrieving package ft2demos-2.3.7-25.32.1.x86_64 (8/82), 107.0 KiB (596.0
KiB unpacked)
Retrieving package fuse-2.8.7-0.9.12.x86_64 (9/82), 63.0 KiB (170.0 KiB
unpacked)
Retrieving package libasound2-1.0.18-16.24.1.x86_64 (10/82), 311.0 KiB
(995.0 KiB unpacked)
Retrieving package libfuse2-2.8.7-0.9.12.x86_64 (11/82), 61.0 KiB (218.0 KiB
unpacked)
Retrieving package libmysqlclient_r15-5.0.96-0.6.1.x86_64 (12/82), 478.0 KiB
(1.4 MiB unpacked)
Retrieving package libpciaccess0-7.4_0.11.0-0.4.6.1.x86_64 (13/82), 17.0 KiB
(35.0 KiB unpacked)
Retrieving package libpixman-1-0-0.24.4-0.11.1.x86_64 (14/82), 180.0 KiB
(541.0 KiB unpacked)
Retrieving package libpq5-9.1.9-0.3.1.x86_64 (15/82), 157.0 KiB (455.0 KiB
unpacked)
Retrieving package libqt4-4.6.3-5.25.5.x86_64 (16/82), 2.5 MiB (8.5 MiB
unpacked)
Retrieving package pkg-config-0.23-1.22.x86_64 (17/82), 78.0 KiB (181.0 KiB
unpacked)
Retrieving package xorg-x11-libXdmcp-7.4-1.15.x86_64 (18/82), 11.0 KiB (23.0
KiB unpacked)
Retrieving package xorg-x11-libXfixes-7.4-1.14.x86_64 (19/82), 10.0 KiB
(23.0 KiB unpacked)
Retrieving package xorg-x11-libXmu-7.4-1.17.x86_64 (20/82), 48.0 KiB (119.0
KiB unpacked)
Retrieving package xorg-x11-libXp-7.4-1.14.x86_64 (21/82), 16.0 KiB (39.0
KiB unpacked)
Retrieving package xorg-x11-libXpm-7.4-1.17.x86_64 (22/82), 46.0 KiB (118.0
KiB unpacked)
Retrieving package xorg-x11-libXrender-7.4-1.14.x86_64 (23/82), 18.0 KiB
(39.0 KiB unpacked)
Retrieving package xorg-x11-libXv-7.4-1.14.x86_64 (24/82), 11.0 KiB (23.0
KiB unpacked)
Retrieving package xorg-x11-libfontenc-7.4-1.15.x86_64 (25/82), 14.0 KiB
(30.0 KiB unpacked)
Retrieving package xorg-x11-libxkbfile-7.4-1.14.x86_64 (26/82), 63.0 KiB
(149.0 KiB unpacked)
Retrieving package xorg-x11-fonts-core-7.4-1.20.noarch (27/82), 9.1 MiB
(10.4 MiB unpacked)
Retrieving package desktop-data-SLED-11-29.22.58.noarch (28/82), 21.3 MiB
(24.5 MiB unpacked)
Retrieving package libdrm-2.4.41-0.8.46.x86_64 (29/82), 139.0 KiB (368.0 KiB
unpacked)
Retrieving package libqt4-sql-4.6.3-5.25.5.x86_64 (30/82), 111.0 KiB (260.0
KiB unpacked)
Retrieving package xorg-x11-xauth-7.4-9.62.46.x86_64 (31/82), 57.0 KiB (44.0
KiB unpacked)
Retrieving package xorg-x11-libXprintUtil-7.4-1.17.x86_64 (32/82), 16.0 KiB
(35.0 KiB unpacked)
Retrieving package libqt4-sql-mysql-4.6.3-5.25.4.x86_64 (33/82), 49.0 KiB
(95.0 KiB unpacked)
Retrieving package xorg-x11-libs-7.4-8.26.32.1.x86_64 (34/82), 700.0 KiB
(2.8 MiB unpacked)
Retrieving package xterm-238-1.16.x86_64 (35/82), 1.4 MiB (2.0 MiB unpacked)
Retrieving package sax2-tools-8.1-561.582.76.x86_64 (36/82), 116.0 KiB
(212.0 KiB unpacked)
Retrieving package Mesa-9.0.3-0.17.1.x86_64 (37/82), 18.9 MiB (65.7 MiB
unpacked)
Retrieving package xdg-menu-0.2-191.22.x86_64 (38/82), 13.0 KiB (45.0 KiB
unpacked)
Retrieving package libqt4-qt3support-4.6.3-5.25.5.x86_64 (39/82), 1.1 MiB
(3.6 MiB unpacked)
Retrieving package icewm-lite-1.2.36-1.18.x86_64 (40/82), 197.0 KiB (755.0
KiB unpacked)
Retrieving package libqt4-x11-4.6.3-5.25.5.x86_64 (41/82), 10.2 MiB (26.6
MiB unpacked)
Retrieving package icewm-1.2.36-1.35.x86_64 (42/82), 252.0 KiB (1.0 MiB
unpacked)
Retrieving package sax2-libsax-perl-8.1-561.582.76.x86_64 (43/82), 224.0 KiB
(1.0 MiB unpacked)
Retrieving package sax2-libsax-8.1-561.582.76.x86_64 (44/82), 348.0 KiB (1.2
MiB unpacked)
Retrieving package sax2-ident-8.1-561.582.76.x86_64 (45/82), 167.0 KiB (1.2
MiB unpacked)
Retrieving package xorg-x11-7.4-9.62.46.x86_64 (46/82), 2.2 MiB (8.9 MiB
unpacked)
Retrieving package xorg-x11-server-7.4-27.81.7.x86_64 (47/82), 1.5 MiB (3.9
MiB unpacked)
Retrieving package xkeyboard-config-1.5-4.40.1.noarch (48/82), 463.0 KiB
(3.1 MiB unpacked)
Retrieving package
xorg-x11-driver-video-radeonhd-1.3.0_20100512_80ba041-1.8.55.x86_64 (49/82),
242.0 KiB (695.0 KiB unpacked)
Retrieving package xorg-x11-driver-video-7.4.0.1-0.81.27.x86_64 (50/82), 2.1
MiB (7.0 MiB unpacked)
Retrieving package sax2-8.1-561.582.76.x86_64 (51/82), 267.0 KiB (726.0 KiB
unpacked)
Retrieving package xorg-x11-driver-input-7.4-13.44.1.x86_64 (52/82), 306.0
KiB (868.0 KiB unpacked)
Retrieving package perl-Capture-Tiny-0.44-42.1.noarch (53/82), 38.0 KiB
(73.0 KiB unpacked)
Retrieving: perl-Capture-Tiny-0.44-42.1.noarch.rpm [done (256.6 KiB/s)]
Retrieving package perl-Config-Simple-4.59-34.5.x86_64 (54/82), 33.0 KiB
(84.0 KiB unpacked)
Retrieving: perl-Config-Simple-4.59-34.5.x86_64.rpm [done]
Retrieving package perl-DBI-1.636-54.12.x86_64 (55/82), 884.0 KiB (2.3 MiB
unpacked)
Retrieving: perl-DBI-1.636-54.12.x86_64.rpm [done (606.4 KiB/s)]
Retrieving package perl-File-BaseDir-0.03-13.4.noarch (56/82), 11.0 KiB
(13.0 KiB unpacked)
Retrieving: perl-File-BaseDir-0.03-13.4.noarch.rpm [done]
Retrieving package perl-File-Which-1.21-47.1.noarch (57/82), 25.0 KiB (43.0
KiB unpacked)
Retrieving: perl-File-Which-1.21-47.1.noarch.rpm [done]
Retrieving package perl-Try-Tiny-0.27-41.2.noarch (58/82), 28.0 KiB (37.0
KiB unpacked)
Retrieving: perl-Try-Tiny-0.27-41.2.noarch.rpm [done]
Retrieving package perl-DBD-Pg-3.3.0-39.1.x86_64 (59/82), 211.0 KiB (607.0
KiB unpacked)
Retrieving: perl-DBD-Pg-3.3.0-39.1.x86_64.rpm [done (489.7 KiB/s)]
Retrieving package pwgen-2.06-90.3.x86_64 (60/82), 19.0 KiB (39.0 KiB
unpacked)
Retrieving: pwgen-2.06-90.3.x86_64.rpm [done]
Retrieving package sshfs-2.4-5.1.x86_64 (61/82), 43.0 KiB (89.0 KiB
unpacked)
Retrieving: sshfs-2.4-5.1.x86_64.rpm [done]
Retrieving package nx-libs-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64
(62/82), 15.0 KiB (30.0 KiB unpacked)
Retrieving: nx-libs-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm
[done]
Retrieving package libXcomp3-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64
(63/82), 338.0 KiB (1.2 MiB unpacked)
Retrieving: libXcomp3-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm
[done]
Retrieving package
libNX_Xdmcp6-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64 (64/82), 12.0
KiB (27.0 KiB unpacked)
Retrieving: libNX_Xdmcp6-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm
[done]
Retrieving package
libNX_X11-6-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64 (65/82), 516.0
KiB (1.2 MiB unpacked)
Retrieving: libNX_X11-6-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm
[done]
Retrieving package
libXcompext3-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64 (66/82), 35.0
KiB (93.0 KiB unpacked)
Retrieving: libXcompext3-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm
[done]
Retrieving package
libNX_Xext6-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64 (67/82), 28.0
KiB (85.0 KiB unpacked)
Retrieving: libNX_Xext6-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm
[done]
Retrieving package
libNX_Xtst6-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64 (68/82), 13.0
KiB (32.0 KiB unpacked)
Retrieving: libNX_Xtst6-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm
[done]
Retrieving package
libNX_Xrender1-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64 (69/82), 20.0
KiB (49.0 KiB unpacked)
Retrieving:
libNX_Xrender1-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm [done]
Retrieving package
libNX_Xpm4-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64 (70/82), 35.0 KiB
(80.0 KiB unpacked)
Retrieving: libNX_Xpm4-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm
[done]
Retrieving package
libNX_Xinerama1-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64 (71/82), 8.0
KiB (14.0 KiB unpacked)
Retrieving:
libNX_Xinerama1-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm [done]
Retrieving package
libNX_Xfixes3-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64 (72/82), 11.0
KiB (27.0 KiB unpacked)
Retrieving:
libNX_Xfixes3-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm [done]
Retrieving package
libNX_Xdamage1-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64 (73/82), 8.0
KiB (13.0 KiB unpacked)
Retrieving:
libNX_Xdamage1-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm [done]
Retrieving package
libNX_Xrandr2-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64 (74/82), 10.0
KiB (18.0 KiB unpacked)
Retrieving:
libNX_Xrandr2-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm [done]
Retrieving package
libNX_Xcomposite1-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64 (75/82),
8.0 KiB (13.0 KiB unpacked)
Retrieving:
libNX_Xcomposite1-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm [done]
Retrieving package
libXcompshad3-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64 (76/82), 34.0
KiB (91.0 KiB unpacked)
Retrieving:
libXcompshad3-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm [done]
Retrieving package nxagent-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64
(77/82), 1.6 MiB (5.0 MiB unpacked)
Retrieving: nxagent-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm
[done (522.7 KiB/s)]
Retrieving package x2goagent-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64
(78/82), 12.0 KiB (37.0 KiB unpacked)
Retrieving: x2goagent-3.5.0.32-0.0x2go1.1.git20160615.734.main.x86_64.rpm
[done]
Retrieving package perl-DBD-SQLite-1.14-11.14.x86_64 (79/82), 45.0 KiB
(103.0 KiB unpacked)
Retrieving package
x2goserver-xsession-4.0.1.19-0.0x2go2.1.git20160621.1064.main.x86_64
(80/82), 26.0 KiB (74.0 KiB unpacked)
Retrieving:
x2goserver-xsession-4.0.1.19-0.0x2go2.1.git20160621.1064.main.x86_64.rpm
[done]
Retrieving package
x2goserver-extensions-4.0.1.19-0.0x2go2.1.git20160621.1064.main.x86_64
(81/82), 27.0 KiB (70.0 KiB unpacked)
Retrieving:
x2goserver-extensions-4.0.1.19-0.0x2go2.1.git20160621.1064.main.x86_64.rpm
[done]
Retrieving package
x2goserver-4.0.1.19-0.0x2go2.1.git20160621.1064.main.x86_64 (82/82), 84.0
KiB (298.0 KiB unpacked)
Retrieving: x2goserver-4.0.1.19-0.0x2go2.1.git20160621.1064.main.x86_64.rpm
[donInstalling: fonts-config-20080121-25.21 [done]
Additional rpm output:
Updating etc/sysconfig/fonts-config...


Installing: hicolor-icon-theme-0.10-102.22 [done]
Installing: sles-admin_de-11.3-0.9.2 [done]
Installing: sles-deployment_de-11.3-0.9.2 [done]
Installing: sles-installquick_de-11.3-0.7.2 [done]
Installing: sles-manuals_en-11.3-0.21.1 [done]
Installing: dbus-1-x11-1.2.10-3.27.1 [done]
Installing: ft2demos-2.3.7-25.32.1 [done]
Installing: fuse-2.8.7-0.9.12 [done]
Additional rpm output:
Starting SuSEconfig, the SuSE Configuration Tool...
Running module permissions only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.permissions...
Checking permissions and ownerships - using the permissions files
        /etc/permissions
        /etc/permissions.easy
        /etc/permissions.d/mail-server
        /etc/permissions.d/postfix
        /etc/permissions.local
setting /usr/bin/fusermount to root:trusted 4755. (wrong permissions 4750)
Finished.


Installing: libasound2-1.0.18-16.24.1 [done]
Installing: libfuse2-2.8.7-0.9.12 [done]
Installing: libmysqlclient_r15-5.0.96-0.6.1 [done]
Installing: libpciaccess0-7.4_0.11.0-0.4.6.1 [done]
Installing: libpixman-1-0-0.24.4-0.11.1 [done]
Installing: libpq5-9.1.9-0.3.1 [done]
Installing: libqt4-4.6.3-5.25.5 [done]
Installing: pkg-config-0.23-1.22 [done]
Installing: xorg-x11-libXdmcp-7.4-1.15 [done]
Installing: xorg-x11-libXfixes-7.4-1.14 [done]
Installing: xorg-x11-libXmu-7.4-1.17 [done]
Installing: xorg-x11-libXp-7.4-1.14 [done]
Installing: xorg-x11-libXpm-7.4-1.17 [done]
Installing: xorg-x11-libXrender-7.4-1.14 [done]
Installing: xorg-x11-libXv-7.4-1.14 [done]
Installing: xorg-x11-libfontenc-7.4-1.15 [done]
Installing: xorg-x11-libxkbfile-7.4-1.14 [done]
Installing: xorg-x11-fonts-core-7.4-1.20 [done]
Additional rpm output:
Starting SuSEconfig, the SuSE Configuration Tool...
Running module fonts only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.fonts...
Creating fonts.{scale,dir} files ...
writing /etc/fonts/suse-font-dirs.conf
writing /etc/fonts/suse-hinting.conf
writing /etc/fonts/suse-bitmaps.conf
Creating cache files for fontconfig ................
generating java font setup
Warning: cannot find a sans serif Japanese font. Japanese in Java might not
work.
Warning: cannot find a serif Japanese font. Japanese in Java might not work.
Warning: cannot find a sans serif simplified Chinese font. Simplified
Chinese in Java might not work.
Warning: cannot find a serif simplified Chinese font. Simplified Chinese in
Java might not work.
Warning: cannot find a sans serif traditional Chinese font. Traditional
Chinese in Java might not work.
Warning: cannot find a serif traditional Chinese font. Traditional Chinese
in Java might not work.
Warning: cannot find a sans serif Korean font. Korean in Java might not
work.
Warning: cannot find a serif Korean font. Korean in Java might not work.
Finished.


Installing: desktop-data-SLED-11-29.22.58 [done]
Additional rpm output:
Updating etc/sysconfig/windowmanager...


Installing: libdrm-2.4.41-0.8.46 [done]
Installing: libqt4-sql-4.6.3-5.25.5 [done]
Installing: xorg-x11-xauth-7.4-9.62.46 [done]
Installing: xorg-x11-libXprintUtil-7.4-1.17 [done]
Installing: libqt4-sql-mysql-4.6.3-5.25.4 [done]
Installing: xorg-x11-libs-7.4-8.26.32.1 [done]
Installing: xterm-238-1.16 [done]
Additional rpm output:
Starting SuSEconfig, the SuSE Configuration Tool...
Running module fonts only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.fonts...
Creating fonts.{scale,dir} files ...
/etc/fonts/suse-font-dirs.conf unchanged
/etc/fonts/suse-hinting.conf unchanged
/etc/fonts/suse-bitmaps.conf unchanged
Creating cache files for fontconfig ................
generating java font setup
Warning: cannot find a sans serif Japanese font. Japanese in Java might not
work.
Warning: cannot find a serif Japanese font. Japanese in Java might not work.
Warning: cannot find a sans serif simplified Chinese font. Simplified
Chinese in Java might not work.
Warning: cannot find a serif simplified Chinese font. Simplified Chinese in
Java might not work.
Warning: cannot find a sans serif traditional Chinese font. Traditional
Chinese in Java might not work.
Warning: cannot find a serif traditional Chinese font. Traditional Chinese
in Java might not work.
Warning: cannot find a sans serif Korean font. Korean in Java might not
work.
Warning: cannot find a serif Korean font. Korean in Java might not work.
Finished.


Installing: sax2-tools-8.1-561.582.76 [done]
Installing: Mesa-9.0.3-0.17.1 [done]
Installing: xdg-menu-0.2-191.22 [done]
Installing: libqt4-qt3support-4.6.3-5.25.5 [done]
Installing: icewm-lite-1.2.36-1.18 [done]
Installing: libqt4-x11-4.6.3-5.25.5 [done]
Installing: icewm-1.2.36-1.35 [done]
Installing: sax2-libsax-perl-8.1-561.582.76 [done]
Installing: sax2-libsax-8.1-561.582.76 [done]
Installing: sax2-ident-8.1-561.582.76 [done]
Installing: xorg-x11-7.4-9.62.46 [done]
Additional rpm output:
Updating etc/sysconfig/displaymanager...
Starting SuSEconfig, the SuSE Configuration Tool...
Running module permissions only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.permissions...
Finished.


Installing: xorg-x11-server-7.4-27.81.7 [done]
Additional rpm output:
Updating etc/sysconfig/displaymanager...
Starting SuSEconfig, the SuSE Configuration Tool...
Running module permissions only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.permissions...
Checking permissions and ownerships - using the permissions files
        /etc/permissions
        /etc/permissions.easy
        /etc/permissions.d/mail-server
        /etc/permissions.d/postfix
        /etc/permissions.local
setting /usr/bin/Xorg to root:root 4711. (wrong permissions 0711)
Finished.


Installing: xkeyboard-config-1.5-4.40.1 [done]
Installing: xorg-x11-driver-video-radeonhd-1.3.0_20100512_80ba041-1.8.55
[done]
Installing: xorg-x11-driver-video-7.4.0.1-0.81.27 [done]
Installing: sax2-8.1-561.582.76 [done]
Installing: xorg-x11-driver-input-7.4-13.44.1 [done]
Installing: perl-Capture-Tiny-0.44-42.1 [done]
Installing: perl-Config-Simple-4.59-34.5 [done]
Installing: perl-DBI-1.636-54.12 [done]
Installing: perl-File-BaseDir-0.03-13.4 [done]
Installing: perl-File-Which-1.21-47.1 [done]
Installing: perl-Try-Tiny-0.27-41.2 [done]
Installing: perl-DBD-Pg-3.3.0-39.1 [done]
Installing: pwgen-2.06-90.3 [error]
Installation of pwgen-2.06-90.3 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error:
/var/cache/zypp/packages/x2go-extras/pwgen-2.06-90.3.x86_64.rpm: Header V4
RSA/SHA1 signature: BAD, key ID 9c6b0b2b
error: /var/cache/zypp/packages/x2go-extras/pwgen-2.06-90.3.x86_64.rpm
cannot be installed


Abort, retry, ignore? [a/r/i] (a): a
Problem occured during or after installation or removal of packages:
Installation aborted by user

Please see the above error message for a hint.
linux-0xmj:~ # 

Mit freundlichen Grüßen

Olaf Matthaei

------------
Dipl.-Ing. Olaf Matthaei
Unternehmensorganisation
PMO

NARZ/AVN Apothekenpartner

E-Mail  : o.matthaei@narz-avn.de
Tel.    : 0421 5762 – 115
Fax     : 0421 5762 – 299
Internet: www.narz-avn.de

Im Serviceverbund mit der
GfI Gesellschaft für Informations- und Datenverarbeitung mbH, Bauerland 3,
28259 Bremen

Gerichtsstand: Amtsgericht Bremen, HRB 10857
Geschäftsführer: Dipl.-Volkswirt Hanno Helmker, Uwe Ennen
[Olaf Matthaei (o.matthaei@narz-avn.de).vcf (text/x-vcard, attachment)]

Information forwarded to x2go-dev@lists.x2go.org, X2Go Developers <x2go-dev@lists.x2go.org>, owner@bugs.x2go.org:
Bug#1111; Package x2goserver version: 4.0.1.19-0. (Sun, 04 Dec 2016 12:25:01 GMT) (full text, mbox, link).


Acknowledgement sent to Mihai Moldovan <ionic@ionic.de>:
Extra info received and forwarded to list. Copy sent to X2Go Developers <x2go-dev@lists.x2go.org>, owner@bugs.x2go.org. (Sun, 04 Dec 2016 12:25:02 GMT) (full text, mbox, link).


Message #10 received at 1111@bugs.x2go.org (full text, mbox, reply):

From: Mihai Moldovan <ionic@ionic.de>
To: Olaf Matthaei <o.matthaei@narz-avn.de>, 1111@bugs.x2go.org
Subject: Re: Package: x2goserver Version: 4.0.1.19-0 SLES 11.3 - x2go-extras - pwgen-2.06-90.3 - Header V4 RSA/SHA1 signature: BAD, key ID
Date: Sun, 4 Dec 2016 13:20:50 +0100
[Message part 1 (text/plain, inline)]
Control: reassign -1 packages.x2go.org
Control: tag -1 moreinfo
Control: retitle -1 SLES 11.3 - x2go-extras - pwgen-2.06-90.3 - Header V4
RSA/SHA1 signature: BAD, key ID

Can you please retry? Note that you will have to re-add the repository (this
time *without* referring to the architecture type - which is the common way
SUSE-repositories are layed out.)

http://wiki.x2go.org/doku.php/wiki:repositories:suse#base_installation

I don't think this will immediately fix your problem, although it's generally
possible because with the new repository layout you will also have to import the
GPG key in question, which should automatically register it with rpm and package
verification should thus succeed - in theory.



Mihai

[signature.asc (application/pgp-signature, attachment)]

Bug reassigned from package 'x2goserver version: 4.0.1.19-0' to 'packages.x2go.org'. Request was from Mihai Moldovan <ionic@ionic.de> to 1111-submit@bugs.x2go.org. (Sun, 04 Dec 2016 12:25:02 GMT) (full text, mbox, link).


Added tag(s) moreinfo. Request was from Mihai Moldovan <ionic@ionic.de> to 1111-submit@bugs.x2go.org. (Sun, 04 Dec 2016 12:25:02 GMT) (full text, mbox, link).


Changed Bug title to 'SLES 11.3 - x2go-extras - pwgen-2.06-90.3 - Header V4' from 'Package: x2goserver Version: 4.0.1.19-0 SLES 11.3 - x2go-extras - pwgen-2.06-90.3 - Header V4 RSA/SHA1 signature: BAD, key ID ' Request was from Mihai Moldovan <ionic@ionic.de> to 1111-submit@bugs.x2go.org. (Sun, 04 Dec 2016 12:25:02 GMT) (full text, mbox, link).


Changed Bug title to 'SLES 11.3 - x2go-extras - pwgen-2.06-90.3 - Header V4 RSA/SHA1 signature: BAD, key ID' from 'SLES 11.3 - x2go-extras - pwgen-2.06-90.3 - Header V4' Request was from Mihai Moldovan <ionic@ionic.de> to control@bugs.x2go.org. (Sun, 04 Dec 2016 12:40:02 GMT) (full text, mbox, link).


Information forwarded to x2go-dev@lists.x2go.org, x2go-project@lists.x2go.org:
Bug#1111; Package packages.x2go.org. (Wed, 07 Dec 2016 18:50:01 GMT) (full text, mbox, link).


Acknowledgement sent to Mihai Moldovan <ionic@ionic.de>:
Extra info received and forwarded to list. Copy sent to x2go-project@lists.x2go.org. (Wed, 07 Dec 2016 18:50:01 GMT) (full text, mbox, link).


Message #23 received at 1111@bugs.x2go.org (full text, mbox, reply):

From: Mihai Moldovan <ionic@ionic.de>
To: Olaf Matthaei <o.matthaei@narz-avn.de>
Cc: 1111@bugs.x2go.org
Subject: Re: Package: x2goserver Version: 4.0.1.19-0 SLES 11.3 - x2go-extras - pwgen-2.06-90.3 - Header V4 RSA/SHA1 signature: BAD, key ID
Date: Wed, 7 Dec 2016 19:46:21 +0100
[Message part 1 (text/plain, inline)]
On 07.12.2016 06:43 AM, Olaf Matthaei wrote:
> What do you mean with "this time *without* referring to the architecture
> type" ? I followed the way in the wiki.

The old behavior was to have one repository for every architecture, but that's
not the "SUSE standard repository layout". Instead, SUSE uses one repository for
all architectures.

The information in the wiki is fine and already updated. If you take a close
look at your last email/command output, you'll notice that the repository
previously had x86_64 in the URL while it now doesn't.


> Here are the result:
> 
> zypper refresh
> Retrieving repository 'perl modules (SLE_11_SP3)' metadata [done]
> Building repository 'perl modules (SLE_11_SP3)' cache [done]
> File '/repodata/repomd.xml' not found on medium
> 'http://packages.x2go.org/sle/11.3/extras/x86_64'
> 
> Abort, retry, ignore? [a/r/i/?] (a): r
> File '/repodata/repomd.xml' not found on medium
> 'http://packages.x2go.org/sle/11.3/extras/x86_64'
> 
> Abort, retry, ignore? [a/r/i/?] (a): i
> Error retrieving metadata for 'x2go-extras':
> SKIP request: User-requested skipping of a file
> Skipping repository 'x2go-extras' because of the above error.
> File '/repodata/repomd.xml' not found on medium
> 'http://packages.x2go.org/sle/11.3/main/x86_64'
> 
> Abort, retry, ignore? [a/r/i/?] (a): i
> Error retrieving metadata for 'x2go-release':
> SKIP request: User-requested skipping of a file
> Skipping repository 'x2go-release' because of the above error.
> Some of the repositories have not been refreshed because of an error.
> 
> zypper repos
> # | Alias                                            | Name
> | Enabled | Refresh
> --+--------------------------------------------------+----------------------
> ----------------------------+---------+--------
> 1 | SUSE-Linux-Enterprise-Server-11-SP3 11.3.3-1.138 |
> SUSE-Linux-Enterprise-Server-11-SP3 11.3.3-1.138 | Yes     | No
> 2 | devel_languages_perl                             | perl modules
> (SLE_11_SP3)                        | Yes     | No
> 3 | x2go-extras                                      | x2go-extras
> | Yes     | No
> 4 | x2go-release                                     | x2go-release
> | Yes     | No
> 
> 
> zypper rr x2go-extras
> Removing repository 'x2go-extras' [done]
> Repository 'x2go-extras' has been removed.
> 
> zypper rr x2go-release
> Removing repository 'x2go-release' [done]
> Repository 'x2go-release' has been removed.
> 
> zypper ar http://packages.x2go.org/sle/11.3/extras x2go-extras
> Adding repository 'x2go-extras' [done]
> Repository 'x2go-extras' successfully added
> Enabled: Yes
> Autorefresh: No
> GPG check: Yes
> URI: http://packages.x2go.org/sle/11.3/extras
> 
> zypper ar http://packages.x2go.org/sle/11.3/main x2go-release
> Adding repository 'x2go-release' [done]
> Repository 'x2go-release' successfully added
> Enabled: Yes
> Autorefresh: No
> GPG check: Yes
> URI: http://packages.x2go.org/sle/11.3/main
> 
> zypper search x2go
> Building repository 'x2go-extras' cache [done]
> Building repository 'x2go-release' cache [done]
> Loading repository data...
> Reading installed packages...
> 
> S | Name                   | Summary                                      |
> Type
> --+------------------------+----------------------------------------------+-
> ----------
>   | X2Go SLE:11:SP3 extras | X2Go extras Repository for SLE:11:SP3        |
> product
>   | X2Go SLE:11:SP3 main   | X2Go main Repository for SLE:11:SP3          |
> product
>   | cups-x2go              | CUPS backend for printing from X2Go          |
> package
>   | cups-x2go              | CUPS backend for printing from X2Go          |
> srcpackage
>   | x2goagent              | X2Go Agent                                   |
> package
>   | x2godesktopsharing     | Share X11 desktops with other users via X2Go |
> package
>   | x2godesktopsharing     | Share X11 desktops with other users via X2Go |
> srcpackage
>   | x2goserver             | X2Go Server                                  |
> package
>   | x2goserver             | X2Go Server                                  |
> srcpackage
>   | x2goserver-extensions  | X2Go Server (extension support)              |
> package
>   | x2goserver-fmbindings  | X2Go Server (file manager bindings)          |
> package
>   | x2goserver-printing    | X2Go Server (printing support)               |
> package
>   | x2goserver-xsession    | X2Go Server (Xsession runner)                |
> package

Okay, good!


> zypper install x2goserver
> Loading repository data...
> Reading installed packages...
> Resolving package dependencies...
> 
> The following NEW packages are going to be installed:
>   libNX_X11-6 libNX_Xcomposite1 libNX_Xdamage1 libNX_Xdmcp6 libNX_Xext6
> libNX_Xfixes3 libNX_Xinerama1 libNX_Xpm4 libNX_Xrandr2 libNX_Xrender1
>   libNX_Xtst6 libXcomp3 libXcompext3 libXcompshad3 nx-libs nxagent
> perl-DBD-SQLite pwgen sshfs x2goagent x2goserver x2goserver-extensions
>   x2goserver-xsession
> 
> The following packages are not supported by their vendor:
>   libNX_X11-6 libNX_Xcomposite1 libNX_Xdamage1 libNX_Xdmcp6 libNX_Xext6
> libNX_Xfixes3 libNX_Xinerama1 libNX_Xpm4 libNX_Xrandr2 libNX_Xrender1
>   libNX_Xtst6 libXcomp3 libXcompext3 libXcompshad3 nx-libs nxagent pwgen
> sshfs x2goagent x2goserver x2goserver-extensions x2goserver-xsession
> 
> 23 new packages to install.
> Overall download size: 2.9 MiB. After the operation, additional 8.6 MiB will
> be used.
> Continue? [y/n/?] (y): y
> Retrieving package pwgen-2.06-90.3.x86_64 (1/23), 19.0 KiB (39.0 KiB
> unpacked)
> Retrieving: pwgen-2.06-90.3.x86_64.rpm [done]
> Retrieving package sshfs-2.4-5.1.x86_64 (2/23), 43.0 KiB (89.0 KiB unpacked)
> Retrieving: sshfs-2.4-5.1.x86_64.rpm [done]
> Retrieving package nx-libs-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64
> (3/23), 15.0 KiB (30.0 KiB unpacked)
> Retrieving: nx-libs-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package libXcomp3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64
> (4/23), 338.0 KiB (1.2 MiB unpacked)
> Retrieving: libXcomp3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> libNX_Xdmcp6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (5/23), 12.0
> KiB (27.0 KiB unpacked)
> Retrieving: libNX_Xdmcp6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> libNX_X11-6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (6/23), 516.0
> KiB (1.2 MiB unpacked)
> Retrieving: libNX_X11-6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> libXcompext3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (7/23), 35.0
> KiB (93.0 KiB unpacked)
> Retrieving: libXcompext3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> libNX_Xext6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (8/23), 28.0 KiB
> (85.0 KiB unpacked)
> Retrieving: libNX_Xext6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> libNX_Xtst6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (9/23), 13.0 KiB
> (32.0 KiB unpacked)
> Retrieving: libNX_Xtst6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> libNX_Xrender1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (10/23), 20.0
> KiB (49.0 KiB unpacked)
> Retrieving:
> libNX_Xrender1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm [done]
> Retrieving package
> libNX_Xpm4-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (11/23), 35.0 KiB
> (80.0 KiB unpacked)
> Retrieving: libNX_Xpm4-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> libNX_Xinerama1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (12/23), 8.0
> KiB (14.0 KiB unpacked)
> Retrieving:
> libNX_Xinerama1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm [done]
> Retrieving package
> libNX_Xfixes3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (13/23), 11.0
> KiB (27.0 KiB unpacked)
> Retrieving:
> libNX_Xfixes3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm [done]
> Retrieving package
> libNX_Xdamage1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (14/23), 8.0
> KiB (13.0 KiB unpacked)
> Retrieving:
> libNX_Xdamage1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm [done]
> Retrieving package
> libNX_Xrandr2-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (15/23), 10.0
> KiB (18.0 KiB unpacked)
> Retrieving:
> libNX_Xrandr2-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm [done]
> Retrieving package
> libNX_Xcomposite1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (16/23),
> 8.0 KiB (13.0 KiB unpacked)
> Retrieving:
> libNX_Xcomposite1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm [done]
> Retrieving package
> libXcompshad3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (17/23), 34.0
> KiB (91.0 KiB unpacked)
> Retrieving:
> libXcompshad3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm [done]
> Retrieving package nxagent-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64
> (18/23), 1.6 MiB (5.0 MiB unpacked)
> Retrieving: nxagent-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done (555.0 KiB/s)]
> Retrieving package x2goagent-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64
> (19/23), 12.0 KiB (37.0 KiB unpacked)
> Retrieving: x2goagent-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> x2goserver-xsession-4.0.1.20-0.0x2go1.1.git20161129.1125.main.x86_64
> (20/23), 29.0 KiB (83.0 KiB unpacked)
> Retrieving:
> x2goserver-xsession-4.0.1.20-0.0x2go1.1.git20161129.1125.main.x86_64.rpm
> [done]
> Retrieving package
> x2goserver-extensions-4.0.1.20-0.0x2go1.1.git20161129.1125.main.x86_64
> (21/23), 30.0 KiB (79.0 KiB unpacked)
> Retrieving:
> x2goserver-extensions-4.0.1.20-0.0x2go1.1.git20161129.1125.main.x86_64.rpm
> [done]
> Retrieving package
> x2goserver-4.0.1.20-0.0x2go1.1.git20161129.1125.main.x86_64 (22/23), 89.0
> KiB (314.0 KiB unpacked)
> Retrieving: x2goserver-4.0.1.20-0.0x2go1.1.git20161129.1125.main.x86_64.rpm
> [done]
> Installing: perl-DBD-SQLite-1.14-11.14 [done]
> Installing: pwgen-2.06-90.3 [error]
> Installation of pwgen-2.06-90.3 failed:
> (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error:
> /var/cache/zypp/packages/x2go-extras/x86_64/pwgen-2.06-90.3.x86_64.rpm:
> Header V4 RSA/SHA1 signature: BAD, key ID 9c6b0b2b
> error:
> /var/cache/zypp/packages/x2go-extras/x86_64/pwgen-2.06-90.3.x86_64.rpm
> cannot be installed
> 
> 
> Abort, retry, ignore? [a/r/i] (a):

The key is not the problem, you obviously have it in your RPM DB already, as
otherwise rpm would have given you a "NOKEY" error.

Checking via "rpm -v --checksign" on the build server reveals:

pwgen-2.06-90.3.x86_64.rpm:
    Header V4 RSA/SHA1 Signature, key ID 9c6b0b2b: OK
    Header SHA1 digest: OK (693079e6da9cde1e9e5418c8a90d47ca4b89cf3a)
    V4 RSA/SHA1 Signature, key ID 9c6b0b2b: OK
    MD5 digest: OK (c680b2bf2f22c0f8e4e29a81efb326dc)

I suspect (also from other resources I found on the net), that SLE 11.3 does not
support V4 signatures, though.

I have thus resigned only the pwgen package for now. Can you please retry
installing x2goserver? It will definitely fail at some package again, but I want
to see if pwgen now looks clean to your rpm binary (i.e., if it doesn't complain
about it any longer.) If switching to V3 signatures with the SHA256 hash
algorithm, I'll resign all packages on 11.3 and 11.2.


Side note: please remember to include 1111@bugs.x2go.org when you're replying,
so that your answer makes it into the bugreport.



Mihai

[signature.asc (application/pgp-signature, attachment)]

Information forwarded to x2go-dev@lists.x2go.org, x2go-dev@lists.x2go.org:
Bug#1111; Package packages.x2go.org. (Fri, 09 Dec 2016 06:00:01 GMT) (full text, mbox, link).


Acknowledgement sent to "Olaf Matthaei" <o.matthaei@narz-avn.de>:
Extra info received and forwarded to list. Copy sent to x2go-dev@lists.x2go.org. (Fri, 09 Dec 2016 06:00:02 GMT) (full text, mbox, link).


Message #28 received at 1111@bugs.x2go.org (full text, mbox, reply):

From: "Olaf Matthaei" <o.matthaei@narz-avn.de>
To: "'Mihai Moldovan'" <ionic@ionic.de>
Cc: <1111@bugs.x2go.org>
Subject: AW: Package: x2goserver Version: 4.0.1.19-0 SLES 11.3 - x2go-extras - pwgen-2.06-90.3 - Header V4 RSA/SHA1 signature: BAD, key ID
Date: Fri, 9 Dec 2016 06:49:32 +0100
Hi,
next try with zypper and with rpm for pwgen:
# rpm -Uhvvvv pwgen-2.06-90.3.x86_64.rpm
D: ============== pwgen-2.06-90.3.x86_64.rpm
D: Expected size:        18988 = lead(96)+sigs(772)+pad(4)+data(18116)
D:   Actual size:        18988
D: opening  db environment /var/lib/rpm/Packages create:cdb:mpool:private
D: opening  db index       /var/lib/rpm/Packages rdonly mode=0x0
D: locked   db index       /var/lib/rpm/Packages
D: opening  db index       /var/lib/rpm/Pubkeys rdonly:nofsync mode=0x0
D:  read h#     175 Header sanity check: OK
D: ========== RSA pubkey id f4a7678c 9c6b0b2b (h#175)
error: pwgen-2.06-90.3.x86_64.rpm: Header V3 RSA/SHA256 signature: BAD, key
ID 9c6b0b2b
error: pwgen-2.06-90.3.x86_64.rpm cannot be installed
D: found 0 source and 0 binary packages
D: closed   db index       /var/lib/rpm/Pubkeys
D: closed   db index       /var/lib/rpm/Packages
D: closed   db environment /var/lib/rpm/Packages
D: May free Score board((nil))

# zypper refresh
Retrieving repository 'perl modules (SLE_11_SP3)' metadata [done]
Building repository 'perl modules (SLE_11_SP3)' cache [done]
Retrieving repository 'x2go-extras' metadata [done]
Building repository 'x2go-extras' cache [done]
Repository 'x2go-release' is up to date.
All repositories have been refreshed.
 
zypper install x2goserver
Loading repository data...
Reading installed packages...
Resolving package dependencies...
The following NEW packages are going to be installed:
  libNX_X11-6 libNX_Xcomposite1 libNX_Xdamage1 libNX_Xdmcp6 libNX_Xext6
  libNX_Xfixes3 libNX_Xinerama1 libNX_Xpm4 libNX_Xrandr2 libNX_Xrender1
  libNX_Xtst6 libXcomp3 libXcompext3 libXcompshad3 nx-libs nxagent pwgen
sshfs
  x2goagent x2goserver x2goserver-extensions x2goserver-xsession
The following packages are not supported by their vendor:
  libNX_X11-6 libNX_Xcomposite1 libNX_Xdamage1 libNX_Xdmcp6 libNX_Xext6
  libNX_Xfixes3 libNX_Xinerama1 libNX_Xpm4 libNX_Xrandr2 libNX_Xrender1
  libNX_Xtst6 libXcomp3 libXcompext3 libXcompshad3 nx-libs nxagent pwgen
sshfs
  x2goagent x2goserver x2goserver-extensions x2goserver-xsession
22 new packages to install.
Overall download size: 2.9 MiB. After the operation, additional 8.5 MiB will
be
used.
Continue? [y/n/?] (y): y
Retrieving package pwgen-2.06-90.3.x86_64 (1/22), 19.0 KiB (39.0 KiB
unpacked)
Retrieving: pwgen-2.06-90.3.x86_64.rpm [done]
Installing: pwgen-2.06-90.3 [error]
Installation of pwgen-2.06-90.3 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error:
/var/cache/zypp/packages/x2go-extras/x86_64/pwgen-2.06-90.3.x86_64.rpm:
Header V3 RSA/SHA256 signature: BAD, key ID 9c6b0b2b
error:
/var/cache/zypp/packages/x2go-extras/x86_64/pwgen-2.06-90.3.x86_64.rpm
cannot be installed

Abort, retry, ignore? [a/r/i] (a): 
i
Installing: sshfs-2.4-5.1 [error]
Installation of sshfs-2.4-5.1 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error:
/var/cache/zypp/packages/x2go-extras/x86_64/sshfs-2.4-5.1.x86_64.rpm: Header
V4 RSA/SHA1 signature: BAD, key ID 9c6b0b2b
error: /var/cache/zypp/packages/x2go-extras/x86_64/sshfs-2.4-5.1.x86_64.rpm
cannot be installed

Abort, retry, ignore? [a/r/i] (a): i
Installing: nx-libs-3.5.0.32-0.0x2go1.1.git20161129.734.main [done]
Installing: libXcomp3-3.5.0.32-0.0x2go1.1.git20161129.734.main [error]
Installation of libXcomp3-3.5.0.32-0.0x2go1.1.git20161129.734.main failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error:
/var/cache/zypp/packages/x2go-release/x86_64/libXcomp3-3.5.0.32-0.0x2go1.1.g
it20161129.734.main.x86_64.rpm: Header V4 RSA/SHA1 signature: BAD, key ID
9c6b0b2b
error:
/var/cache/zypp/packages/x2go-release/x86_64/libXcomp3-3.5.0.32-0.0x2go1.1.g
it20161129.734.main.x86_64.rpm cannot be installed
 
 

-----Ursprüngliche Nachricht-----
Von: Mihai Moldovan [mailto:ionic@ionic.de] 
Gesendet: Mittwoch, 7. Dezember 2016 19:46
An: Olaf Matthaei
Cc: 1111@bugs.x2go.org
Betreff: Re: Package: x2goserver Version: 4.0.1.19-0 SLES 11.3 - x2go-extras
- pwgen-2.06-90.3 - Header V4 RSA/SHA1 signature: BAD, key ID


On 07.12.2016 06:43 AM, Olaf Matthaei wrote:
> What do you mean with "this time *without* referring to the 
> architecture type" ? I followed the way in the wiki.

The old behavior was to have one repository for every architecture, but
that's not the "SUSE standard repository layout". Instead, SUSE uses one
repository for all architectures.

The information in the wiki is fine and already updated. If you take a close
look at your last email/command output, you'll notice that the repository
previously had x86_64 in the URL while it now doesn't.


> Here are the result:
> 
> zypper refresh
> Retrieving repository 'perl modules (SLE_11_SP3)' metadata [done] 
> Building repository 'perl modules (SLE_11_SP3)' cache [done] File 
> '/repodata/repomd.xml' not found on medium 
> 'http://packages.x2go.org/sle/11.3/extras/x86_64'
> 
> Abort, retry, ignore? [a/r/i/?] (a): r
> File '/repodata/repomd.xml' not found on medium 
> 'http://packages.x2go.org/sle/11.3/extras/x86_64'
> 
> Abort, retry, ignore? [a/r/i/?] (a): i
> Error retrieving metadata for 'x2go-extras':
> SKIP request: User-requested skipping of a file
> Skipping repository 'x2go-extras' because of the above error. File 
> '/repodata/repomd.xml' not found on medium 
> 'http://packages.x2go.org/sle/11.3/main/x86_64'
> 
> Abort, retry, ignore? [a/r/i/?] (a): i
> Error retrieving metadata for 'x2go-release':
> SKIP request: User-requested skipping of a file
> Skipping repository 'x2go-release' because of the above error. Some of 
> the repositories have not been refreshed because of an error.
> 
> zypper repos
> # | Alias                                            | Name
> | Enabled | Refresh
> --+--------------------------------------------------+----------------
> --+--------------------------------------------------+------
> ----------------------------+---------+--------
> 1 | SUSE-Linux-Enterprise-Server-11-SP3 11.3.3-1.138 |
> SUSE-Linux-Enterprise-Server-11-SP3 11.3.3-1.138 | Yes     | No
> 2 | devel_languages_perl                             | perl modules
> (SLE_11_SP3)                        | Yes     | No
> 3 | x2go-extras                                      | x2go-extras
> | Yes     | No
> 4 | x2go-release                                     | x2go-release
> | Yes     | No
> 
> 
> zypper rr x2go-extras
> Removing repository 'x2go-extras' [done]
> Repository 'x2go-extras' has been removed.
> 
> zypper rr x2go-release
> Removing repository 'x2go-release' [done]
> Repository 'x2go-release' has been removed.
> 
> zypper ar http://packages.x2go.org/sle/11.3/extras x2go-extras Adding 
> repository 'x2go-extras' [done] Repository 'x2go-extras' successfully 
> added
> Enabled: Yes
> Autorefresh: No
> GPG check: Yes
> URI: http://packages.x2go.org/sle/11.3/extras
> 
> zypper ar http://packages.x2go.org/sle/11.3/main x2go-release Adding 
> repository 'x2go-release' [done] Repository 'x2go-release' 
> successfully added
> Enabled: Yes
> Autorefresh: No
> GPG check: Yes
> URI: http://packages.x2go.org/sle/11.3/main
> 
> zypper search x2go
> Building repository 'x2go-extras' cache [done]
> Building repository 'x2go-release' cache [done]
> Loading repository data...
> Reading installed packages...
> 
> S | Name                   | Summary
|
> Type
>
--+------------------------+----------------------------------------------+-
> ----------
>   | X2Go SLE:11:SP3 extras | X2Go extras Repository for SLE:11:SP3
|
> product
>   | X2Go SLE:11:SP3 main   | X2Go main Repository for SLE:11:SP3
|
> product
>   | cups-x2go              | CUPS backend for printing from X2Go
|
> package
>   | cups-x2go              | CUPS backend for printing from X2Go
|
> srcpackage
>   | x2goagent              | X2Go Agent
|
> package
>   | x2godesktopsharing     | Share X11 desktops with other users via X2Go
|
> package
>   | x2godesktopsharing     | Share X11 desktops with other users via X2Go
|
> srcpackage
>   | x2goserver             | X2Go Server
|
> package
>   | x2goserver             | X2Go Server
|
> srcpackage
>   | x2goserver-extensions  | X2Go Server (extension support)
|
> package
>   | x2goserver-fmbindings  | X2Go Server (file manager bindings)
|
> package
>   | x2goserver-printing    | X2Go Server (printing support)
|
> package
>   | x2goserver-xsession    | X2Go Server (Xsession runner)
|
> package

Okay, good!


> zypper install x2goserver
> Loading repository data...
> Reading installed packages...
> Resolving package dependencies...
> 
> The following NEW packages are going to be installed:
>   libNX_X11-6 libNX_Xcomposite1 libNX_Xdamage1 libNX_Xdmcp6 
> libNX_Xext6 libNX_Xfixes3 libNX_Xinerama1 libNX_Xpm4 libNX_Xrandr2
libNX_Xrender1
>   libNX_Xtst6 libXcomp3 libXcompext3 libXcompshad3 nx-libs nxagent 
> perl-DBD-SQLite pwgen sshfs x2goagent x2goserver x2goserver-extensions
>   x2goserver-xsession
> 
> The following packages are not supported by their vendor:
>   libNX_X11-6 libNX_Xcomposite1 libNX_Xdamage1 libNX_Xdmcp6 
> libNX_Xext6 libNX_Xfixes3 libNX_Xinerama1 libNX_Xpm4 libNX_Xrandr2
libNX_Xrender1
>   libNX_Xtst6 libXcomp3 libXcompext3 libXcompshad3 nx-libs nxagent 
> pwgen sshfs x2goagent x2goserver x2goserver-extensions 
> x2goserver-xsession
> 
> 23 new packages to install.
> Overall download size: 2.9 MiB. After the operation, additional 8.6 
> MiB will be used. Continue? [y/n/?] (y): y
> Retrieving package pwgen-2.06-90.3.x86_64 (1/23), 19.0 KiB (39.0 KiB
> unpacked)
> Retrieving: pwgen-2.06-90.3.x86_64.rpm [done]
> Retrieving package sshfs-2.4-5.1.x86_64 (2/23), 43.0 KiB (89.0 KiB
unpacked)
> Retrieving: sshfs-2.4-5.1.x86_64.rpm [done]
> Retrieving package nx-libs-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64
> (3/23), 15.0 KiB (30.0 KiB unpacked)
> Retrieving: nx-libs-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
libXcomp3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64
> (4/23), 338.0 KiB (1.2 MiB unpacked)
> Retrieving: libXcomp3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> libNX_Xdmcp6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (5/23), 12.0
> KiB (27.0 KiB unpacked)
> Retrieving:
libNX_Xdmcp6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> libNX_X11-6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (6/23), 516.0
> KiB (1.2 MiB unpacked)
> Retrieving:
libNX_X11-6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> libXcompext3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (7/23), 35.0
> KiB (93.0 KiB unpacked)
> Retrieving:
libXcompext3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> libNX_Xext6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (8/23), 28.0
KiB
> (85.0 KiB unpacked)
> Retrieving:
libNX_Xext6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> libNX_Xtst6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (9/23), 13.0
KiB
> (32.0 KiB unpacked)
> Retrieving:
libNX_Xtst6-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> libNX_Xrender1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (10/23),
20.0
> KiB (49.0 KiB unpacked)
> Retrieving:
> libNX_Xrender1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm [done]
> Retrieving package
> libNX_Xpm4-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (11/23), 35.0
KiB
> (80.0 KiB unpacked)
> Retrieving: libNX_Xpm4-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> libNX_Xinerama1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (12/23),
8.0
> KiB (14.0 KiB unpacked)
> Retrieving:
> libNX_Xinerama1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm [done]
> Retrieving package
> libNX_Xfixes3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (13/23),
11.0
> KiB (27.0 KiB unpacked)
> Retrieving:
> libNX_Xfixes3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm [done]
> Retrieving package
> libNX_Xdamage1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (14/23),
8.0
> KiB (13.0 KiB unpacked)
> Retrieving:
> libNX_Xdamage1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm [done]
> Retrieving package
> libNX_Xrandr2-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (15/23),
10.0
> KiB (18.0 KiB unpacked)
> Retrieving:
> libNX_Xrandr2-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm [done]
> Retrieving package
> libNX_Xcomposite1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (16/23),
> 8.0 KiB (13.0 KiB unpacked)
> Retrieving:
> libNX_Xcomposite1-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
[done]
> Retrieving package
> libXcompshad3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64 (17/23),
34.0
> KiB (91.0 KiB unpacked)
> Retrieving:
> libXcompshad3-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm [done]
> Retrieving package nxagent-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64
> (18/23), 1.6 MiB (5.0 MiB unpacked)
> Retrieving: nxagent-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done (555.0 KiB/s)]
> Retrieving package
x2goagent-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64
> (19/23), 12.0 KiB (37.0 KiB unpacked)
> Retrieving: x2goagent-3.5.0.32-0.0x2go1.1.git20161129.734.main.x86_64.rpm
> [done]
> Retrieving package
> x2goserver-xsession-4.0.1.20-0.0x2go1.1.git20161129.1125.main.x86_64
> (20/23), 29.0 KiB (83.0 KiB unpacked)
> Retrieving:
> x2goserver-xsession-4.0.1.20-0.0x2go1.1.git20161129.1125.main.x86_64.rpm
> [done]
> Retrieving package
> x2goserver-extensions-4.0.1.20-0.0x2go1.1.git20161129.1125.main.x86_64
> (21/23), 30.0 KiB (79.0 KiB unpacked)
> Retrieving:
> x2goserver-extensions-4.0.1.20-0.0x2go1.1.git20161129.1125.main.x86_64.rpm
> [done]
> Retrieving package
> x2goserver-4.0.1.20-0.0x2go1.1.git20161129.1125.main.x86_64 (22/23), 89.0
> KiB (314.0 KiB unpacked)
> Retrieving:
x2goserver-4.0.1.20-0.0x2go1.1.git20161129.1125.main.x86_64.rpm
> [done]
> Installing: perl-DBD-SQLite-1.14-11.14 [done]
> Installing: pwgen-2.06-90.3 [error]
> Installation of pwgen-2.06-90.3 failed:
> (with --nodeps --force) Error: Subprocess failed. Error: RPM failed:
error:
> /var/cache/zypp/packages/x2go-extras/x86_64/pwgen-2.06-90.3.x86_64.rpm:
> Header V4 RSA/SHA1 signature: BAD, key ID 9c6b0b2b
> error:
> /var/cache/zypp/packages/x2go-extras/x86_64/pwgen-2.06-90.3.x86_64.rpm
> cannot be installed
> 
> 
> Abort, retry, ignore? [a/r/i] (a):

The key is not the problem, you obviously have it in your RPM DB already, as
otherwise rpm would have given you a "NOKEY" error.

Checking via "rpm -v --checksign" on the build server reveals:

pwgen-2.06-90.3.x86_64.rpm:
    Header V4 RSA/SHA1 Signature, key ID 9c6b0b2b: OK
    Header SHA1 digest: OK (693079e6da9cde1e9e5418c8a90d47ca4b89cf3a)
    V4 RSA/SHA1 Signature, key ID 9c6b0b2b: OK
    MD5 digest: OK (c680b2bf2f22c0f8e4e29a81efb326dc)

I suspect (also from other resources I found on the net), that SLE 11.3 does
not support V4 signatures, though.

I have thus resigned only the pwgen package for now. Can you please retry
installing x2goserver? It will definitely fail at some package again, but I
want to see if pwgen now looks clean to your rpm binary (i.e., if it doesn't
complain about it any longer.) If switching to V3 signatures with the SHA256
hash algorithm, I'll resign all packages on 11.3 and 11.2.


Side note: please remember to include 1111@bugs.x2go.org when you're
replying, so that your answer makes it into the bugreport.



Mihai



Information forwarded to x2go-dev@lists.x2go.org, x2go-dev@lists.x2go.org:
Bug#1111; Package packages.x2go.org. (Fri, 09 Dec 2016 08:35:02 GMT) (full text, mbox, link).


Acknowledgement sent to Mihai Moldovan <ionic@ionic.de>:
Extra info received and forwarded to list. Copy sent to x2go-dev@lists.x2go.org. (Fri, 09 Dec 2016 08:35:02 GMT) (full text, mbox, link).


Message #33 received at 1111@bugs.x2go.org (full text, mbox, reply):

From: Mihai Moldovan <ionic@ionic.de>
To: Olaf Matthaei <o.matthaei@narz-avn.de>
Cc: 1111@bugs.x2go.org
Subject: Re: SLES 11.3 - x2go-extras - pwgen-2.06-90.3 - Header V4 RSA/SHA1 signature: BAD, key ID
Date: Fri, 9 Dec 2016 09:31:33 +0100
[Message part 1 (text/plain, inline)]
Control: close -1

When did you try doing all of this? I found out what the real problem was - SLES
11 SP3 and lower don't support RSA keys with a key size higher than 1024 bits
for RPM signatures. Our main signing key has a key size of 2048 bits. Thus, I've
changed all SLE 11 repositories to use the 1024-bit EPEL5-compatibility key
(both for signing repository metadata and the packages themselves) in the
packages and the corresponding archive repositories yesterday evening.

After that, all packages installed successfully while trying to install
x2goserver in my SLES 11 SP3 VM.

Please run "zypper clean" and "zypper refresh" to delete cached files and update
the local repository metadata on your machine. Afterwards, installing x2goserver
should work fine.

Closing up the bug report for now. Though, please give me feedback whether it
worked now or is still failing.



Mihai

[signature.asc (application/pgp-signature, attachment)]

Marked Bug as done Request was from Mihai Moldovan <ionic@ionic.de> to 1111-submit@bugs.x2go.org. (Fri, 09 Dec 2016 08:35:02 GMT) (full text, mbox, link).


Notification sent to "Olaf Matthaei" <o.matthaei@narz-avn.de>:
Bug acknowledged by developer. (Fri, 09 Dec 2016 08:35:02 GMT) (full text, mbox, link).


Information forwarded to x2go-dev@lists.x2go.org, x2go-dev@lists.x2go.org:
Bug#1111; Package packages.x2go.org. (Mon, 12 Dec 2016 07:25:02 GMT) (full text, mbox, link).


Acknowledgement sent to "Olaf Matthaei" <o.matthaei@narz-avn.de>:
Extra info received and forwarded to list. Copy sent to x2go-dev@lists.x2go.org. (Mon, 12 Dec 2016 07:25:02 GMT) (full text, mbox, link).


Message #42 received at 1111@bugs.x2go.org (full text, mbox, reply):

From: "Olaf Matthaei" <o.matthaei@narz-avn.de>
To: "'Mihai Moldovan'" <ionic@ionic.de>
Cc: <1111@bugs.x2go.org>
Subject: AW: SLES 11.3 - x2go-extras - pwgen-2.06-90.3 - Header V4 RSA/SHA1 signature: BAD, key ID
Date: Mon, 12 Dec 2016 08:21:55 +0100
Thanks, no it works fine.

-----Ursprüngliche Nachricht-----
Von: Mihai Moldovan [mailto:ionic@ionic.de] 
Gesendet: Freitag, 9. Dezember 2016 09:32
An: Olaf Matthaei
Cc: 1111@bugs.x2go.org
Betreff: Re: SLES 11.3 - x2go-extras - pwgen-2.06-90.3 - Header V4 RSA/SHA1
signature: BAD, key ID


Control: close -1

When did you try doing all of this? I found out what the real problem was -
SLES 11 SP3 and lower don't support RSA keys with a key size higher than
1024 bits for RPM signatures. Our main signing key has a key size of 2048
bits. Thus, I've changed all SLE 11 repositories to use the 1024-bit
EPEL5-compatibility key (both for signing repository metadata and the
packages themselves) in the packages and the corresponding archive
repositories yesterday evening.

After that, all packages installed successfully while trying to install
x2goserver in my SLES 11 SP3 VM.

Please run "zypper clean" and "zypper refresh" to delete cached files and
update the local repository metadata on your machine. Afterwards, installing
x2goserver should work fine.

Closing up the bug report for now. Though, please give me feedback whether
it worked now or is still failing.



Mihai



Bug archived. Request was from Debbugs Internal Request <owner@bugs.x2go.org> to internal_control@bugs.x2go.org. (Tue, 10 Jan 2017 06:24:01 GMT) (full text, mbox, link).


Send a report that this bug log contains spam.


X2Go Developers <owner@bugs.x2go.org>. Last modified: Sun Dec 8 02:13:53 2019; Machine Name: ymir.das-netzwerkteam.de

X2Go Bug tracking system

Debbugs is free software and licensed under the terms of the GNU Public License version 2. The current version can be obtained from https://bugs.debian.org/debbugs-source/.

Copyright © 1999 Darren O. Benham, 1997,2003 nCipher Corporation Ltd, 1994-97 Ian Jackson, 2005-2017 Don Armstrong, and many other contributors.